Jenkins和Behat简介

Hi i got some problem with my behat and jenkins configuration.

I would like run Behat test in a jenkins build with this configuration :

/behat.yml

default:
    extensions:
        Behat\MinkExtension\Extension:
            base_url: 'http://symfony.localvm/app_dev.php'
            browser_name: 'firefox'
            javascript_session: 'selenium2'
            goutte: ~
            zombie: ~
            selenium2: ~

jenkins:
    formatter:
        name: progress,junit,html
        parameters:
            output_path: ,app/build/behat,app/build/behat.html
    extensions:
        Behat\MinkExtension\Extension:
            base_url: 'http://symfony.localvm/app_dev.php'
            javascript_session: selenium2

And in my build.xml

    <target name="behat" description="Run behat test">
        <exec executable="../bin/behat" failonerror="false" inputstring=""></exec>
    </target>

(My composer)

    "require-dev": {
        "behat/behat": "2.4.*@stable",
        "behat/mink-extension": "@dev",
        "behat/mink-goutte-driver": "@dev",
        "fabpot/goutte": "@dev",
        "behat/mink-sahi-driver": "@dev",
        "behat/mink-zombie-driver": "@dev",
        "behat/mink-selenium2-driver": "@dev"
    },

But Jenkins doesn't use the jenkins profile in behat.yml, how I tell to Jenkins : "Hey Jenkins, user the jenkins profile please!" in the configuratio ? Or Jenkins must do it alone?

If I push the formatter parameter in the default profile and use the command line the .xml files are well generated.

Thx for help

查看全部
duan1933
duan1933
2013/07/25 19:50
  • jenkins
  • php
  • symfony
  • 点赞
  • 收藏
  • 回答
    私信
满意答案
查看全部

1个回复