dongtao9158
2014-04-14 06:09
浏览 46
已采纳

WordPress没有在本地环境中运行,为Google应用引擎开发

I have installed the WordPress, MySQL,PHP SDK on Linux (Ubuntu 13.10) and configure everything according to google-appengine-help-page

But, I can't access the wordpress in local environment also after the deployment.

when I run the following, in the terminal, from my home directory, where APPLICATION_DIRECTORY IS prsent

google_appengine/dev_appserver.py APPLICATION_DIRECTORY

I get error , the output is....

INFO     2014-04-14 05:55:59,407 sdk_update_checker.py:242] Checking for updates to the SDK.
INFO     2014-04-14 05:56:00,904 sdk_update_checker.py:258] Update check failed: HTTP Error 404: Not Found
INFO     2014-04-14 05:56:00,927 api_server.py:171] Starting API server at: http://localhost:44134
INFO     2014-04-14 05:56:00,952 dispatcher.py:182] Starting module "default" running at: http://localhost:8080
ERROR    2014-04-14 05:56:00,953 php_runtime.py:223] The PHP runtime is not available
Traceback (most recent call last):
  File "/home/hkc/google_appengine/google/appengine/tools/devappserver2/php_runtime.py", line 219, in new_instance
    self._check_environment(php_executable_path)
  File "/home/hkc/google_appengine/google/appengine/tools/devappserver2/php_runtime.py", line 148, in _check_environment
    'flag (%s) does not exist.' % php_executable_path)
_PHPBinaryError: The path specified with the --php_executable_path flag () does not exist.
INFO     2014-04-14 05:56:00,954 admin_server.py:117] Starting admin server at: http://localhost:8000

The error shows that php_executable_path does not exist. I have the php-5.4.25, google-appengine, APPLICATION_DIRECTORY all under my, home directory.

When I open localhost:8080 (added http:// before that), it shows,

The path specified with the --php_executable_path flag () does not exist.

How can I correct this ?

图片转代码服务由CSDN问答提供 功能建议

我在Linux上安装了WordPress,MySQL,PHP SDK(Ubuntu 13.10)并根据 google-appengine-help-page

但是,我可以 在部署之后也不能在本地环境中访问wordpress。

当我在终端中从我的主目录运行以下内容,其中APPLICATION_DIRECTORY是prsent \ n

  google_appengine / dev_appserver.py APPLICATION_DIRECTORY 
   
 
 

我收到错误,输出是.... < pre> INFO 2014-04-14 05:55:59,407 sdk_update_checker.py:242]检查SDK的更新。 INFO 2014-04-14 05:56:00,904 sdk_update_checker.py:258]更新检查失败 :HTTP错误404:未找到 INFO 2014-04-14 05:56:00,927 api_server.py:171]启动API服务器:http:// localhost:44134 INFO 2014-04-14 05:56:00,952调度程序 .py:182]启动模块“def ault“运行于:http:// localhost:8080 ERROR 2014-04-14 05:56:00,953 php_runtime.py:223] PHP运行时不可用 Traceback(最近一次调用最后一次): 文件”/ home / hkc / google_appengine / google / appengine / tools / devappserver2 / php_runtime.py“,第219行,在new_instance self._check_environment(php_executable_path) 文件”/ home / hkc / google_appengine / google / appengine / tools / devappserver2 /php_runtime.py“,第148行,_check_environment '标志(%s)不存在。” %php_executable_path) _PHPBinaryError:使用--php_executable_path标志()指定的路径不存在。 INFO 2014-04-14 05:56:00,954 admin_server.py:117]启动管理服务器:http:// localhost: 8000

错误显示php_executable_path不存在。 我在我的主目录下有php-5.4.25,google-appengine,APPLICATION_DIRECTORY。

当我打开localhost:8080(之前添加了http://)时,它显示 ,

 使用--php_executable_path标志()指定的路径不存在。
   
 
 

我该怎么办? 纠正这个?

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dongzhilian0188 2014-04-15 09:04
    已采纳

    The --php_executable_path should point to a php-cgi installed with Ubuntu. This is likely somewhere like /usr/bin/php5-cgi

    已采纳该答案
    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题