dongqi8114
dongqi8114
2014-02-08 10:05

Vim在编辑php文件时烦人的自动版本

已采纳

Consider this scenario :

function name() {
   $query = "select { some-value ";
}

Now, While typing the closing curly brace }, the line automatically indents to the left side like this :

function name() {
$query = "select { some-value }";
}

This is very much annoying. Each time, I have to indent it once again to the right. Secondly, consider this :

Class Name {
    $var = 'val'
}

Now, when I type semicolon ;, the line automatically indents to the left like this :

Class Name {
$var = 'val';
}

I also tried downloading the php-correct-indenting plugin and putting it inside the ~/.vim/indent/ directory, but still the same problem exists. BTW, I use vim 7.4.

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

1条回答

  • douwu8251 douwu8251 7年前

    You can figure out where the relevant options were set with

    :verbose set smartindent? ai? indentexpr?
    

    There is not much point in scrutinizing the vimrc file if the options are set somewhere else. (I had a quick look: Line 28 is the part that interests me the most.) BTW, I hope you mean ~/.vim/indent/ and not /.vim/indent/.

    点赞 评论 复制链接分享