错误:在rpmdb中找不到包元组('php-pecl-jsonc','x86_64','0','1.3.7','1.el6.remi.5.6')

I need to upgrade my PHP version from 7.1.26 to 7.2 due to symfony on my CentOS server but I got this error:

Error: Package tuple ('php-pecl-jsonc', 'x86_64', '0', '1.3.7', '1.el6.remi.5.6') could not be found in rpmdb

I did:

yum-config-manager --enable remi-php72
yum install php php-mcrypt php-cli php-gd php-curl php-mysql php-ldap php-zip php-fileinfo --skip-broken

and got this:

Loaded plugins: fastestmirror
Setting up Install Process
Determining fastest mirrors
Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=x86_64 error was
14: problem making ssl connection
 * base: tux.rainside.sk
 * epel: mirror.vutbr.cz
 * extras: tux.rainside.sk
 * remi: rpms.remirepo.net
 * remi-php56: rpms.remirepo.net
 * remi-php71: rpms.remirepo.net
 * remi-php72: rpms.remirepo.net
 * remi-safe: rpms.remirepo.net
 * updates: tux.rainside.sk
 * webtatic: uk.repo.webtatic.com
WANdisco-git                                                                                                                                                 | 2.9 kB     00:00
WANdisco-git/primary_db                                                                                                                                      | 134 kB     00:00
base                                                                                                                                                         | 3.7 kB     00:00
extras                                                                                                                                                       | 3.4 kB     00:00
extras/primary_db                                                                                                                                            |  29 kB     00:00
icinga-stable-release                                                                                                                                        | 2.5 kB     00:00
icinga-stable-release/primary_db                                                                                                                             | 309 kB     00:00
remi                                                                                                                                                         | 3.0 kB     00:00
remi/primary_db                                                                                                                                              | 2.3 MB     00:00
remi-php56                                                                                                                                                   | 3.0 kB     00:00
remi-php56/primary_db                                                                                                                                        | 245 kB     00:00
remi-php71                                                                                                                                                   | 3.0 kB     00:00
remi-php71/primary_db                                                                                                                                        | 212 kB     00:00
remi-php72                                                                                                                                                   | 3.0 kB     00:00
remi-php72/primary_db                                                                                                                                        | 196 kB     00:00
remi-safe                                                                                                                                                    | 3.0 kB     00:00
remi-safe/primary_db                                                                                                                                         | 1.2 MB     00:00
updates                                                                                                                                                      | 3.4 kB     00:00
updates/primary_db                                                                                                                                           | 3.7 MB     00:00
webtatic                                                                                                                                                     | 2.4 kB     00:00
Package php-mysql-5.4.45-17.el6.remi.x86_64 is obsoleted by php-mysqlnd-7.1.26-1.el6.remi.x86_64 which is already installed
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:7.1.26-1.el6.remi will be updated
---> Package php.x86_64 0:7.2.18-1.el6.remi will be an update
--> Processing Dependency: libargon2.so.0()(64bit) for package: php-7.2.18-1.el6.remi.x86_64
---> Package php-cli.x86_64 0:7.1.26-1.el6.remi will be updated
---> Package php-cli.x86_64 0:7.2.18-1.el6.remi will be an update
---> Package php-common.x86_64 0:7.1.26-1.el6.remi will be updated
--> Processing Dependency: php-common(x86-64) = 7.1.26-1.el6.remi for package: php-json-7.1.26-1.el6.remi.x86_64
Error: Package tuple ('php-pecl-jsonc', 'x86_64', '0', '1.3.7', '1.el6.remi.5.6') could not be found in rpmdb

Could somebody help me with this?

source for the upgrade: https://www.tecmint.com/install-php-7-in-centos-6/

Thank you.

dongren1353
dongren1353 yumupdate已加载的插件:fastermirror设置更新进程从缓存的主机文件加载镜像速度无法获取metalink镜像.fedoraproject.org/metalink?repo=epel-6&arch=x86_64错误是14:问题使得ssl连接*base:tux.rainside。sk*epel:mirror.vutbr.cz*extras:tux.rainside.sk*remi:rpms.remirepo.net*remi-php71:rpms.remirepo.net*remi-php72:rpms.remirepo.net*remi-safe:rpms.remirepo.net*更新:tux.rainside.sk错误:包元组('php-pecl-jsonc','x86_64','0','1.3.7','1.el6.remi.5.6')在rpmdb中找不到
一年多之前 回复
doupian9798
doupian9798 yum检查所有已加载的插件:fastermirrorcheck['all']
一年多之前 回复
duanpiangeng8958
duanpiangeng8958 同时禁用会产生冲突的webtatic(单个提供商避免问题)
一年多之前 回复
dongshan7060
dongshan7060 运行“yumcheckall”,但看起来你的rpmdb已损坏
一年多之前 回复
dongyi6269
dongyi6269 我禁用了remi-php56并尝试了“yumupdate”但得到了同样的错误。我不知道为什么yum试图安装php-pecl-jsonc,因为我不再需要它了,我甚至不知道需要什么这种依赖。
一年多之前 回复
duanliujie8639
duanliujie8639 你也可以禁用remi-php56和remi-php71,因为只需要remi-php72
一年多之前 回复
duanli0119
duanli0119 安装php时,尝试一个简单的“yumupdate”。BTW,php-pecl-jsonc只是PHP5.x,所以不需要在那里(由php-json取代)
一年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐