为什么Magento 2.3从7.1.3支持PHP 7.1并且不包括以前的7.1版本?

Magento 2.3系统要求说它支持PHP 7.1.3+,但这不包括7.1.0,7.1.1和 7.1.2版本:</ p>

https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html </ p>

是吗? 错误或是否有任何理由为什么排除前3个次要版本?</ p>

谢谢。</ p>
</ div>

展开原文

原文

Magento 2.3 system requirements says it supports PHP 7.1.3+, but this excludes 7.1.0, 7.1.1 and 7.1.2 versions:

https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html

Is it a mistake or is there any reason why the 3 previous minor versions are excluded?

Thanks.

dpa0760
dpa0760 确实,vendor/magento/magento2-base中的package.json使用:“php”:“~7.1.3||~7.2.0”。我会跟着那个,谢谢。
一年多之前 回复
dpjw67160
dpjw67160 好吧,我问,因为我需要为模块指定所需的PHP版本......我无法理解为什么要排除这三个版本...可以使用PHP7.1.0引入可空类型,没有什么重大改变在那之后,我当然找不到任何与7.1.3有关的东西可以解释为什么从那里开始..
一年多之前 回复
dongzhou1865
dongzhou1865 除非你有特别的理由去思考,否则我会按照他们的说法接受文件。
一年多之前 回复

1个回答



Php7.1中有严格的输入法。 Php 7.0还不支持。</ p>
</ div>

展开原文

原文

Php7.1 has strict typing in it. Php 7.0 does not support that yet.

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐