namespace_Pt
叫我PT
2019-10-23 21:58
采纳率: 50%
浏览 477

vscode 配置c\c++编译环境后,能正常编译运行代码但用debug模式时在控制台每次都会弹出这几行是为什么?

图片说明
就这几行红字,怎么能消除掉啊,虽然暂时没有影响,但是看着好不爽。。

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • qq_40169115
    qq_40169115 2019-10-23 22:30
    已采纳

    答:这几行字并不影响使用,提示你calculator.exe程序 已推出代码,无法取消,因为取消反而会造成影响,完全不会有影响所以不必担心。
    只是一个提示代码,没有影响,后续有什么问题也可以私信我,我看到就会为你回答的。
    如果对我的回答满意,请采纳

    点赞 评论
  • dmankill
    dmankill 2019-10-23 22:29

    这个是调试信息,给你诊断用的,看习惯就好了,

    点赞 评论
  • infoworld
    infoworld 2019-10-23 22:54

    试试在Debug配置文件launch.json里增加属性,主要是moduleLoad的值为false.

    "logging": {
        "moduleLoad": false,
        "trace": false
      },
    

    可以,我试过了。

    {
        "configurations": [
            {  
                "name": "(gdb) launch",
                "type": "cppdbg",
                "request": "launch",
                "program": "${workspaceRoot}/${fileBasenameNoExtension}.exe",
                "args": [],
                "stopAtEntry": false,
                "cwd": "${workspaceFolder}",
                "environment": [],
                "externalConsole": false,
                "preLaunchTask": "g++",
                "MIMode": "gdb",
                "logging": {
                    "moduleLoad": false,
                    "trace": false
                },
                "miDebuggerPath": "E:\\software\\cygwin64\\bin\\gdb.exe",
                "setupCommands": [
                    {
                        "description": "asdfas",
                        "text": "-enable-pretty-printing",
                        "ignoreFailures": true
                    }
                ] 
            } 
        ]
    }
    

    图片说明

    点赞 评论

相关推荐