Nginx使用默认配置

I have configured nginx as my web server for my php api. I have put my configuration file with the url in /etc/nginx/sites-available location. But instead of picking up this file my nginx seems to be using the default configurations.

The bellow specified is my default file in /etc/nginx/sites-avaiable location

    # SSL configuration
#
# listen 443 ssl default_server;
# listen [::]:443 ssl default_server;
#
# Note: You should disable gzip for SSL traffic.
# See: https://bugs.debian.org/773332
#
# Read up on ssl_ciphers to ensure a secure configuration.
# See: https://bugs.debian.org/765782
#
# Self signed certs generated by the ssl-cert package
# Don't use them in a production server!
#
# include snippets/snakeoil.conf;

root /var/www/html;
# Add index.php to the list if you are using PHP
index login.html index.html index.htm index.nginx-debian.html;
#index login.html
server_name _;

location / {
        # First attempt to serve request as file, then
        # as directory, then fall back to displaying a 404.
        try_files $uri $uri/ =404;
}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
#
location ~ \.php$ {
       include snippets/fastcgi-php.conf;
#
#       # With php7.0-cgi alone:
#       fastcgi_pass 127.0.0.1:9000;
#       # With php7.0-fpm:
       fastcgi_pass unix:/run/php/php7.0-fpm.sock;
}

# deny access to .htaccess files, if Apache's document root
# concurs with nginx's one
#
#location ~ /\.ht {
#       deny all;
#}
}
# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and 
symlink that
# to sites-enabled/ to enable it.
#
#server {
#       listen 80;
#       listen [::]:80;
#
#       server_name example.com;
#
#       root /var/www/example.com;
#       index index.html;
#
#       location / {
#               try_files $uri $uri/ =404;
#       }
#}

Please give me a solution on how to resolve this issue.

I will also provide my own configuration in /etc/nginx/sites-available/

server {
listen 80;

root /var/www/html;
#root /var/www/html/registry;
#index visitor_info.php info.php index.html index.htm index.nginx-debian.html;
index login.php skills.php question_topic.php connection.php json.php questions.php user_answers.php multiple_choices.php user_details.php answer_validation.php ad$


server_name mydomainurl;

location / {
    try_files $uri $uri/ =404;
}

location ~ \.php$ {
    include snippets/fastcgi-php.conf;
    fastcgi_pass unix:/run/php/php7.0-fpm.sock;
}

location ~ /\.ht {
    deny all;
}

}

The symbolik link is also created in the /etc/nginx/sites-enables location.

Thanks in advance.

douyue3800
douyue3800 这是我运行该命令时得到的输出nginx:配置文件/etc/nginx/nginx.conf语法正常nginx:配置文件/etc/nginx/nginx.conf测试成功
一年多之前 回复
doufeng1249
doufeng1249 您应该使用nginx-t测试配置,并查看Nginx实际使用的文件与nginx-T
一年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐