Centos 7无法与POSTGRES连接

I have a Centos 7 development server which is currently running for testing purposes. It is installed with PHP 7.1.19, mariadb, jasper server and tomcat.

But now, I need to install Postgres database server (PgSql). I have spent whole day just to search the solution and all failed.

The Centos 7 comes with PHP 5.4.16 and php-pgsql 5.4.16 by default (same version). I have upgraded the PHP version. I just focus on MySql because no requirement for PgSql until now.

From repo:

[root@localhost a]# yum info php-pgsql
Loaded plugins: fastestmirror, remove-with-leaves
Loading mirror speeds from cached hostfile
 * base: centos.exabytes.com.my
 * epel: del-repos.extreme-ix.org
 * extras: centos.exabytes.com.my
 * updates: centos.biz.net.id
Available Packages
Name        : php-pgsql
Arch        : x86_64
Version     : 5.4.16
Release     : 45.el7
Size        : 86 k
Repo        : base/7/x86_64
Summary     : A PostgreSQL database module for PHP
URL         : http://www.php.net/
License     : PHP
Description : The php-pgsql add PostgreSQL database support to PHP.
            : PostgreSQL is an object-relational database management
            : system that supports almost all SQL constructs. PHP is an
            : HTML-embedded scripting language. If you need back-end support for
            : PostgreSQL, you should install this package in addition to the main
            : php package.

The problem now is, when I want to install the php-pgsql connector:

yum install php-pgsql

it gave me an error:

[root@localhost ~]# yum install php-pgsql --skip-broken
Loaded plugins: fastestmirror, remove-with-leaves
Loading mirror speeds from cached hostfile
 * base: centos.exabytes.com.my
 * epel: del-repos.extreme-ix.org
 * extras: centos.exabytes.com.my
 * updates: centos.biz.net.id
Resolving Dependencies
--> Running transaction check
---> Package php-pgsql.x86_64 0:5.4.16-45.el7 will be installed
--> Processing Dependency: php-pdo(x86-64) = 5.4.16-45.el7 for package: php-pgsql-5.4.16-45.el7.x86_64

Packages skipped because of dependency problems:
    php-pgsql-5.4.16-45.el7.x86_64 from base

This must be version conflict between PHP (higher) and php-pgsql (lower).

Without this driver, my phpinfo() has no pdo-pgsql section

Does anyone has faced same previous experience, might helps and share the knowledge with me.

Note: I am fully coding, just has basic knowledge on server

Thank you

duankao4489
duankao4489 你能分享php-m|的输出吗?greppgsql?
接近 2 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐