Ampps安装问题PHP模块

I downloaded the latest Ampps windows version and during installation received many PHP Warnings 'Unable to Initalize module...'. The .dll files are in the correct location but I'm not sure why it won't initiate the .dlls and why the API's are mismatched.

Failed loading C:/Program Files (x86)/Ampps\php-5.6\ioncube_loader_win_5.6.dll
Xdebug requires Zend Engine API version 220131226.
The Zend Engine API version 220121212 which is installed, is outdated.

PHP Warning:  PHP Startup: bz2: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:/Program Files (x86)/Ampps\\php-5.6\\ext\\php_curl.dll' - The specified procedure could not be found.
 in Unknown on line 0
PHP Warning:  PHP Startup: fileinfo: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: gd: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: gettext: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: gmp: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:/Program Files (x86)/Ampps\\php-5.6\\ext\\php_imap.dll' - The specified procedure could not be found.
 in Unknown on line 0
PHP Warning:  PHP Startup: mbstring: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: exif: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: mysql: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: mysqli: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:/Program Files (x86)/Ampps\\php-5.6\\ext\\php_openssl.dll' - The specified procedure could not be found.
 in Unknown on line 0
PHP Warning:  PHP Startup: pdo_mysql: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: pdo_sqlite: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: soap: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: sockets: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: sqlite3: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: tidy: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: xmlrpc: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:/Program Files (x86)/Ampps\\php-5.6\\ext\\php_xsl.dll' - The specified procedure could not be found.
 in Unknown on line 0
PHP Warning:  PHP Startup: com_dotnet: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: mongo: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
[Tue Apr 02 17:54:28.999194 2019] [mpm_winnt:notice] [pid 7712:tid 828] AH00455: Apache/2.4.27 (Win32) OpenSSL/1.1.0f PHP/5.6.31 configured -- resuming normal operations
[Tue Apr 02 17:54:28.999194 2019] [mpm_winnt:notice] [pid 7712:tid 828] AH00456: Apache Lounge VC15 Server built: Jul  7 2017 11:43:51
[Tue Apr 02 17:54:28.999194 2019] [core:notice] [pid 7712:tid 828] AH00094: Command line: 'apache\\bin\\httpd.exe -d C:/Program Files (x86)/Ampps/apache'
[Tue Apr 02 17:54:28.999194 2019] [mpm_winnt:notice] [pid 7712:tid 828] AH00418: Parent: Created child process 2992
Failed loading C:/Program Files (x86)/Ampps\php-5.6\ioncube_loader_win_5.6.dll
Xdebug requires Zend Engine API version 220131226.
The Zend Engine API version 220121212 which is installed, is outdated.

PHP Warning:  PHP Startup: com_dotnet: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: mongo: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0
[Tue Apr 02 18:00:58.604316 2019] [mpm_winnt:notice] [pid 15976:tid 668] AH00455: Apache/2.4.27 (Win32) OpenSSL/1.1.0f PHP/5.6.31 configured -- resuming normal operations
[Tue Apr 02 18:00:58.604316 2019] [mpm_winnt:notice] [pid 15976:tid 668] AH00456: Apache Lounge VC15 Server built: Jul  7 2017 11:43:51
[Tue Apr 02 18:00:58.604316 2019] [core:notice] [pid 15976:tid 668] AH00094: Command line: 'apache\\bin\\httpd.exe -d C:/Program Files (x86)/Ampps/apache'
[Tue Apr 02 18:00:58.609313 2019] [mpm_winnt:notice] [pid 15976:tid 668] AH00418: Parent: Created child process 6388
Failed loading C:/Program Files (x86)/Ampps\php-5.6\ioncube_loader_win_5.6.dll
Xdebug requires Zend Engine API version 220131226.
The Zend Engine API version 220121212 which is installed, is outdated.
dousi1994
dousi1994 我无法解决这些错误。然而,这迫使我看看其他选项,发现一个名为'Laragon'的小宝石建议检查出来。laragon.org
一年多之前 回复
douruoshen1449
douruoshen1449 我遇到同样的问题你能找到解决方案吗?
一年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐