duanfan1869
2019-03-22 01:31
浏览 354

Wordpress错误 - 抱歉,您无权访问此页面。 将网站从一个域迁移到另一个域后

I keep seeing the error - Sorry, you are not allowed to access this page. When trying to login to the website at the new hosting location and new domain.

What I have tried to far:

  • logged into PHP my admin created a new user in the wp_users table used md5() to set the password
  • went into the wp_usermeta and added wp_capabilities a:1:{s:13:"administrator";s:1:"1";}
  • added wp_user_level 10 to wp_usermeta table
  • created a new fresh .htaccess file
  • went into the wp_options table and updated template, stylesheet & active_plugins to use a twentyseventeen theme and plugins a:0:{}
  • I enabled WP_debug and only got the following errors:

[21-Mar-2019 23:22:42 UTC] PHP Notice:  Use of undefined constant is_transparent - assumed 'is_transparent' in /home/yarrasol/public_html/wp-content/themes/okab/framework/functions/admin/customizer/css-var/css_navbar.php on line 3
[21-Mar-2019 23:22:42 UTC] PHP Notice:  Undefined index: dima_body_background_image_repeat in /home/yarrasol/public_html/wp-content/themes/okab/framework/functions/admin/customizer/css-var/css_page.php on line 7
[21-Mar-2019 23:22:42 UTC] PHP Notice:  Undefined index: dima_body_background_image_position in /home/yarrasol/public_html/wp-content/themes/okab/framework/functions/admin/customizer/css-var/css_page.php on line 8
[21-Mar-2019 23:22:42 UTC] PHP Notice:  Undefined index: dima_body_background_image_size in /home/yarrasol/public_html/wp-content/themes/okab/framework/functions/admin/customizer/css-var/css_page.php on line 9
[21-Mar-2019 23:22:42 UTC] PHP Notice:  Undefined index: dima_body_background_image_attachment in /home/yarrasol/public_html/wp-content/themes/okab/framework/functions/admin/customizer/css-var/css_page.php on line 10 

There is more errors - but wasn't able to post them without getting flagged as spam.

Sorry for the long post, just trying to be as descriptive as possible thank you all in advance.

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dtz8044 2019-03-22 02:22

    thank you your comments. I managed to figure out the issue. Due to the database tables in the original hosting server having a different prefix, I should have updated the wp-config.php file to the updated prefix. However I updated all the database tables to match the prefix shown in the config file, I noticed this issue as I dropped the wp_options table and loaded one in from a different wp install and it worked.

    打赏 评论

相关推荐 更多相似问题