dongmanzui8486
dongmanzui8486
2017-03-30 19:58
浏览 276
已采纳

使用cpulimit和PHP减少FFmpeg CPU使用率

I run FFmpeg on my server using PHP exec().

It currently uses 100% of the cpu thread while encoding.

I followed this gude that uses a program called cpulimit to reduce it to 30%.


PHP

$args = "nice -19 cpulimit -l 30 -- ffmpeg -y -i intput.avi -vcodec libx264 -acodec aac -b:a 192k -threads 1 output.mp4"
exec(escapeshellcmd($args));

FFmpeg/PHP works, and it will work with nice/cpulimit through the terminal, but after adding
nice -19 cpulimit -l 30 -- to the PHP script it no longer works with exec().


Output

FFmpeg output returns blank. I'm not able to see the full output, I tried using:

$output = shell_exec($args);
echo "<p>$output</p>"

and

file_put_contents("/var/www/mysite/logs/$output.log", $line . PHP_EOL, FILE_APPEND);

But they return 1 empty line.


Solution

My thought is that www-data runs FFmpeg and nice/cpulimit may need root?

How can I get PHP exec() to work with FFmpeg args and cpulimit?

Or is there an alternative way to limit the usage %?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • dqysi86208
    dqysi86208 2017-03-31 01:24
    已采纳

    I found the answer on this forum post using google translate.

    https://murobbs.muropaketti.com/threads/nice-komento-ja-php-n-exec-funktio-ratkaistu.551174/

    Define the path to FFmpeg if using nice or cpulimit

    nice -19 cpulimit -l 30 /usr/local/bin/ffmpeg -i ...
    

    Now it works through PHP exec().

    点赞 评论
  • duanlan8763
    duanlan8763 2017-03-30 23:54

    If safemode is enabled then, the execution of programes are limited. Check this documentation here, http://php.net/manual/en/function.exec.php

    点赞 评论

相关推荐