通过yum安装php-pecl-memcache尝试安装php-cli,这与EasyApache的版本冲突

我正在使用cPanel / WHM / EasyApache 4运行64位CentOS 7,我正在尝试获取memcache和 已安装memcached(PHP)。</ p>

我通过yum安装了memcache,但是在尝试“yum install php-pecl-memcached”时,这是我得到的错误:</ p >

 事务检查错误:

文件/ usr / bin / php来自安装php-cli-5.4.16-42.el7.x86_64
与包ea中的文件冲突 php-cli-0.1.0-2.4.1.cpanel.x86_64
</ code> </ pre>

这是在现场网站上发生的,所以我想确认我可以卸载php -cli通过EasyApache而不影响我的前端。 (我也尝试通过EasyApache安装memcached,但它抱怨无法找到libmemcached,这是通过该接口无法使用的。)</ p>
</ div>

展开原文

原文

I'm running 64-bit CentOS 7 with cPanel/WHM/EasyApache 4, and am trying to get memcache and memcached (PHP) installed.

I installed memcache via yum without a hitch, but when trying to "yum install php-pecl-memcached", this is the error I get:

Transaction check error:

file /usr/bin/php from install of php-cli-5.4.16-42.el7.x86_64
 conflicts with file from package ea-php-cli-0.1.0-2.4.1.cpanel.x86_64

This is happening on a live site, so I want to confirm that I can uninstall php-cli via EasyApache without affecting my front end. (I also tried installing memcached via EasyApache, but it complains about not being able to find libmemcached, which is not available through that interface.)

douao8353
douao8353 使用--replacefiles标志我唯一担心的是版本号不同。我知道它是EA的版本,但我想确认这样做是安全的。
3 年多之前 回复
dongpa3109
dongpa3109 可能重复的禁用yum事务检查文件冲突
3 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问