eclipse rcp p2 update eclipse 3.6 可以使用的demo 5C

eclipse rcp p2 update eclipse 3.6 可以使用的demo

百度 或者贴吧上看了很多 但是执行起来发现跟新 job 总是null

希望得到一个完整的 demo 注释全点 先 5分 解决了 加分

邮箱 544303626@qq.com

1个回答

qq_30016209
上下上下左右左右BABA 这个代码看上去不全 ArchiPlugin.bundleContext 会报错
4 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
RCP中报com.ibm.icu错误
希望解决过这个问题的朋友给予解答方法,谢了! [code="java"] !SESSION 2009-08-12 00:16:47.578 ----------------------------------------------- eclipse.buildId=unknown java.version=1.5.0_09 java.vendor=Sun Microsystems Inc. BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_CN Framework arguments: -application cn.blogjava.youxia.rcp_start.application Command-line arguments: -application cn.blogjava.youxia.rcp_start.application -data C:\Documents and Settings\thinkpad\workspace/../runtime-cn.blogjava.youxia.rcp_start.application -dev file:C:/Documents and Settings/thinkpad/workspace/.metadata/.plugins/org.eclipse.pde.core/cn.blogjava.youxia.rcp_start.application/dev.properties -os win32 -ws win32 -arch x86 !ENTRY org.eclipse.osgi 4 0 2009-08-12 00:16:47.984 !MESSAGE Error installing bundle: reference:file:../myeclipse/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar/ !STACK 0 org.osgi.framework.BundleException: Bundle "com.ibm.icu" version "3.6.1.v20070906" has already been installed from: initial@reference:file:plugins/com.ibm.icu_3.6.1.v20070906.jar/ at org.eclipse.osgi.framework.internal.core.Framework.createAndVerifyBundle(Framework.java:642) at org.eclipse.osgi.framework.internal.core.Framework.installWorkerPrivileged(Framework.java:909) at org.eclipse.osgi.framework.internal.core.Framework$2.run(Framework.java:824) at java.security.AccessController.doPrivileged(Native Method) at org.eclipse.osgi.framework.internal.core.Framework.installWorker(Framework.java:875) at org.eclipse.osgi.framework.internal.core.Framework.installBundle(Framework.java:819) at org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(BundleContextImpl.java:229) at org.eclipse.core.runtime.adaptor.EclipseStarter.installBundles(EclipseStarter.java:1064) at org.eclipse.core.runtime.adaptor.EclipseStarter.loadBasicBundles(EclipseStarter.java:621) at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:303) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:172) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447) at org.eclipse.equinox.launcher.Main.run(Main.java:1173) at org.eclipse.equinox.launcher.Main.main(Main.java:1148) !ENTRY org.eclipse.osgi 4 0 2009-08-12 00:16:47.984 !MESSAGE Error installing bundle: reference:file:../myeclipse/eclipse/plugins/javax.servlet_2.4.0.v200706111738.jar/ !STACK 0 org.osgi.framework.BundleException: Bundle "javax.servlet" version "2.4.0.v200706111738" has already been installed from: initial@reference:file:plugins/javax.servlet_2.4.0.v200706111738.jar/ at org.eclipse.osgi.framework.internal.core.Framework.createAndVerifyBundle(Framework.java:642) at org.eclipse.osgi.framework.internal.core.Framework.installWorkerPrivileged(Framework.java:909) at org.eclipse.osgi.framework.internal.core.Framework$2.run(Framework.java:824) at java.security.AccessController.doPrivileged(Native Method) at org.eclipse.osgi.framework.internal.core.Framework.installWorker(Framework.java:875) at org.eclipse.osgi.framework.internal.core.Framework.installBundle(Framework.java:819) at org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(BundleContextImpl.java:229) at org.eclipse.core.runtime.adaptor.EclipseStarter.installBundles(EclipseStarter.java:1064) at org.eclipse.core.runtime.adaptor.EclipseStarter.loadBasicBundles(EclipseStarter.java:621) at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:303) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:172) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447) at org.eclipse.equinox.launcher.Main.run(Main.java:1173) at org.eclipse.equinox.launcher.Main.main(Main.java:1148) !ENTRY org.eclipse.osgi 4 0 2009-08-12 00:16:48.171 !MESSAGE Application error !STACK 1 java.lang.RuntimeException: Application "cn.blogjava.youxia.rcp_start.application" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error. at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242) at org.eclipse.equinox.internal.app.EclipseAppContainer.start(EclipseAppContainer.java:98) at org.eclipse.equinox.internal.app.Activator.addingService(Activator.java:112) at org.osgi.util.tracker.ServiceTracker$Tracked.trackAdding(ServiceTracker.java:1064) at org.osgi.util.tracker.ServiceTracker$Tracked.trackInitialServices(ServiceTracker.java:926) at org.osgi.util.tracker.ServiceTracker.open(ServiceTracker.java:330) at org.osgi.util.tracker.ServiceTracker.open(ServiceTracker.java:274) at org.eclipse.equinox.internal.app.Activator.start(Activator.java:54) at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999) at java.security.AccessController.doPrivileged(Native Method) at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993) at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974) at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260) at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400) at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111) at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:417) at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189) at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340) at org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(SingleSourcePackage.java:37) at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:405) at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369) at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357) at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClassInternal(Unknown Source) at org.eclipse.core.internal.runtime.PlatformActivator.startAppContainer(PlatformActivator.java:47) at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:32) at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999) at java.security.AccessController.doPrivileged(Native Method) at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993) at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974) at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346) at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350) at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118) at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634) at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508) at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282) at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468) at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195) at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297) !ENTRY org.eclipse.osgi 2 0 2009-08-12 00:16:48.171 !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved: !SUBENTRY 1 org.eclipse.osgi 2 0 2009-08-12 00:16:48.171 !MESSAGE Bundle initial@reference:file:D:/Workbench/Demo1/ was not resolved. !SUBENTRY 2 cn.blogjava.youxia.rcp_start 2 0 2009-08-12 00:16:48.171 !MESSAGE Missing required bundle org.eclipse.core.runtime.compatibility_0.0.0. !ENTRY org.eclipse.osgi 2 0 2009-08-12 00:16:48.171 !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists: !SUBENTRY 1 org.eclipse.osgi 2 0 2009-08-12 00:16:48.171 !MESSAGE Bundle initial@reference:file:D:/Workbench/Demo1/ [3] was not resolved. !SUBENTRY 2 cn.blogjava.youxia.rcp_start 2 0 2009-08-12 00:16:48.171 !MESSAGE Missing required bundle org.eclipse.core.runtime.compatibility_0.0.0. [/code]
Eclipse的RCP插件怎么安装
请问大家,我下载了eclipse的RCP插件,用link的形式安装了上去,结果是有些功能得到了体现,有些没有,怎么回事?谢谢! [b]问题补充:[/b] 我下载了eclipse-RCP-SDK-3.4.2-win32.zip,用link的形式安装了,但是在做扩展的时候,有此属性没有,而用单独的eclipse插件(Eclipse for RCP/Plug-in Developers (176 MB) )会有。。是什么问题。 [b]问题补充:[/b] 我同事,直接下载eclipse-RCP-SDK-3.4.2-win32.zip 覆盖也会有一样的问题。 [b]问题补充:[/b] 大家在RCP开发都没有碰到此问题吗?
eclipse无法启动了,日志记录如下。没有安装Oracle。
环境变量如下: %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%JAVA_HOME%\bin;%JAVA_HOME%\jre\bin; C:\Program Files\TortoiseSVN\bin; jdk版本为1.6. 之前还开发的好好的,今天早上就不行了。升级过Flash插件。没安装Oracle,有SQLDevelop。 !SESSION 2014-05-26 16:34:13.138 ----------------------------------------------- eclipse.buildId=4.3.0.I20130605-2000 java.version=1.7.0_25 java.vendor=Oracle Corporation BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_CN Framework arguments: -product org.eclipse.epp.package.rcp.product Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.rcp.product !ENTRY org.eclipse.osgi 2 0 2014-05-26 16:34:14.980 !MESSAGE 由于未解析以下根约束,所以未解析一个或多个束: !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.980 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.mylyn.commons.workbench_3.9.0.v20130612-0100.jar。 !SUBENTRY 2 org.eclipse.mylyn.commons.workbench 2 0 2014-05-26 16:34:14.980 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.980 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.ui.views.properties.tabbed_3.6.0.v20130515-1857.jar。 !SUBENTRY 2 org.eclipse.ui.views.properties.tabbed 2 0 2014-05-26 16:34:14.980 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.980 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.jdt.compiler.apt.nl_zh_4.3.0.v20131123020001.jar。 !SUBENTRY 2 org.eclipse.jdt.compiler.apt.nl_zh 2 0 2014-05-26 16:34:14.980 !MESSAGE 缺少主机 org.eclipse.jdt.compiler.apt_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.980 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.egit.mylyn.ui_3.0.0.201306101825-r.jar。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:14.980 !MESSAGE 缺少已导入包 org.eclipse.ui.plugin_0.0.0。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:14.980 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.980 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.m2e.logback.appender_1.4.0.20130601-0317.jar。 !SUBENTRY 2 org.eclipse.m2e.logback.appender 2 0 2014-05-26 16:34:14.980 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.980 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.m2e.scm_1.4.0.20130601-0317.jar。 !SUBENTRY 2 org.eclipse.m2e.scm 2 0 2014-05-26 16:34:14.980 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 2 org.eclipse.m2e.scm 2 0 2014-05-26 16:34:14.981 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_3.5.2。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.981 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.mylyn.commons.notifications.ui_1.1.0.v20130612-0100.jar。 !SUBENTRY 2 org.eclipse.mylyn.commons.notifications.ui 2 0 2014-05-26 16:34:14.981 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.981 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.m2e.refactoring_1.4.0.20130601-0317.jar。 !SUBENTRY 2 org.eclipse.m2e.refactoring 2 0 2014-05-26 16:34:14.981 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.refactoring 2 0 2014-05-26 16:34:14.981 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.981 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.compare.win32_1.0.200.v20130514-1224.jar。 !SUBENTRY 2 org.eclipse.compare.win32 2 0 2014-05-26 16:34:14.981 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.981 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.ui.net_1.2.200.v20120807-0927.jar。 !SUBENTRY 2 org.eclipse.ui.net 2 0 2014-05-26 16:34:14.981 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.981 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.equinox.p2.ui.importexport_1.1.0.v20130327-2119.jar。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2014-05-26 16:34:14.981 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.981 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.emf.edit.ui_2.9.0.v20130610-0406.jar。 !SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2014-05-26 16:34:14.981 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.981 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.equinox.p2.ui_2.3.0.v20130528-2154.jar。 !SUBENTRY 2 org.eclipse.equinox.p2.ui 2 0 2014-05-26 16:34:14.981 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.981 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.m2e.launching_1.4.0.20130601-0317.jar。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:14.981 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:14.981 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.981 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.platform_4.3.0.v20130605-2000/。 !SUBENTRY 2 org.eclipse.platform 2 0 2014-05-26 16:34:14.981 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.982 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.m2e.core.ui_1.4.0.20130601-0317.jar。 !SUBENTRY 2 org.eclipse.m2e.core.ui 2 0 2014-05-26 16:34:14.982 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.982 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.mylyn.versions.ui_1.1.0.v20130612-0100.jar。 !SUBENTRY 2 org.eclipse.mylyn.versions.ui 2 0 2014-05-26 16:34:14.982 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.982 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.m2e.editor_1.4.0.20130601-0317.jar。 !SUBENTRY 2 org.eclipse.m2e.editor 2 0 2014-05-26 16:34:14.982 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.editor 2 0 2014-05-26 16:34:14.982 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.982 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.gef_3.9.0.201305060205.jar。 !SUBENTRY 2 org.eclipse.gef 2 0 2014-05-26 16:34:14.982 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_[3.2.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.982 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.ui.workbench.nl_zh_4.3.0.v20131123020001.jar。 !SUBENTRY 2 org.eclipse.ui.workbench.nl_zh 2 0 2014-05-26 16:34:14.982 !MESSAGE 缺少主机 org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.982 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.ui.ide_3.9.0.v20130517-0139.jar。 !SUBENTRY 2 org.eclipse.ui.ide 2 0 2014-05-26 16:34:14.982 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_[3.7.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.982 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.equinox.p2.ui.sdk_1.0.300.v20130503-1750.jar。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2014-05-26 16:34:14.983 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.983 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.m2e.jdt_1.4.0.20130601-0317.jar。 !SUBENTRY 2 org.eclipse.m2e.jdt 2 0 2014-05-26 16:34:14.983 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.jdt 2 0 2014-05-26 16:34:14.983 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.983 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.jdt.compiler.tool.nl_zh_4.3.0.v20131123020001.jar。 !SUBENTRY 2 org.eclipse.jdt.compiler.tool.nl_zh 2 0 2014-05-26 16:34:14.983 !MESSAGE 缺少主机 org.eclipse.jdt.compiler.tool_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.983 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.ui_3.105.0.v20130522-1122.jar。 !SUBENTRY 2 org.eclipse.ui 2 0 2014-05-26 16:34:14.983 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))". !SUBENTRY 2 org.eclipse.ui 2 0 2014-05-26 16:34:14.983 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_[3.105.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.983 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.mylyn.team.cvs_3.9.0.v20130612-0100.jar。 !SUBENTRY 2 org.eclipse.mylyn.team.cvs 2 0 2014-05-26 16:34:14.983 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.983 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.m2e.discovery_1.4.0.20130601-0317.jar。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:14.983 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:14.984 !MESSAGE 未解析 bundle reference:file:plugins/org.eclipse.m2e.editor.xml_1.4.0.20130601-0317.jar。 !SUBENTRY 2 org.eclipse.m2e.editor.xml 2 0 2014-05-26 16:34:14.984 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !ENTRY org.eclipse.osgi 2 0 2014-05-26 16:34:15.312 !MESSAGE 以下是未解析的束的完整列表,请参阅上一个日志条目以了解根本原因(如果存在该日志条目的话): !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.312 !MESSAGE 未解析 bundle org.eclipse.ant.ui_3.5.400.v20130514-1341 [59]。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.ide_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.views_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.editors_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.ui.externaltools_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.ui.console_[3.1.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.debug.ui_[3.6.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.ui_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.debug.ui_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ant.ui 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.junit_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.312 !MESSAGE 未解析 bundle org.eclipse.compare_3.5.400.v20130514-1224 [60]。 !SUBENTRY 2 org.eclipse.compare 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.compare 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_[3.3.0,4.0.0)。 !SUBENTRY 2 org.eclipse.compare 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.ui.views_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.compare 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.compare 2 0 2014-05-26 16:34:15.312 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.312 !MESSAGE 未解析 bundle org.eclipse.compare.win32_1.0.200.v20130514-1224 [62]。 !SUBENTRY 2 org.eclipse.compare.win32 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.compare_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.compare.win32 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.313 !MESSAGE 未解析 bundle org.eclipse.debug.ui_3.9.0.v20130516-1713 [86]。 !SUBENTRY 2 org.eclipse.debug.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.debug.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.ui.console_[3.4.0,4.0.0)。 !SUBENTRY 2 org.eclipse.debug.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.debug.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.debug.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.313 !MESSAGE 未解析 bundle org.eclipse.egit.doc_3.0.0.201306101825-r [116]。 !SUBENTRY 2 org.eclipse.egit.doc 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.ui.cheatsheets_[3.3.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.313 !MESSAGE 未解析 bundle org.eclipse.egit.mylyn.ui_3.0.0.201306101825-r [117]。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator.resources_0.0.0。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.tasks.ui_[3.0.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.team.ui_[3.0.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.resources.ui_[3.0.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_0.0.0。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少已导入包 org.eclipse.egit.ui_[3.0.0,3.1.0)。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少已导入包 org.eclipse.egit.ui.internal.commit_[3.0.0,3.1.0)。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:15.313 !MESSAGE 缺少已导入包 org.eclipse.egit.ui.internal.synchronize.model_[3.0.0,3.1.0)。 !SUBENTRY 2 org.eclipse.egit.mylyn.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少已导入包 org.eclipse.ui.plugin_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.314 !MESSAGE 未解析 bundle org.eclipse.egit.ui_3.0.0.201306101825-r [118]。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.team.ui_[3.6.200,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_[3.4.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_[3.4.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.compare_[3.4.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_[3.4.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.jsch.ui_[1.1.100,2.0.0)。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_[3.4.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator_[3.3.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少可选的必需 bundle org.eclipse.search_[3.4.0,4.0.0)。 !SUBENTRY 2 org.eclipse.egit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少可选的必需 bundle org.eclipse.debug.ui_[3.4.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.314 !MESSAGE 未解析 bundle org.eclipse.emf.common.ui_2.8.0.v20130610-0406 [120]。 !SUBENTRY 2 org.eclipse.emf.common.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.emf.common.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.ide_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.314 !MESSAGE 未解析 bundle org.eclipse.emf.edit.ui_2.9.0.v20130610-0406 [127]。 !SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.ui.views_[3.4.0,4.0.0)。 !SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.emf.common.ui_[2.8.0,3.0.0)。 !SUBENTRY 2 org.eclipse.emf.edit.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.ide_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.314 !MESSAGE 未解析 bundle org.eclipse.epp.mpc.ui_1.2.0.v20130612-1900 [130]。 !SUBENTRY 2 org.eclipse.epp.mpc.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.ui_3.6.0。 !SUBENTRY 2 org.eclipse.epp.mpc.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少必需的 bundle org.eclipse.equinox.p2.ui.discovery_[1.0.0,1.1.0)。 !SUBENTRY 2 org.eclipse.epp.mpc.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.intro_0.0.0。 !SUBENTRY 2 org.eclipse.epp.mpc.ui 2 0 2014-05-26 16:34:15.314 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.intro.universal_0.0.0。 !SUBENTRY 2 org.eclipse.epp.mpc.ui 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.equinox.p2.ui_1.0.4。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.315 !MESSAGE 未解析 bundle org.eclipse.epp.package.rcp_2.0.0.20130613-0530 [131]。 !SUBENTRY 2 org.eclipse.epp.package.rcp 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.platform_[4.3.0,5.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.315 !MESSAGE 未解析 bundle org.eclipse.equinox.p2.ui_2.3.0.v20130528-2154 [172]。 !SUBENTRY 2 org.eclipse.equinox.p2.ui 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.ui_3.6.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.equinox.security.ui_[1.0.0,2.0.0)。 !SUBENTRY 2 org.eclipse.equinox.p2.ui 2 0 2014-05-26 16:34:15.315 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.315 !MESSAGE 未解析 bundle org.eclipse.equinox.p2.ui.discovery_1.0.0.v20130502-0334 [173]。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.discovery 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.discovery 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.ui.browser_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.discovery 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.equinox.p2.ui_2.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.315 !MESSAGE 未解析 bundle org.eclipse.equinox.p2.ui.importexport_1.1.0.v20130327-2119 [174]。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.equinox.p2.ui_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少已导入包 org.eclipse.equinox.internal.p2.ui_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少已导入包 org.eclipse.equinox.internal.p2.ui.dialogs_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少已导入包 org.eclipse.equinox.internal.p2.ui.model_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少已导入包 org.eclipse.equinox.internal.p2.ui.viewers_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2014-05-26 16:34:15.315 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.315 !MESSAGE 未解析 bundle org.eclipse.equinox.p2.ui.sdk_1.0.300.v20130503-1750 [175]。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.ui_3.6.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.equinox.p2.ui_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2014-05-26 16:34:15.315 !MESSAGE Missing optionally imported package org.eclipse.compare_0.0.0. !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2014-05-26 16:34:15.315 !MESSAGE Missing optionally imported package org.eclipse.compare.structuremergeviewer_0.0.0. !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2014-05-26 16:34:15.315 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.315 !MESSAGE 未解析 bundle org.eclipse.equinox.p2.ui.sdk.scheduler_1.2.0.v20130603-2142 [176]。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2014-05-26 16:34:15.315 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.equinox.p2.ui_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少已导入包 org.eclipse.equinox.internal.p2.ui_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少已导入包 org.eclipse.equinox.internal.p2.ui.actions_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少已导入包 org.eclipse.equinox.internal.p2.ui.query_0.0.0。 !SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少已导入包 org.eclipse.equinox.p2.ui_[2.0.0,3.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.316 !MESSAGE 未解析 bundle org.eclipse.equinox.security.ui_1.1.100.v20130327-1442 [182]。 !SUBENTRY 2 org.eclipse.equinox.security.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.4.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.316 !MESSAGE 未解析 bundle org.eclipse.gef_3.9.0.201305060205 [186]。 !SUBENTRY 2 org.eclipse.gef 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.views_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.gef 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_[3.2.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.316 !MESSAGE 未解析 bundle org.eclipse.help.ui_4.0.0.v20130515-1955 [189]。 !SUBENTRY 2 org.eclipse.help.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.6.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.316 !MESSAGE 未解析 bundle org.eclipse.jdt_3.9.0.v20130605-2000 [191]。 !SUBENTRY 2 org.eclipse.jdt 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui.intro_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui.cheatsheets_[3.2.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.316 !MESSAGE 未解析 bundle org.eclipse.jdt.apt.ui_3.3.300.v20120516-0617 [195]。 !SUBENTRY 2 org.eclipse.jdt.apt.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.ui_[3.2.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.apt.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.316 !MESSAGE 未解析 bundle org.eclipse.jdt.debug.ui_3.6.200.v20130514-0841 [201]。 !SUBENTRY 2 org.eclipse.jdt.debug.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.debug.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.debug.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.debug.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.debug.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.debug.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.debug.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.debug.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui.console_[3.4.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.debug.ui 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.search_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.316 !MESSAGE 未解析 bundle org.eclipse.jdt.junit_3.7.200.v20130514-0733 [203]。 !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2014-05-26 16:34:15.316 !MESSAGE 缺少必需的 bundle org.eclipse.ui.views_[3.3.100,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.debug.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.debug.ui_[3.3.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.compare_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ltk.ui.refactoring_[3.5.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.317 !MESSAGE 未解析 bundle org.eclipse.jdt.ui_3.9.0.v20130605-1748 [208]。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.search_[3.7.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.debug.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.compare_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.team.ui_[3.4.100,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui.console_[3.4.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui.views_[3.3.100,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ltk.ui.refactoring_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator_[3.3.200,4.0.0)。 !SUBENTRY 2 org.eclipse.jdt.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator.resources_[3.4.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.317 !MESSAGE 未解析 bundle org.eclipse.jsch.ui_1.1.400.v20111007-1310 [224]。 !SUBENTRY 2 org.eclipse.jsch.ui 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.317 !MESSAGE 未解析 bundle org.eclipse.ltk.ui.refactoring_3.7.100.v20130605-1748 [226]。 !SUBENTRY 2 org.eclipse.ltk.ui.refactoring 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ltk.ui.refactoring 2 0 2014-05-26 16:34:15.317 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator_[3.3.200,4.0.0)。 !SUBENTRY 2 org.eclipse.ltk.ui.refactoring 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.compare_[3.5.0,4.0.0)。 !SUBENTRY 2 org.eclipse.ltk.ui.refactoring 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.team.ui_[3.4.100,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.321 !MESSAGE 未解析 bundle org.eclipse.m2e.core.ui_1.4.0.20130601-0317 [229]。 !SUBENTRY 2 org.eclipse.m2e.core.ui 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui.console_3.4.0。 !SUBENTRY 2 org.eclipse.m2e.core.ui 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_3.5.2。 !SUBENTRY 2 org.eclipse.m2e.core.ui 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.core.ui 2 0 2014-05-26 16:34:15.321 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.321 !MESSAGE 未解析 bundle org.eclipse.m2e.discovery_1.4.0.20130601-0317 [230]。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.equinox.p2.ui.discovery_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.m2e.core.ui_[1.4.0,1.5.0)。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.equinox.p2.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少已导入包 org.eclipse.equinox.internal.p2.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少已导入包 org.eclipse.equinox.internal.p2.ui.dialogs_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少已导入包 org.eclipse.equinox.internal.p2.ui.model_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少已导入包 org.eclipse.equinox.p2.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.discovery 2 0 2014-05-26 16:34:15.321 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.321 !MESSAGE 未解析 bundle org.eclipse.m2e.editor_1.4.0.20130601-0317 [231]。 !SUBENTRY 2 org.eclipse.m2e.editor 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.search_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.editor 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.editor 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.wst.sse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.editor 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.editor 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.m2e.editor.xml_[1.4.0,1.5.0)。 !SUBENTRY 2 org.eclipse.m2e.editor 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.m2e.core.ui_[1.4.0,1.5.0)。 !SUBENTRY 2 org.eclipse.m2e.editor 2 0 2014-05-26 16:34:15.321 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.321 !MESSAGE 未解析 bundle org.eclipse.m2e.editor.xml_1.4.0.20130601-0317 [232]。 !SUBENTRY 2 org.eclipse.m2e.editor.xml 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.editor.xml 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.editor.xml 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.wst.xml.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.editor.xml 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.wst.sse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.editor.xml 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.editor.xml 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.m2e.core.ui_[1.4.0,1.5.0)。 !SUBENTRY 2 org.eclipse.m2e.editor.xml 2 0 2014-05-26 16:34:15.321 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.321 !MESSAGE 未解析 bundle org.eclipse.m2e.jdt_1.4.0.20130601-0317 [233]。 !SUBENTRY 2 org.eclipse.m2e.jdt 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.jdt 2 0 2014-05-26 16:34:15.321 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.jdt 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.m2e.core.ui_[1.4.0,1.5.0)。 !SUBENTRY 2 org.eclipse.m2e.jdt 2 0 2014-05-26 16:34:15.322 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.322 !MESSAGE 未解析 bundle org.eclipse.m2e.launching_1.4.0.20130601-0317 [234]。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.ui.externaltools_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.ui.console_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.debug.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.debug.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.m2e.core.ui_[1.4.0,1.5.0)。 !SUBENTRY 2 org.eclipse.m2e.launching 2 0 2014-05-26 16:34:15.322 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.322 !MESSAGE 未解析 bundle org.eclipse.m2e.lifecyclemapping.defaults_1.4.0.20130601-0317 [235]。 !SUBENTRY 2 org.eclipse.m2e.lifecyclemapping.defaults 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.m2e.jdt_[1.4.0,1.5.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.322 !MESSAGE 未解析 bundle org.eclipse.m2e.logback.appender_1.4.0.20130601-0317 [236]。 !SUBENTRY 2 org.eclipse.m2e.logback.appender 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.ui.console_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.logback.appender 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.m2e.core.ui_[1.4.0,1.5.0)。 !SUBENTRY 2 org.eclipse.m2e.logback.appender 2 0 2014-05-26 16:34:15.322 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.322 !MESSAGE 未解析 bundle org.eclipse.m2e.refactoring_1.4.0.20130601-0317 [241]。 !SUBENTRY 2 org.eclipse.m2e.refactoring 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.refactoring 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.ui_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.refactoring 2 0 2014-05-26 16:34:15.322 !MESSAGE 缺少必需的 bundle org.eclipse.compare_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.refactoring 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.refactoring 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ltk.ui.refactoring_0.0.0。 !SUBENTRY 2 org.eclipse.m2e.refactoring 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.m2e.core.ui_[1.4.0,1.5.0)。 !SUBENTRY 2 org.eclipse.m2e.refactoring 2 0 2014-05-26 16:34:15.323 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.323 !MESSAGE 未解析 bundle org.eclipse.m2e.scm_1.4.0.20130601-0317 [242]。 !SUBENTRY 2 org.eclipse.m2e.scm 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.m2e.core.ui_[1.4.0,1.5.0)。 !SUBENTRY 2 org.eclipse.m2e.scm 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_3.5.2。 !SUBENTRY 2 org.eclipse.m2e.scm 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_3.5.1。 !SUBENTRY 2 org.eclipse.m2e.scm 2 0 2014-05-26 16:34:15.323 !MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE)(version=1.7)))". !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.323 !MESSAGE 未解析 bundle org.eclipse.mylyn.bugzilla.ui_3.9.0.v20130612-0100 [245]。 !SUBENTRY 2 org.eclipse.mylyn.bugzilla.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.bugzilla.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.compare_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.bugzilla.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui.views_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.bugzilla.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.bugzilla.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.bugzilla.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.tasks.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.bugzilla.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.bugzilla.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.workbench_[3.8.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.323 !MESSAGE 未解析 bundle org.eclipse.mylyn.builds.ui_1.1.0.v20130612-0100 [247]。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.console_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少可选的必需 bundle org.eclipse.jdt.debug.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少可选的必需 bundle org.eclipse.jdt.junit_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少可选的必需 bundle org.eclipse.jdt.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.team.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.compare_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.notifications.ui_1.0.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.repositories.ui_1.0.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_3.8.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.workbench_3.8.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.tasks.ui_3.8.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.team.ui_3.8.0。 !SUBENTRY 2 org.eclipse.mylyn.builds.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.versions.ui_1.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.323 !MESSAGE 未解析 bundle org.eclipse.mylyn.commons.notifications.ui_1.1.0.v20130612-0100 [253]。 !SUBENTRY 2 org.eclipse.mylyn.commons.notifications.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.notifications.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.notifications.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_3.8.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.notifications.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.workbench_3.8.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.323 !MESSAGE 未解析 bundle org.eclipse.mylyn.commons.repositories.ui_1.1.0.v20130612-0100 [256]。 !SUBENTRY 2 org.eclipse.mylyn.commons.repositories.ui 2 0 2014-05-26 16:34:15.323 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.repositories.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.repositories.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_3.8.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.repositories.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.workbench_3.8.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.324 !MESSAGE 未解析 bundle org.eclipse.mylyn.commons.ui_3.9.0.v20130612-0100 [258]。 !SUBENTRY 2 org.eclipse.mylyn.commons.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.324 !MESSAGE 未解析 bundle org.eclipse.mylyn.commons.workbench_3.9.0.v20130612-0100 [259]。 !SUBENTRY 2 org.eclipse.mylyn.commons.workbench 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.workbench 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.browser_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.workbench 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少可选的必需 bundle org.eclipse.ui.editors_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.workbench 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.workbench 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.commons.workbench 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_3.8.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.324 !MESSAGE 未解析 bundle org.eclipse.mylyn.context.tasks.ui_3.9.0.v20130612-0100 [262]。 !SUBENTRY 2 org.eclipse.mylyn.context.tasks.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.context.tasks.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.context.tasks.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.context.tasks.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.workbench_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.context.tasks.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.context.ui_3.8.0。 !SUBENTRY 2 org.eclipse.mylyn.context.tasks.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.monitor.ui_3.8.0。 !SUBENTRY 2 org.eclipse.mylyn.context.tasks.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.tasks.ui_3.8.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.324 !MESSAGE 未解析 bundle org.eclipse.mylyn.context.ui_3.9.0.v20130612-0100 [263]。 !SUBENTRY 2 org.eclipse.mylyn.context.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.context.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.context.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui.views_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.context.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.context.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.workbench_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.context.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.monitor.ui_[3.8.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.324 !MESSAGE 未解析 bundle org.eclipse.mylyn.debug.ui_3.9.0.v20130612-0100 [264]。 !SUBENTRY 2 org.eclipse.mylyn.debug.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.context.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.debug.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.ide.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.debug.ui 2 0 2014-05-26 16:34:15.324 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.debug.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.debug.ui_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.325 !MESSAGE 未解析 bundle org.eclipse.mylyn.discovery.ui_3.9.0.v20130612-0100 [266]。 !SUBENTRY 2 org.eclipse.mylyn.discovery.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.discovery.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.discovery.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.workbench_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.discovery.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少可选的必需 bundle org.eclipse.equinox.p2.ui_1.0.4。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.325 !MESSAGE 未解析 bundle org.eclipse.mylyn.gerrit.ui_2.0.0.v20130612-0100 [268]。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.workbench_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.reviews.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.tasks.ui_3.8.0。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.compare_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.egit.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.tasks.ui_3.8.0。 !SUBENTRY 2 org.eclipse.mylyn.gerrit.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.325 !MESSAGE 未解析 bundle org.eclipse.mylyn.git.ui_1.1.0.v20130612-0100 [270]。 !SUBENTRY 2 org.eclipse.mylyn.git.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.git.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.versions.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.git.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.egit.ui_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.325 !MESSAGE 未解析 bundle org.eclipse.mylyn.hudson.ui_1.1.0.v20130612-0100 [273]。 !SUBENTRY 2 org.eclipse.mylyn.hudson.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.hudson.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.builds.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.hudson.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少可选的必需 bundle org.eclipse.ecf.discovery_3.0.0。 !SUBENTRY 2 org.eclipse.mylyn.hudson.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少可选的必需 bundle org.eclipse.ecf.provider.discovery_2.0.0。 !SUBENTRY 2 org.eclipse.mylyn.hudson.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少可选的必需 bundle org.eclipse.ecf.provider.jmdns_3.0.0。 !SUBENTRY 2 org.eclipse.mylyn.hudson.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.notifications.ui_1.0.0。 !SUBENTRY 2 org.eclipse.mylyn.hudson.ui 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.repositories.ui_1.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.325 !MESSAGE 未解析 bundle org.eclipse.mylyn.ide.ant_3.9.0.v20130612-0100 [274]。 !SUBENTRY 2 org.eclipse.mylyn.ide.ant 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ant.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.ide.ant 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.debug.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.ide.ant 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.ide.ant 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.ide.ant 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.ide.ant 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.ui.views_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.ide.ant 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.ide.ant 2 0 2014-05-26 16:34:15.325 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.context.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.ide.ant 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.monitor.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.ide.ant 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.ide.ui_[3.8.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.326 !MESSAGE 未解析 bundle org.eclipse.mylyn.ide.ui_3.9.0.v20130612-0100 [275]。 !SUBENTRY 2 org.eclipse.mylyn.ide.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.ide.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.ide.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_3.4.0。 !SUBENTRY 2 org.eclipse.mylyn.ide.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.ide.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.context.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.ide.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.resources.ui_[3.8.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.326 !MESSAGE 未解析 bundle org.eclipse.mylyn.java.tasks_3.9.0.v20130612-0100 [276]。 !SUBENTRY 2 org.eclipse.mylyn.java.tasks 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.debug.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.tasks 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.debug.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.tasks 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.junit_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.tasks 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.tasks 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.tasks 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.tasks.ui_[3.8.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.326 !MESSAGE 未解析 bundle org.eclipse.mylyn.java.ui_3.9.0.v20130612-0100 [277]。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.debug.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.debug.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.junit_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.search_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui.views_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.context.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.monitor.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.resources.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.java.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.ide.ui_[3.8.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.326 !MESSAGE 未解析 bundle org.eclipse.mylyn.monitor.ui_3.9.0.v20130612-0100 [279]。 !SUBENTRY 2 org.eclipse.mylyn.monitor.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.326 !MESSAGE 未解析 bundle org.eclipse.mylyn.pde.ui_3.9.0.v20130612-0100 [280]。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui.editors_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.326 !MESSAGE 缺少必需的 bundle org.eclipse.ui.workbench.texteditor_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.pde.ui_3.4.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.pde.api.tools.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.debug.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.search_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.debug.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.junit_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.jdt.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.context.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.ide.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.java.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.java.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.monitor.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.pde.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.resources.ui_[3.8.0,4.0.0)。 !SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-26 16:34:15.327 !MESSAGE 未解析 bundle org.eclipse.mylyn.resources.ui_3.9.0.v20130612-0100 [281]。 !SUBENTRY 2 org.eclipse.mylyn.resources.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.ui.ide_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.resources.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.ui_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.resources.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.ui.navigator_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.resources.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.compare_0.0.0。 !SUBENTRY 2 org.eclipse.mylyn.resources.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.resources.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.context.ui_[3.8.0,4.0.0)。 !SUBENTRY 2 org.eclipse.mylyn.resources.ui 2 0 2014-05-26 16:34:15.327 !MESSAGE 缺少必需的 bundle org.eclipse.mylyn.monitor.ui_[3.8.0,4.0.0)。 !SUBENTRY 1 org.eclipse.o
安装eclipse出错log,什么原因
[2019-08-25 21:28:31] Executing bootstrap tasks [2019-08-25 21:28:31] Java(TM) SE Runtime Environment 12.0.2+10 [2019-08-25 21:28:31] Product org.eclipse.products.epp.package.jee.2019-06 [2019-08-25 21:28:31] Bundle org.eclipse.oomph.setup 1.13.0.v20190530-1228, build=4030, branch=ed8d2fdcc99c1d3461399fc1bee02645433fa697 [2019-08-25 21:28:31] Bundle org.eclipse.oomph.setup.core 1.13.0.v20190531-1228, build=4030, branch=ed8d2fdcc99c1d3461399fc1bee02645433fa697 [2019-08-25 21:28:31] Bundle org.eclipse.oomph.setup.p2 1.11.0.v20190530-1228, build=4030, branch=ed8d2fdcc99c1d3461399fc1bee02645433fa697 [2019-08-25 21:28:31] Performing P2 Director (Eclipse IDE for Enterprise Java Developers (2019-06)) [2019-08-25 21:28:31] Offline = false [2019-08-25 21:28:31] Mirrors = true [2019-08-25 21:28:31] Resolving 89 requirements from 3 repositories to E:\eclipse\eclipse\eclipse [2019-08-25 21:28:31] Requirement epp.package.jee [4.12.0,5.0.0) [2019-08-25 21:28:31] Requirement org.eclipse.platform.feature.group [4.12.0,5.0.0) [2019-08-25 21:28:31] Requirement org.eclipse.rcp.feature.group [4.12.0,5.0.0) [2019-08-25 21:28:31] Requirement org.eclipse.buildship.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.cft.server.core.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.cft.server.ui.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.common.doc.user.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.connectivity.doc.user.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.connectivity.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.connectivity.oda.designer.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.connectivity.oda.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.doc.user.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.apache.derby.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.hsqldb.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.ibm.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.ingres.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.jdbc.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.jdt.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.msft.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.mysql.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.oda.designer.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.oda.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.oracle.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.postgresql.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.sap.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.sdk.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.sqlite.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.sybase.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.intro.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.modelbase.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sdk.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.data.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.ddl.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.parsers.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.results.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqltools.doc.user.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.eclemma.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.egit.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.egit.mylyn.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.epp.mpc.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jdt.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.common.eclipselink.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.common.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.jaxb.eclipselink.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.jaxb.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.jpa.eclipselink.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.jpa.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jsf.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.common.fproj.enablement.jdt.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.enterprise_ui.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.server_adapters.ext.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.server_adapters.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.server_ui.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.web_ui.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.webpageeditor.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.ws.axis2tools.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.ws.cxf.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.ws.jaxws.dom.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.ws.jaxws.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.logback.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.wtp.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.wtp.jaxrs.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.wtp.jpa.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.wtp.jsf.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn.bugzilla_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn.context_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn.ide_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn.java_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn.wikitext_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.pde.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.tips.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.tm.terminal.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.common.fproj.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.jsdt.chromium.debug.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.jsdt.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.server_adapters.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.web_ui.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.xml_ui.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.xsl.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.oomph.setup.feature.group [2019-08-25 21:28:32] Repository http://download.eclipse.org/technology/epp/packages/2019-06 [2019-08-25 21:28:32] Repository http://download.eclipse.org/releases/2019-06/201906191000 [2019-08-25 21:28:32] Repository http://download.eclipse.org/oomph/updates/milestone/latest [2019-08-25 21:32:11] ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 Unable to read repository at http://download.eclipse.org/releases/2019-06/201906191000/content.xml.xz. java.net.SocketTimeoutException: Read timed out at java.base/java.net.SocketInputStream.socketRead0(Native Method) at java.base/java.net.SocketInputStream.socketRead(SocketInputStream.java:115) at java.base/java.net.SocketInputStream.read(SocketInputStream.java:168) at java.base/java.net.SocketInputStream.read(SocketInputStream.java:140) at org.apache.http.impl.io.SessionInputBufferImpl.streamRead(SessionInputBufferImpl.java:137) at org.apache.http.impl.io.SessionInputBufferImpl.fillBuffer(SessionInputBufferImpl.java:153) at org.apache.http.impl.io.SessionInputBufferImpl.read(SessionInputBufferImpl.java:206) at org.apache.http.impl.io.ChunkedInputStream.read(ChunkedInputStream.java:189) at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:135) at java.base/java.util.zip.InflaterInputStream.fill(InflaterInputStream.java:243) at java.base/java.util.zip.InflaterInputStream.read(InflaterInputStream.java:159) at java.base/java.util.zip.GZIPInputStream.read(GZIPInputStream.java:118) at org.apache.http.client.entity.LazyDecompressingInputStream.read(LazyDecompressingInputStream.java:70) at java.base/java.io.FilterInputStream.read(FilterInputStream.java:133) at java.base/java.io.FilterInputStream.read(FilterInputStream.java:107) at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer$1.performFileTransfer(AbstractRetrieveFileTransfer.java:178) at org.eclipse.ecf.filetransfer.FileTransferJob.run(FileTransferJob.java:74) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63) [2019-08-25 21:32:11]
eclipse RCP开发 toobar位置问题
RCP开发,在工具栏添加一个按钮,plugin.xml配置内容如下 ``` <menuContribution locationURI="toolbar:org.eclipse.ui.trim.command2"> <toolbar id="com.test.navigator.toolbar1" label="demo"> <command commandId="com.test.navigator.demo" label="demo" style="push" tooltip="demo"> </command> </toolbar> </menuContribution> ``` 查阅eclipse官方资料, locationURI="toolbar:org.eclipse.ui.trim.command2"可以实现按钮位置早 top right显示, ![图片说明](https://img-ask.csdn.net/upload/201910/24/1571894798_444698.png) 但是实际位置显示在如下图1的位置,我想显示在2的位置,也就是最右边,怎样才能显示在2的位置? ![图片说明](https://img-ask.csdn.net/upload/201910/24/1571894686_176012.png)
Eclipse RCP 开发可以用Swing 开发图形界面吗?
最近在搞Eclipse RCP开发,需要对之前的一款Swing开发的软件移植到Eclipse RCP下,但发现Eclipse RCP都是用的SWT、JFace技术,不知道能不能将Swing移植过去?
eclipse的WindowBuilder插件打开错误
按照论坛上的正常步骤安装了windowBuilder插件后,在eclipse新建WindowBuilder 的时候,总是报错: The selected wizard could not be started. Plug-in org.eclipse.wb.rcp was unable to load class org.eclipse.wb.internal.rcp.wizards.project.NewProjectWizard. An error occurred while automatically activating bundle org.eclipse.wb.core.java (590). 怎么解决啊?
Eclipse Rcp 调用XML Editor
使用eclipse rcp 开发要调用xml的编辑器 FileDialog dialog=new FileDialog(window.getShell(),SWT.NONE); String filePath=dialog.open(); String editorID="org.eclipse.wst.xml.ui.internal.tabletree.XMLMultiPageEditorPart"; FileEditorInput input=new FileEditorInput(filePath); page.openEditor(input,editorID); 提示:PartInitException :Text editor does not have a document provider
eclipse RCP开发中如何在Activator中获取plugin.xml中配置的action
action是在extensions里重写eclipse提供的标准扩展点:org.eclipse.ui.actionSets。想在Activator中获取此action对象并调用setEnable()方法,达到控制按钮的可用和禁用状态。望各位大神帮忙!
RCP学习遇到的问题
最近在学习Eclipse的RCP,下载了mp3m的源码,Import到我的Eclipse3.5运行后抛出异常,请哪位“牛人”帮忙解决下,谢谢! 异常如下: !SESSION 2010-08-15 22:21:08.470 ----------------------------------------------- eclipse.buildId=unknown java.version=1.6.0_17 java.vendor=Sun Microsystems Inc. BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_CN Framework arguments: -application com.siemens.ct.mp3m.application Command-line arguments: -application com.siemens.ct.mp3m.application -data H:\source code\java\workspace/../runtime-com.siemens.ct.mp3m.application -dev file:H:/source code/java/workspace/.metadata/.plugins/org.eclipse.pde.core/com.siemens.ct.mp3m.application/dev.properties -os win32 -ws win32 -arch x86 -consoleLog !ENTRY org.eclipse.osgi 2 0 2010-08-15 22:21:09.531 !MESSAGE The activator com.siemens.ct.mp3m.Activator for bundle com.siemens.ct.mp3m is invalid !STACK 0 org.osgi.framework.BundleException: The activator com.siemens.ct.mp3m.Activator for bundle com.siemens.ct.mp3m is invalid at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:157) at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:751) at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:352) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:280) at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:408) at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:238) at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1193) at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160) at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:874) at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243) at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:189) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514) at org.eclipse.equinox.launcher.Main.run(Main.java:1311) at org.eclipse.equinox.launcher.Main.main(Main.java:1287) Caused by: java.lang.ClassNotFoundException: com.siemens.ct.mp3m.Activator at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:494) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398) at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105) at java.lang.ClassLoader.loadClass(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.loadClass(BundleLoader.java:326) at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:231) at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:150) ... 23 more Root exception: java.lang.ClassNotFoundException: com.siemens.ct.mp3m.Activator at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:494) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398) at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105) at java.lang.ClassLoader.loadClass(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.loadClass(BundleLoader.java:326) at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:231) at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:150) at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:751) at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:352) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:280) at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:408) at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:238) at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1193) at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160) at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:874) at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243) at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:189) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514) at org.eclipse.equinox.launcher.Main.run(Main.java:1311) at org.eclipse.equinox.launcher.Main.main(Main.java:1287) !ENTRY org.eclipse.osgi 4 0 2010-08-15 22:21:09.531 !MESSAGE Application error !STACK 1 org.eclipse.core.runtime.CoreException: Plug-in com.siemens.ct.mp3m was unable to load class com.siemens.ct.mp3m.Application. at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.throwException(RegistryStrategyOSGI.java:180) at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:162) at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:874) at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243) at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:189) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514) at org.eclipse.equinox.launcher.Main.run(Main.java:1311) at org.eclipse.equinox.launcher.Main.main(Main.java:1287) Caused by: java.lang.ClassNotFoundException: com.siemens.ct.mp3m.Application at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:494) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398) at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105) at java.lang.ClassLoader.loadClass(Unknown Source) at org.eclipse.osgi.internal.loader.BundleLoader.loadClass(BundleLoader.java:326) at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:231) at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1193) at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160) ... 16 more
Eclipse RCP
在eclipse rcp开发中怎样嵌入pdf浏览!好像swt支持这个!怎么写呢?比如怎样在一个view中显示呀!求答!!多谢!
Eclipse RCP的IApplication.EXIT_RESTART
最近帮人在写一个小型的局域网的C/S的系统。由于系统需要登录,所以我想在登录前先连接数据库,判断数据库是否连接正常。 我的数据库连接类是一个单例的DBconn类。DBconn类通过一个单例Env类获得properties类型文件的数据。我在Application类中获得DBconn的实例后,判断连接是否为空。如果为空,就修改properties类型的配置文件。 文件可以正常修改,但是由于是DBconn由于是单例,所以无法修改。 于是就想通过让系统重启一遍,让类重新加载。所以就在Application类中使用Application.EXIT_RESTART进行重启。 但是结果还是一样的。文件可以修改,但是DBConn从Env类获得的数据还是旧的数据,没有发生变化。 有什么办法可以让类重新加载吗?以便于重新获得文件中的配置信息?
eclipse删除后重新安装时出错
具体错误提示如下: [2016-03-10 23:07:32] Executing bootstrap tasks [2016-03-10 23:07:32] Product org.eclipse.products.epp.package.java.mars [2016-03-10 23:07:32] Bundle org.eclipse.oomph.setup 1.3.0.v20160213-0953, build=2199, branch=7194e06d06a87ced95779121a8281b59b9abdf81, commit=7194e06d06a87ced95779121a8281b59b9abdf81 [2016-03-10 23:07:32] Bundle org.eclipse.oomph.setup.core 1.3.0.v20160213-0953, build=2199, branch=7194e06d06a87ced95779121a8281b59b9abdf81, commit=7194e06d06a87ced95779121a8281b59b9abdf81 [2016-03-10 23:07:32] Bundle org.eclipse.oomph.setup.p2 1.3.0.v20160213-0953, build=2199, branch=7194e06d06a87ced95779121a8281b59b9abdf81, commit=7194e06d06a87ced95779121a8281b59b9abdf81 [2016-03-10 23:07:32] Performing P2 Director (Eclipse IDE for Java Developers (Mars)) [2016-03-10 23:07:32] Offline = false [2016-03-10 23:07:32] Mirrors = true [2016-03-10 23:07:32] Resolving 5 requirements from 3 repositories to C:\Users\Cassie_\eclipse\java-mars2\eclipse [2016-03-10 23:07:32] Requirement epp.package.java [4.5.0,4.6.0) [2016-03-10 23:07:32] Requirement org.eclipse.platform.feature.group [4.5.0,4.6.0) [2016-03-10 23:07:32] Requirement org.eclipse.rcp.feature.group [4.5.0,4.6.0) [2016-03-10 23:07:32] Requirement org.eclipse.jdt.feature.group [3.11.0,3.12.0) [2016-03-10 23:07:32] Requirement org.eclipse.oomph.setup.feature.group [2016-03-10 23:07:32] Repository http://download.eclipse.org/technology/epp/packages/mars [2016-03-10 23:07:32] Repository http://download.eclipse.org/releases/mars/201602261000 [2016-03-10 23:07:32] Repository http://download.eclipse.org/oomph/updates/milestone/latest [2016-03-10 23:11:08] ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 Unable to read repository at http://download.eclipse.org/releases/mars/201602261000/content.xml.xz. java.net.SocketException: Connection reset at java.net.SocketInputStream.read(Unknown Source) at java.net.SocketInputStream.read(Unknown Source) at org.apache.http.impl.io.AbstractSessionInputBuffer.read(AbstractSessionInputBuffer.java:198) at org.apache.http.impl.io.ContentLengthInputStream.read(ContentLengthInputStream.java:178) at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:137) at java.io.FilterInputStream.read(Unknown Source) at java.net.SocketInputStream.read(Unknown Source) at org.apache.http.impl.io.AbstractSessionInputBuffer.read(AbstractSessionInputBuffer.java:198) at org.apache.http.impl.io.ContentLengthInputStream.read(ContentLengthInputStream.java:178) at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:137) at java.io.FilterInputStream.read(Unknown Source) at java.io.FilterInputStream.read(Unknown Source) at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer$1.performFileTransfer(AbstractRetrieveFileTransfer.java:178) at org.eclipse.ecf.filetransfer.FileTransferJob.run(FileTransferJob.java:73) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55) [2016-03-10 23:11:08] 就是这样的,求大神帮忙,要开始写作业了啊!! PS:就是直接又下了一个Eclipse,然后运行.exe文件的时候,出错了。打不开。
安装windowbuilder报错
Cannot complete the install because one or more required items could not be found. Software being installed: SWT Designer 1.6.0.r36x201305212028 (org.eclipse.wb.rcp.feature.feature.group 1.6.0.r36x201305212028) Missing requirement: SWT Designer 1.6.0.r36x201305212028 (org.eclipse.wb.rcp.feature.feature.group 1.6.0.r36x201305212028) requires 'org.eclipse.pde.feature.group 3.2.0' but it could not be found
如何打包Eclipse RCP?
如题,按照以下方式,我创建了一个RCP项目 ![图片说明](https://img-ask.csdn.net/upload/201512/14/1450079322_252727.jpg) ![图片说明](https://img-ask.csdn.net/upload/201512/14/1450079428_238594.jpg) ![图片说明](https://img-ask.csdn.net/upload/201512/14/1450079438_318518.jpg) ![图片说明](https://img-ask.csdn.net/upload/201512/14/1450079494_611312.jpg) 想请教一下有人熟悉RCP开发么,怎么将其导出为exe程序。 我尝试过网上所说的各种例子,总是出现各种问题。 在官网上也没用找出具体的导出实例。
eclipse rcp中怎么为文本框绑定复合键事件
在进行eclipse rcp程序开发时想为一个Text文本框,shift+a?
如何在eclipse rcp_gef应用中实现eclipse的outline视图的工具条栏?
如图,这是系统的outline,有工具条的 ![CSDN移动问答][1] 如图,这是gef应用中做的outline,无工具条 ![CSDN移动问答][2] 如图,这就是要实现的工具条以及其上的功能,亦是问题之所在 ![CSDN移动问答][3] 求高手,求解! 这是MyGraphicalEditor类中实现outline的代码: protected class OutlinePage extends ContentOutlinePage { private ScrollableThumbnail thumbnail; private DisposeListener disposeListener; private SashForm sash; public OutlinePage() { super(new TreeViewer()); } public void createControl(Composite parent) { sash = new SashForm(parent, SWT.VERTICAL); IActionBars bars = getSite().getActionBars(); ActionRegistry ar = getActionRegistry(); bars.setGlobalActionHandler(ActionFactory.COPY.getId(), ar.getAction(ActionFactory.COPY.getId())); bars.setGlobalActionHandler(ActionFactory.PASTE.getId(), ar.getAction(ActionFactory.PASTE.getId())); getViewer().createControl(sash); getViewer().setEditDomain(getEditDomain()); getViewer().setEditPartFactory(new AppTreeEditPartFactory()); getViewer().setContents(model); getSelectionSynchronizer().addViewer(getViewer()); Canvas canvas = new Canvas(sash, SWT.BORDER); LightweightSystem lws = new LightweightSystem(canvas); thumbnail = new ScrollableThumbnail( (Viewport) ((ScalableRootEditPart) getGraphicalViewer() .getRootEditPart()).getFigure()); thumbnail.setSource(((ScalableRootEditPart) getGraphicalViewer() .getRootEditPart()) .getLayer(LayerConstants.PRINTABLE_LAYERS)); lws.setContents(thumbnail); disposeListener = new DisposeListener() { @Override public void widgetDisposed(DisposeEvent e) { if (thumbnail != null) { thumbnail.deactivate(); thumbnail = null; } } }; getGraphicalViewer().getControl().addDisposeListener( disposeListener); } [1]: http://dl2.iteye.com/upload/attachment/0090/4122/4b06dd89-e22d-3c6c-a773-fe0dcc233ab9.jpg [2]: http://dl2.iteye.com/upload/attachment/0090/4143/c98420af-5692-3e0f-ab74-d105b70752af.jpg [3]: http://dl2.iteye.com/upload/attachment/0090/4145/215aed88-178b-345b-9290-36d51f8f3985.jpg
solaris 上运行eclipse
工作上要求在solaris上搭建eclipse RCP的开发环境。我在官网下载了最新的eclipse-rcp-gtk版本。但在solaris 上解压后, 到解压目录下直接执行 ./eclipse 提示 eclipse: Invalid argument
爬虫福利二 之 妹子图网MM批量下载
爬虫福利一:27报网MM批量下载 点击 看了本文,相信大家对爬虫一定会产生强烈的兴趣,激励自己去学习爬虫,在这里提前祝:大家学有所成! 目标网站:妹子图网 环境:Python3.x 相关第三方模块:requests、beautifulsoup4 Re:各位在测试时只需要将代码里的变量path 指定为你当前系统要保存的路径,使用 python xxx.py 或IDE运行即可。 ...
Java学习的正确打开方式
在博主认为,对于入门级学习java的最佳学习方法莫过于视频+博客+书籍+总结,前三者博主将淋漓尽致地挥毫于这篇博客文章中,至于总结在于个人,实际上越到后面你会发现学习的最好方式就是阅读参考官方文档其次就是国内的书籍,博客次之,这又是一个层次了,这里暂时不提后面再谈。博主将为各位入门java保驾护航,各位只管冲鸭!!!上天是公平的,只要不辜负时间,时间自然不会辜负你。 何谓学习?博主所理解的学习,它是一个过程,是一个不断累积、不断沉淀、不断总结、善于传达自己的个人见解以及乐于分享的过程。
程序员必须掌握的核心算法有哪些?
由于我之前一直强调数据结构以及算法学习的重要性,所以就有一些读者经常问我,数据结构与算法应该要学习到哪个程度呢?,说实话,这个问题我不知道要怎么回答你,主要取决于你想学习到哪些程度,不过针对这个问题,我稍微总结一下我学过的算法知识点,以及我觉得值得学习的算法。这些算法与数据结构的学习大多数是零散的,并没有一本把他们全部覆盖的书籍。下面是我觉得值得学习的一些算法以及数据结构,当然,我也会整理一些看过...
Elastic:菜鸟上手指南
您们好,我是Elastic的刘晓国。如果大家想开始学习Elastic的话,那么这里将是你理想的学习园地。在我的博客几乎涵盖了你想学习的许多方面。在这里,我来讲述一下作为一个菜鸟该如何阅读我的这些博客文章。 我们可以按照如下的步骤来学习: 1)Elasticsearch简介:对Elasticsearch做了一个简单的介绍 2)Elasticsearch中的一些重要概念:cluster, n...
大学四年自学走来,这些私藏的实用工具/学习网站我贡献出来了
大学四年,看课本是不可能一直看课本的了,对于学习,特别是自学,善于搜索网上的一些资源来辅助,还是非常有必要的,下面我就把这几年私藏的各种资源,网站贡献出来给你们。主要有:电子书搜索、实用工具、在线视频学习网站、非视频学习网站、软件下载、面试/求职必备网站。 注意:文中提到的所有资源,文末我都给你整理好了,你们只管拿去,如果觉得不错,转发、分享就是最大的支持了。 一、电子书搜索 对于大部分程序员...
为啥国人偏爱Mybatis,而老外喜欢Hibernate/JPA呢?
关于SQL和ORM的争论,永远都不会终止,我也一直在思考这个问题。昨天又跟群里的小伙伴进行了一番讨论,感触还是有一些,于是就有了今天这篇文。 声明:本文不会下关于Mybatis和JPA两个持久层框架哪个更好这样的结论。只是摆事实,讲道理,所以,请各位看官勿喷。 一、事件起因 关于Mybatis和JPA孰优孰劣的问题,争论已经很多年了。一直也没有结论,毕竟每个人的喜好和习惯是大不相同的。我也看...
Java知识体系最强总结(2020版)
更新于2019-12-15 10:38:00 本人从事Java开发已多年,平时有记录问题解决方案和总结知识点的习惯,整理了一些有关Java的知识体系,这不是最终版,会不定期的更新。也算是记录自己在从事编程工作的成长足迹,通过博客可以促进博主与阅读者的共同进步,结交更多志同道合的朋友。特此分享给大家,本人见识有限,写的博客难免有错误或者疏忽的地方,还望各位大佬指点,在此表示感激不尽。 文章目录...
计算机专业的书普遍都这么贵,你们都是怎么获取资源的?
介绍几个可以下载编程电子书籍的网站。 1.Github Github上编程书资源很多,你可以根据类型和语言去搜索。推荐几个热门的: free-programming-books-zh_CN:58K 星的GitHub,编程语言、WEB、函数、大数据、操作系统、在线课程、数据库相关书籍应有尽有,共有几百本。 Go语言高级编程:涵盖CGO,Go汇编语言,RPC实现,Protobuf插件实现,Web框架实...
卸载 x 雷某度!GitHub 标星 1.5w+,从此我只用这款全能高速下载工具!
作者 | Rocky0429 来源 | Python空间 大家好,我是 Rocky0429,一个喜欢在网上收集各种资源的蒟蒻… 网上资源眼花缭乱,下载的方式也同样千奇百怪,比如 BT 下载,磁力链接,网盘资源等等等等,下个资源可真不容易,不一样的方式要用不同的下载软件,因此某比较有名的 x 雷和某度网盘成了我经常使用的工具。 作为一个没有钱的穷鬼,某度网盘几十 kb 的下载速度让我...
复习一周,京东+百度一面,不小心都拿了Offer
京东和百度一面都问了啥,面试官百般刁难,可惜我全会。
毕业5年,我问遍了身边的大佬,总结了他们的学习方法
我问了身边10个大佬,总结了他们的学习方法,原来成功都是有迹可循的。
推荐10个堪称神器的学习网站
每天都会收到很多读者的私信,问我:“二哥,有什么推荐的学习网站吗?最近很浮躁,手头的一些网站都看烦了,想看看二哥这里有什么新鲜货。” 今天一早做了个恶梦,梦到被老板辞退了。虽然说在我们公司,只有我辞退老板的份,没有老板辞退我这一说,但是还是被吓得 4 点多都起来了。(主要是因为我掌握着公司所有的核心源码,哈哈哈) 既然 4 点多起来,就得好好利用起来。于是我就挑选了 10 个堪称神器的学习网站,推...
这些软件太强了,Windows必装!尤其程序员!
Windows可谓是大多数人的生产力工具,集娱乐办公于一体,虽然在程序员这个群体中都说苹果是信仰,但是大部分不都是从Windows过来的,而且现在依然有很多的程序员用Windows。 所以,今天我就把我私藏的Windows必装的软件分享给大家,如果有一个你没有用过甚至没有听过,那你就赚了????,这可都是提升你幸福感的高效率生产力工具哦! 走起!???? NO、1 ScreenToGif 屏幕,摄像头和白板...
大学四年因为知道了这32个网站,我成了别人眼中的大神!
依稀记得,毕业那天,我们导员发给我毕业证的时候对我说“你可是咱们系的风云人物啊”,哎呀,别提当时多开心啦????,嗯,我们导员是所有导员中最帅的一个,真的???? 不过,导员说的是实话,很多人都叫我大神的,为啥,因为我知道这32个网站啊,你说强不强????,这次是绝对的干货,看好啦,走起来! PS:每个网站都是学计算机混互联网必须知道的,真的牛杯,我就不过多介绍了,大家自行探索,觉得没用的,尽管留言吐槽吧???? 社...
看完这篇HTTP,跟面试官扯皮就没问题了
我是一名程序员,我的主要编程语言是 Java,我更是一名 Web 开发人员,所以我必须要了解 HTTP,所以本篇文章就来带你从 HTTP 入门到进阶,看完让你有一种恍然大悟、醍醐灌顶的感觉。 最初在有网络之前,我们的电脑都是单机的,单机系统是孤立的,我还记得 05 年前那会儿家里有个电脑,想打电脑游戏还得两个人在一个电脑上玩儿,及其不方便。我就想为什么家里人不让上网,我的同学 xxx 家里有网,每...
史上最全的IDEA快捷键总结
现在Idea成了主流开发工具,这篇博客对其使用的快捷键做了总结,希望对大家的开发工作有所帮助。
阿里程序员写了一个新手都写不出的低级bug,被骂惨了。
这种新手都不会范的错,居然被一个工作好几年的小伙子写出来,差点被当场开除了。
一文带你看清 HTTP 所有概念
上一篇文章我们大致讲解了一下 HTTP 的基本特征和使用,大家反响很不错,那么本篇文章我们就来深究一下 HTTP 的特性。我们接着上篇文章没有说完的 HTTP 标头继续来介绍(此篇文章会介绍所有标头的概念,但没有深入底层) HTTP 标头 先来回顾一下 HTTP1.1 标头都有哪几种 HTTP 1.1 的标头主要分为四种,通用标头、实体标头、请求标头、响应标头,现在我们来对这几种标头进行介绍 通用...
作为一个程序员,CPU的这些硬核知识你必须会!
CPU对每个程序员来说,是个既熟悉又陌生的东西? 如果你只知道CPU是中央处理器的话,那可能对你并没有什么用,那么作为程序员的我们,必须要搞懂的就是CPU这家伙是如何运行的,尤其要搞懂它里面的寄存器是怎么一回事,因为这将让你从底层明白程序的运行机制。 随我一起,来好好认识下CPU这货吧 把CPU掰开来看 对于CPU来说,我们首先就要搞明白它是怎么回事,也就是它的内部构造,当然,CPU那么牛的一个东...
【综合篇】浏览器的工作原理:浏览器幕后揭秘
web(给达达前端加星标,提升前端技能)了解浏览器是如何工作的,能够让你站在更高的角度去理解前端浏览器的发展历程的三大路线,第一是应用程序web化,第二是web应用移动化,第三是web操...
破14亿,Python分析我国存在哪些人口危机!
一、背景 二、爬取数据 三、数据分析 1、总人口 2、男女人口比例 3、人口城镇化 4、人口增长率 5、人口老化(抚养比) 6、各省人口 7、世界人口 四、遇到的问题 遇到的问题 1、数据分页,需要获取从1949-2018年数据,观察到有近20年参数:LAST20,由此推测获取近70年的参数可设置为:LAST70 2、2019年数据没有放上去,可以手动添加上去 3、将数据进行 行列转换 4、列名...
作为一个程序员,内存和磁盘的这些事情,你不得不知道啊!!!
截止目前,我已经分享了如下几篇文章: 一个程序在计算机中是如何运行的?超级干货!!! 作为一个程序员,CPU的这些硬核知识你必须会! 作为一个程序员,内存的这些硬核知识你必须懂! 这些知识可以说是我们之前都不太重视的基础知识,可能大家在上大学的时候都学习过了,但是嘞,当时由于老师讲解的没那么有趣,又加上这些知识本身就比较枯燥,所以嘞,大家当初几乎等于没学。 再说啦,学习这些,也看不出来有什么用啊!...
这个世界上人真的分三六九等,你信吗?
偶然间,在知乎上看到一个问题 一时间,勾起了我深深的回忆。 以前在厂里打过两次工,做过家教,干过辅导班,做过中介。零下几度的晚上,贴过广告,满脸、满手地长冻疮。 再回首那段岁月,虽然苦,但让我学会了坚持和忍耐。让我明白了,在这个世界上,无论环境多么的恶劣,只要心存希望,星星之火,亦可燎原。 下文是原回答,希望能对你能有所启发。 如果我说,这个世界上人真的分三六九等,...
B 站上有哪些很好的学习资源?
哇说起B站,在小九眼里就是宝藏般的存在,放年假宅在家时一天刷6、7个小时不在话下,更别提今年的跨年晚会,我简直是跪着看完的!! 最早大家聚在在B站是为了追番,再后来我在上面刷欧美新歌和漂亮小姐姐的舞蹈视频,最近两年我和周围的朋友们已经把B站当作学习教室了,而且学习成本还免费,真是个励志的好平台ヽ(.◕ฺˇд ˇ◕ฺ;)ノ 下面我们就来盘点一下B站上优质的学习资源: 综合类 Oeasy: 综合...
死磕Lambda表达式(二):Lambda的使用
在哪使用Lambda表达式?怎么样正确的使用Lambda表达式?
史上最牛逼的 Eclipse 快捷键,提高开发效率!
如果你在使用IDEA,请参考博主另外的一篇idea快捷键的博客。
在三线城市工作爽吗?
我是一名程序员,从正值青春年华的 24 岁回到三线城市洛阳工作,至今已经 6 年有余。一不小心又暴露了自己的实际年龄,但老读者都知道,我驻颜有术,上次去看房子,业务员肯定地说:“小哥肯定比我小,我今年还不到 24。”我只好强颜欢笑:“你说得对。” 从我拥有记忆到现在进入而立之年,我觉得,我做过最明智的选择有下面三个: 1)高中三年,和一位女同学保持着算不上朋友的冷淡关系;大学半年,把这位女同学追到...
CSS操作之你不得不知的一些小技巧(一)ヾ(Ő∀Ő๑)ノ太棒了!!
目录 CSS单行/多行文本,超出隐藏并显示省略号 1. CSS单行/多行文本,超出隐藏并显示省略号 方法一:使用CSS属性 单行文本溢出显示省略号 width: 100px; overflow: hidden; text-overflow:ellipsis; //文本溢出显示省略号 white-space: nowrap; //文本不会换...
强烈推荐 10 款珍藏的 Chrome 浏览器插件
Firebug 的年代,我是火狐(Mozilla Firefox)浏览器的死忠;但后来不知道为什么,该插件停止了开发,导致我不得不寻求一个新的网页开发工具。那段时间,不少人开始推荐 Chrome 浏览器,我想那就试试吧,期初我觉得用起来很别扭,毕竟我不是一个“喜新厌旧”的人。但用的次数越来越多,也就习惯了。 Chrome 浏览器有一个好处,就是插件极其丰富,只有你想不到的,没有你找不到的,这恐怕是...
我以为我对数据库索引十分了解,直到我遇到了阿里面试官。
索引的数据结构分析,数据库面试到索引最常见的问题分析,我总结了一下。
Java程序员都需要懂的「反射」
前言 只有光头才能变强。 文本已收录至我的GitHub精选文章,欢迎Star:https://github.com/ZhongFuCheng3y/3y 今天来简单写一下Java的反射。本来没打算写反射这个知识点的,只是不少的读者都问过我:“你的知识点好像缺了反射阿。能不能补一下?” 这周末也有点空了,所以来写写我对反射的简单理解。这篇是入门文章,没有高深的知识点,希望能对新人有帮助。如果...
相关热词 c# singleton c#中类的默认值是 c#各种进制之间的转换 c# 正则表达式保留汉字 c#后台跨域 c#基础代码大全 c#指定combox选择 c#关系 mono c# 相差毫秒 用c#做一个简易计算器
立即提问