doukao2180
2016-05-10 05:59 阅读 22

错误:PleskFatalException:StatInfo-> getActiveDomainsNumber()失败:sysinfo失败:sh:/ usr / local / psa / admin / bin / sysinfo:权限被拒绝

I ran this command /usr/local/psa/admin/bin/mail_auth_view but this was displaying none. I surf the net and found that this /usr/local/psa/admin/sbin/mchk --without-spam command can repair it but plesk become more worst.

I tried /usr/local/psa/admin/sbin/mchk --with-spam 1004 ==> Checking for: mail_imap_restore... fail 1005 ==> Checking for: mail_spam_restore... fail

/etc/init.d/psa start but seeing following error:

ERROR: PleskFatalException: StatInfo->getActiveDomainsNumber() failed: sysinfo failed: sh: /usr/local/psa/admin/bin/sysinfo: Permission denied

Additionally, an exception has occurred while trying to report this error: PleskFatalException StatInfo->getProductVersion failed: sysinfo failed: sh: /usr/local/psa/admin/bin/sysinfo: Permission denied (class.SystemStatisticsForm.php:123)

Search for related Knowledge Base articles`

Please advise

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

1条回答 默认 最新

  • drv13270 drv13270 2016-05-11 07:29

    Check files:

    # ls -la /usr/local/psa/admin/bin/sysinfo
    lrwxrwxrwx. 1 root root 15 Apr  7  2015 /usr/local/psa/admin/bin/sysinfo -> ../sbin/wrapper
    # ls -la /usr/local/psa/admin/sbin/sysinfo
    -rwxr-x---. 1 root root 72920 Aug 11  2014 /usr/local/psa/admin/sbin/sysinfo
    

    Pay attention that /usr/local/psa/admin/bin/sysinfo it is a symlink to ../sbin/wrapper

    wrapper file:

     # ls -lZ /usr/local/psa/admin/sbin/wrapper
     ---s--x---. root psaadm system_u:object_r:bin_t:s0       /usr/local/psa/admin/sbin/wrapper
     # ls -lnZ /usr/local/psa/admin/sbin/wrapper
     ---s--x---. 0 501 system_u:object_r:bin_t:s0       /usr/local/psa/admin/sbin/wrapper
     # file /usr/local/psa/admin/sbin/wrapper
     /usr/local/psa/admin/sbin/wrapper: setuid ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, stripped
     # lsattr /usr/local/psa/admin/sbin/wrapper
     -------------e- /usr/local/psa/admin/sbin/wrapper
    

    If you on a RedHat-like OS, for a test, you can temporary switch off Selinux by:

    # setenforce 0
    # getenforce
    Permissive
    
    点赞 评论 复制链接分享