Nginx PHP5.6权限错误

我的Nginx error.log文件中出现以下错误,我需要做些什么才能防止这种情况发生 发生了吗?</ p>


2016/06/28 09:43:37 [crit] 1631#0:* 1 connect()到
unix:/ run / php / php5.6 fpm.sock失败(13:权限被拒绝),而
连接到上游,客户端:192.168.56.1,服务器:my-vm,请求:
“GET / HTTP / 1.1”,上游:
“fastcgi :// unix:/run/php/php5.6-fpm.sock:“,$ host:”my-vm-1“</ p>
</ blockquote>

Nginx运行时 www-数据权限。 错误消息引用的文件夹的权限( /run/php/php5.6-fpm.sock </ code>)如下所示:</ p>

   drwxr-xr-x 20 root root 700 Jun 28 09:45 run 
drwxr-xr-x 2 www-data www-data 80 Jun 28 09:44 php
srw-rw ---- 1 www-data www-data 0月28日09:44 php5.6-fpm.sock
</ code> </ pre>

PHP的用户/组( /etc/php/5.6/fpm/pool .d / www.conf </ code>)是:</ p>

  user = www-data 
group = www-data
listen.owner = www-data
listen.group = www-data
listen.mode = 0660
</ code> </ pre>

nginx.conf </ code>文件没有任何用户</ code >价值集。 有些人建议将其设置为 www-data </ code>,但如果我设置此Nginx服务将无法启动,那么为什么会省略它。</ p>
</ div>

展开原文

原文

I am getting the following error in my Nginx error.log file, what do I need to do to prevent this from happening?

2016/06/28 09:43:37 [crit] 1631#0: *1 connect() to unix:/run/php/php5.6 fpm.sock failed (13: Permission denied) while connecting to upstream, client: 192.168.56.1, server: my-vm, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/run/php/php5.6-fpm.sock:", $host: "my-vm-1"

Nginx runs with www-data permissions. The permissions of the folder that the error message is referencing (/run/php/php5.6-fpm.sock) are as follows:

drwxr-xr-x 20 root       root         700 Jun 28 09:45 run
drwxr-xr-x 2  www-data   www-data     80  Jun 28 09:44 php
srw-rw---- 1  www-data   www-data     0   Jun 28 09:44 php5.6-fpm.sock

The user/group of PHP (/etc/php/5.6/fpm/pool.d/www.conf) is:

user = www-data
group = www-data
listen.owner = www-data
listen.group = www-data
listen.mode = 0660

The nginx.conf file does not have any user value set. Some people have suggested setting this to www-data, but if I set this the Nginx service won't start, hence why it is ommitted.

dongxieyi9115
dongxieyi9115 一个解决方案是在nginx配置中使用nginx作为用户,并将用户nginx添加到www-data组
4 年多之前 回复
dongshi1934
dongshi1934 这个问题似乎已经存在于此:stackoverflow.com/questions/23443398/...
4 年多之前 回复

1个回答



我通过将以下用户指令添加到我的nginx.conf文件的 top </ strong>来解决此问题:</ p>

 用户www-data www-data; 
</ code> </ pre>
</ div>

展开原文

原文

I fixed this by adding the following user directive to the top of my nginx.conf file:

user www-data www-data;

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐