douzong5057
2016-04-28 12:31
浏览 47
已采纳

El capitan是否破坏了我安装的php?

I have tried almost everything to fix this, but nothing helped me, I am using OSX 10.11.4 El Capitan, I have installed homebrew and php55 with it, version 5.5.34. I am using some php extensions along with it, for example pgsql. Once I have upgraded to Capitan I had to solve some problems with apache but it was not a big problem, but for the php, it looks like it stopped loading my extensions. As I kind of noob in this I don't really know what info to share. This is my apache error_lo which is repeating:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/Cellar/php55/5.5.34/lib/php/extensions/no-debug-non-zts-20121212/php_pgsql.dll' - dlopen(/usr/local/Cellar/php55/5.5.34/lib/php/extensions/no-debug-non-zts-20121212/php_pgsql.dll, 9): image not found in Unknown on line 0
[Thu Apr 28 14:21:12.002839 2016] [mpm_prefork:notice] [pid 27896] AH00163: Apache/2.4.18 (Unix) PHP/5.5.34 configured -- resuming normal operations
[Thu Apr 28 14:21:12.002910 2016] [core:notice] [pid 27896] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'

When I try to go to the extension folder it is not even there, only a folder called build is in the /usr/local/Cellar/php55/5.5.34/lib/php

Can someone please help me?

Thanks in advance

图片转代码服务由CSDN问答提供 功能建议

我已经尝试了几乎所有东西来解决这个问题,但没有任何帮助, 我正在使用OSX 10.11.4 El Capitan ,我已经安装了自制软件和php55,版本5.5.34。 我正在使用一些php扩展,例如pgsql。 一旦我升级到Capitan我必须用apache解决一些问题但它不是 很大的问题,但对于PHP,它似乎停止加载我的扩展。 因为我在这里有点菜鸟,我真的不知道要分享什么信息。 这是我的apache error_lo,它重复:

  PHP警告:PHP启动:无法加载动态库'/usr/local/Cellar/php55/5.5.34/lib/  php / extensions / no-debug-non-zts-20121212 / php_pgsql.dll' -  dlopen(/usr/local/Cellar/php55/5.5.34/lib/php/extensions/no-debug-non-zts-20121212/  php_pgsql.dll,9):在0号线上未知的图像
 [4月28日星期四14:21:12.002839 2016] [mpm_prefork:通知] [pid 27896] AH00163:Apache / 2.4.18(Unix)PHP / 5.5  .34配置 - 恢复正常操作
 [4月28日14:21:12.002910 2016] [核心:通知] [pid 27896] AH00094:命令行:'/ usr / sbin / httpd -D FOREGROUND'
   
 
 

当我尝试转到扩展文件夹时,它甚至不存在,只有一个名为build的文件夹位于/usr/local/Cellar/php55/5.5.34/lib中 / php

有人可以帮助我吗?

提前致谢

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

1条回答 默认 最新

  • dousi0144 2016-04-29 15:02
    最佳回答

    So the solution for installing php --with-pgsql is to install xcode in console first.

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题