mongodb php-driver:php启动错误

我按照此处显示的指南安装了mongodb php-driver:

https://github.com/mongodb/mongo-php-driver </ p>

但是当我运行 #php </ code>命令时,它显示以下错误:</ p>

 警告:PHP启动:无法加载动态库
'/ opt / lampp / lib / php / extensions / no-debug-non-zts-20151012 / mongodb.so' -

/ opt / lampp / lib / php / extensions / no-debug-non-zts-20151012 / mongodb.so: symbol
CRYPTO_get_locking_callback,版本OPENSSL_1.0.0未在文件
libcrypto.so.1.0.0中定义,链接时间参考在第0行的未知中
</ code> </ pre>


< / p>

我正在使用:
</ p>

 
Lampp Stack </ strong>
PHP: 7.0.0 </ strong>
OS: Ubuntu 15.10 </ strong>
Pear: 1.10.1 </ strong> </ pre>

如果您有任何解决方案,请提出建议。 提前致谢。</ p>
</ div>

展开原文

原文

I installed mongodb php-driver as per the guideline shown here:
https://github.com/mongodb/mongo-php-driver

But when I run #php command its showing following error :

Warning: PHP Startup: Unable to load dynamic library
'/opt/lampp/lib/php/extensions/no-debug-non-zts-20151012/mongodb.so' - 
/opt/lampp/lib/php/extensions/no-debug-non-zts-20151012/mongodb.so: symbol 
CRYPTO_get_locking_callback, version OPENSSL_1.0.0 not defined in file 
libcrypto.so.1.0.0 with link time reference in Unknown on line 0


I am using :

Lampp Stack
PHP : 7.0.0 
OS: Ubuntu 15.10
Pear: 1.10.1

Please suggest any solution if you have. Thanks in advance .

1个回答

It looks like you don't have SSL library enabled/installed correctly on your system. Most likely, I am thinking you don't have the libssl-dev package installed.

You should install this with apt-get install libssl-dev libsasl2-dev, and then reinstall the mongodb extension with pecl uninstall mongodb && pecl install mongodb.

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐