dongpu5874
dongpu5874
2015-11-12 17:52

安装Composer失败“openssl extension is missing”错误

已采纳

I've been trying to install Composer for about a month now on a Windows 10 computer. Every time I run the Windows OS installer, it gives me this error:

Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:

The openssl extension is missing, which means that secure HTTPS transfers are impossible.
If possible you should enable it or recompile php with --with-openssl

I've checked in my php.ini file (C:\Bitnami\wampstack-5.4.39-0\php\php.ini) and it is not commented out. I've checked for the DLL itself in the ETC folder, it's there. I've restarted my Apache Web Server several times. Heck, I've reinstalled PHP and my WAMP Servers. Nothing is working. I've tried downloading a fresh Composer installer thinking maybe my original one got corrupted some how. Still doesn't work. Am I missing something here?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

1条回答

  • dounei5721 dounei5721 6年前

    After about another week of research and talking with a University professor about it, I ultimately found that the issue stemmed from my Bitnami installation path. Installing the wampstack as it defaulted by the installer (wampstack-version#) seems to cause problems in composers ability to install. Make sure to install it without the version on the end of the wampstack path.

    点赞 评论 复制链接分享