Xdebug远程调试 - 在步骤中崩溃,步入等

我在vagrant中有一个虚拟开发环境,我使用puphpet.com进行了配置。 直到今天,一切都处于完美的工作状态,但突然 - 似乎与我的行为无关 - Xdebug停止工作。</ p>

我使用phpstorm进行开发和调试,结果是,我设置了一个断点 在phpstorm中,然后我在phpstorm和Chrome Xdebug Helper扩展中启用了远程调试监听器。 当代码到达断点时,执行暂停并且我能够调查不同的变量,但是当我尝试使用continue,step over或step into逐步执行我的代码时,phpstorm只是退出调试模式并且我的浏览器显示 503错误。</ p>

我查看了系统日志,它显示这是一个分段错误,所以没有太多的线索。 然后我启用了Xdebug日志。 我真的不知道如何解释它,但在我看来,它记录它成功地能够在断点处停止然后当错误发生它只是停止记录 - 这是有道理的,考虑到它似乎是一个 分段错误。</ p>

我尝试使用 pecl upgrade xdebug </ code>更新xdebug,我尝试在不同于端口9000默认端口的端口上运行它。 没有改变任何内容。</ p>

我现在可能会尝试什么建议?</ p>

我的虚拟机正在运行Ubuntu 14.04 LTS x64。 PHP是v5.6.14,Xdebug是v2.3.2。</ p>

这是我的puphpet配置的链接,以防它可能有所帮助: https://gist.github.com/webconsult/dfa23f65ce2394624b0d </ p>
</ div>

展开原文

原文

I have a virtual development environment in vagrant which I have provisioned using puphpet.com. Until today, everything was in perfect working order, but suddently - seemingly unrelated to my actions - Xdebug stopped working.

I use phpstorm for development and debugging and what happens is, I set a breakpoint in phpstorm, then I enable the remote debugging listener in phpstorm and the Chrome Xdebug Helper extension. When the code reaches the breakpoint, execution is paused and I am able to investigate the different variables, but as soon as I try to step through my code with either continue, step over or step into, phpstorm simply exits debug mode and my browser shows a 503 error.

I had a look at the syslog, which shows that it is a segmentation error, so not much in the way of clues there. Then I enabled the Xdebug log. I don't really know how to interpret it, but it seems to me that it logs that it was succesfully able to stop at a breakpoint and then when the error happens it just stops logging - which makes sense considering that it seems to be a segmentation error.

I tried updating xdebug with pecl upgrade xdebug and I tried running it on a port different from the port 9000 default. Did not change anything.

Any suggestions what I might try now?

My virtual machine is running Ubuntu 14.04 LTS x64. PHP is v5.6.14 and Xdebug is v2.3.2.

Here is a link to my puphpet configuration in case it might help: https://gist.github.com/webconsult/dfa23f65ce2394624b0d

duanbipu7601
duanbipu7601 不,对不起我还没有。如果有人可以帮助我,我将不胜感激。
4 年多之前 回复
doulai8405
doulai8405 我有同样的问题,你有没有想到它?
4 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐