doctrine / migrations与symfony 2.2不兼容。*

long story short: Im using Symfony 2.2.* (yes, its old) and a DEV-Enviroment using a deploy script. This script runs "composer update". Every thing works fine until today. Now I recive this error:

     - Conclusion: remove symfony/symfony v2.2.11
     - Conclusion: don't install symfony/symfony v2.2.11
     - Conclusion: don't install symfony/symfony v2.2.10
     - Conclusion: don't install symfony/symfony v2.2.9
     - Conclusion: don't install symfony/symfony v2.2.8
     - Conclusion: don't install symfony/symfony v2.2.7
     - Conclusion: don't install symfony/symfony v2.2.6
     - Conclusion: don't install symfony/symfony v2.2.5
     - Conclusion: don't install symfony/symfony v2.2.4
     - Conclusion: don't install symfony/symfony v2.2.3
     - Conclusion: don't install symfony/symfony v2.2.2
     - Conclusion: don't install symfony/symfony v2.2.1

And especially this both:

    - doctrine/migrations dev-master requires symfony/yaml ~2.3 -> satisfiable by symfony/yaml[v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.0-BETA1, v2.4.0-BETA2, v2.4.0-RC1, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.0-BETA1, v2.5.0-BETA2, v2.5.0-RC1, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.0-BETA1, v2.6.0-BETA2, v2.6.1, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.0-BETA1, v2.7.0-BETA2].

+

    - doctrine/migrations dev-master requires symfony/yaml ~2.3 -> satisfiable by symfony/yaml[v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.0-BETA1, v2.4.0-BETA2, v2.4.0-RC1, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.0-BETA1, v2.5.0-BETA2, v2.5.0-RC1, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.0-BETA1, v2.6.0-BETA2, v2.6.1, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.0-BETA1, v2.7.0-BETA2]

My composer.json looks like

"name": "symfony/framework-standard-edition",
"description": "The \"Symfony Standard Edition\" distribution",
"autoload": {
    "psr-0": { "": "src/" }
},
"require": {
    "php": ">=5.3.3",
    "symfony/symfony": "2.2.*",
    "doctrine/orm": "~2.2,>=2.2.3",
    "doctrine/doctrine-bundle": "1.2.*",
    "twig/extensions": "1.0.*",
    "symfony/assetic-bundle": "2.1.*",
    "symfony/swiftmailer-bundle": "2.2.*",
    "symfony/monolog-bundle": "2.2.*",
    "sensio/distribution-bundle": "2.2.*",
    "sensio/framework-extra-bundle": "2.2.*",
    "sensio/generator-bundle": "2.2.*",
    "jms/security-extra-bundle": "1.4.*",
    "jms/di-extra-bundle": "1.3.*",
    "doctrine/migrations" : "dev-master",
"doctrine/doctrine-migrations-bundle": "dev-master",
"igorw/file-serve-bundle": "1.0.*",
    "phpunit/phpunit": "3.7.*",
    "kriswallsmith/assetic" : "v1.1.0-alpha4"

},
"scripts": {
    "post-install-cmd": [
        "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap",
        "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache",
        "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets",
        "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile"
    ],
    "post-update-cmd": [
        "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap",
        "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache",
        "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets",
        "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile"
    ]
},
"config": {
    "bin-dir": "bin"
},
"minimum-stability": "alpha",
"extra": {
    "symfony-app-dir": "app",
    "symfony-web-dir": "web",
    "branch-alias": {
        "dev-master": "2.2-dev"
    }
}

Does everyone have a idea to solve this Problem? I've tried to upgrade Symfony to 2.3 but this also caused new dependency problems, with

"jms/security-extra-bundle": "1.4.*",
"jms/di-extra-bundle": "1.3.*",

for example.

Best would be to set doctrine:migrations to a version that works with symfony 2.2.* but I dont have a Idea where to get it, or what I have to change.

I looking forward to your answers and would like to thank every one here (you helped me out thousend times before). Thanks for all ;-)

doupaimo8288
doupaimo8288 一般来说,最好执行一个作曲家安装而不是作曲家更新,这样你就可以确定你使用的是哪个版本的库(我希望经过测试)。您需要对composer.lock文件进行版本化(如作曲家文档中所述)。希望这有帮助。
5 年多之前 回复

1个回答

There is list of releases of migration bundle. Here is your working config(i tested it on my pc):

 "require": {
    "php": ">=5.3.3",
    "symfony/symfony": "2.2.*",
    "symfony/debug": "2.3.*",
    "doctrine/orm": "~2.2,>=2.2.3",
    "doctrine/doctrine-bundle": "1.2.*",
    "twig/extensions": "1.0.*",
    "symfony/assetic-bundle": "2.1.*",
    "symfony/swiftmailer-bundle": "2.2.*",
    "symfony/monolog-bundle": "2.2.*",
    "sensio/distribution-bundle": "2.2.*",
    "sensio/framework-extra-bundle": "2.2.*",
    "sensio/generator-bundle": "2.2.*",
    "jms/security-extra-bundle": "1.4.*",
    "jms/di-extra-bundle": "1.3.*",
    "doctrine/doctrine-migrations-bundle": "v1.0.0",
    "igorw/file-serve-bundle": "1.0.*",
    "phpunit/phpunit": "3.7.*",
    "kriswallsmith/assetic" : "v1.1.0-alpha4"
  },
dongwupei7803
dongwupei7803 你能解释一下你的解决方案,我们可以学习。 谢谢。
4 年多之前 回复
dongruoqiong9017
dongruoqiong9017 完善! 像魅力一样工作;-)非常感谢你。 你救了我的一天。
5 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐