duanpi5733
duanpi5733
2014-06-26 19:50
浏览 62
已采纳

域名范围的Cookie未在Chrome中保存.uk二级域名

Google Chrome doesn't seem to be saving my domain-wide session cookie.

My server is sending the following headers out:

HTTP/1.1 200 OK
Date: Thu, 26 Jun 2014 19:42:48 GMT
Server: Apache
Set-Cookie: AuthID=a0dbc62667968c7d3c47dd80068a8b76; path=/; domain=.aerox.uk
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Content-Length: 109
Keep-Alive: timeout=10, max=50
Connection: Keep-Alive
Content-Type: text/html

But on subsequent requests the cookie is not being sent back out. If I try the same page in Internet Explorer is works just fine. Also if I change it from a domain-wide cookie to a sub-domain specific one it also works fine.

If I click on the page icon in the address bar and look at cookies set by this domain it shows none in either the allowed or blocked lists.


Here is some of my cookie config.

In .htaccess:

# PHP Settings
php_value session.cookie_domain ".aerox.uk"
php_value session.name "AuthID"
#php_flag session.auto_start 1

php_value auto_prepend_file "../auto_header.php"

In auto_header.php:

<?php
session_name('AuthID');
session_set_cookie_params(0,'/','.aerox.uk');
session_start();
?>
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • duanchouyi6730
    duanchouyi6730 2014-07-01 17:12
    已采纳

    After testing a few different versions and releases of Google Chrome it seems to be an issue with how releases prior to 36 treat .uk Second Level Domains (SLD).

    I've searched through the change logs and found that versions prior to version 36 use an old version of the public suffix list.

    This is the change that fixes Chrome to allow .uk domains to work correctly

    点赞 评论

相关推荐