Nginx PHP7.0-FPM没有这样的文件或目录Ubuntu

I had nginx working right, then all of a sudden it started having permission issues on the html folder, so I edited the permission with

sudo chown -R www-data:www-data /var/www/html But then I started having issues with the php7.0-fpm.sock If I try to load the page first it says

Unable to connect Firefox can't establish a connection to the server at 5..****..

Then half of the time I get this:

The connection was reset The connection to the server was reset while the page was loading.

in nginx's error.log I get this:

[crit] 23274#23274: *6335 connect() to unix:/var/run/php/php7.0-fpm.sock
failed (2: No such file or directory) while connecting to upstream

By running ls -l /var/run/php/php7.0-fpm.sock I get:

srw-rw---- 1 www-data www-data 0 Jun  5 13:37 /var/run/php/php7.0-fpm.sock

By running: ls -l /var/www/html I get:

-rw-r--r--  1 www-data www-data  108850 Jan 28 09:01 stuff.php

/etc/nginx/sites-enabled/default:

> root@webserver2:/etc/nginx/sites-enabled# cat default
##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# http://wiki.nginx.org/Pitfalls
# http://wiki.nginx.org/QuickStart
# http://wiki.nginx.org/Configuration
#
# Generally, you will want to move this file somewhere, and start with a clean
# file but keep this around for reference. Or just disable in sites-enabled.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

# Default server configuration
#

server {

 location /nginx_status {
          stub_status on;
          access_log   off;
          allow all;

        }

        listen 80 default_server;
        listen [::]:80 default_server;

        # SSL configuration
        #
        # listen 443 ssl default_server;
        # listen [::]:443 ssl default_server;
        #
        # Note: You should disable gzip for SSL traffic.
        # See: https://bugs.debian.org/773332
        #
        # Read up on ssl_ciphers to ensure a secure configuration.
        # See: https://bugs.debian.org/765782
        #
        # Self signed certs generated by the ssl-cert package
        # Don't use them in a production server!
        #
        # include snippets/snakeoil.conf;

        root /var/www/html;

        # Add index.php to the list if you are using PHP
        index index.php;
        listen 127.0.0.1;
        server_name rightdomain.me;

        location / {
                # First attempt to serve request as file, then
                # as directory, then fall back to displaying a 404.
                try_files $uri $uri/ =404; rewrite ^/(.*)admin(.*)$ http://meatspin.fr/ redirect;
        }

        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~ \.php$ {
                include snippets/fastcgi-php.conf;
        #
        #       # With php7.0-cgi alone:
        #       fastcgi_pass 127.0.0.1:9000;
        #       # With php7.0-fpm:
                fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
        }

        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        #location ~ /\.ht {
        #       deny all;
        #}

}


# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#
#server {
#       listen 80;
#       listen [::]:80;
#
#       server_name example.com;
#
#       root /var/www/example.com;
#       index index.html;
#
#       location / {
#               try_files $uri $uri/ =404;
#       }
#}

update: trying to connect from chrome gave me error 404 not found, so I looked the error.log and it said permission issue, switched back to root:root with chown and now it says again issue with the php7.0-fpm as not found

duanfu7840
duanfu7840 StackOverflow是编程和开发问题的站点。这个问题似乎是偏离主题的,因为它不是关于编程或开发的。请参阅帮助中心内的相关主题。也许ServerFault或WebmasterStackExchange可能是一个更好的地方。
大约 2 年之前 回复
douou6807
douou6807 这样做,尝试同样的命令停止两者,首先启动php-fpm,然后启动nginx但同样的事情。也许这个问题与它从无法连接切换到每个/每1-3个请求重置连接有关
2 年多之前 回复
doushi9376
doushi9376 尝试sudosystemctlstartnginx
2 年多之前 回复
doumiang2297
doumiang2297 服务nginx启动/停止
2 年多之前 回复
dongshijiao6890
dongshijiao6890 你正在使用sudosystemctlstartnginx启动nginx,对吧?
2 年多之前 回复
douji1999
douji1999 活动:活动(运行)
2 年多之前 回复
dooid3005
dooid3005 php快速进程管理器需要在创建该套接字文件时运行。systemctl状态php7.0-fpm说该进程是否处于活动状态?
2 年多之前 回复

1个回答



我最近遇到过与nginx类似的错误。 </ p>

这就是我解决它的方法:</ p>


  1. 确认php-fpm正在运行。 由于安装了某些模块,它在我的情况下重新启动。 在fpm-restart期间,nginx尝试连接并且没有运行fpm。</ li>
  2. 确保php-fpm和nginx具有对套接字文件的适当权限。</ li>
  3. In 我的情况后来我将php-fpm从socket转换为9000端口。</ li>
    </ ol>

    希望这会有所帮助。</ p>
    </ div>

展开原文

原文

I had encountered a similar error with nginx recently.

This is how I solved it:

  1. Confirm that php-fpm is running. It was restarting in my case due to certain modules being installed. During fpm-restarts, nginx tried to connect and there's no fpm running.
  2. Make sure that php-fpm and nginx have proper permission to the socket file.
  3. In my case I later switched php-fpm from socket to port 9000.

Hope this helps.

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问