dongsui0929
2015-10-13 00:10
浏览 196
已采纳

安装guzzle / guzzle laravel 5项目

I installed koraktor/steam-condenser (https://packagist.org/packages/koraktor/steam-condenser) in my laravel project, but koraktor/steam-condenser need guzzel/guzzel (https://packagist.org/packages/guzzle/guzzle). I am tried to install guzzle/guzzle and got an Problem.

E:\Projekti\csgo_project_1>composer require guzzle/guzzle

Using version ^3.9@dev for guzzle/guzzle ./composer.json has been updated php artisan clear-compiled Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - Conclusion: don't install symfony/event-dispatcher v2.7.5 - Conclusion: don't install symfony/event-dispatcher v2.7.4 - Conclusion: don't install symfony/event-dispatcher v2.7.3 - Conclusion: don't install symfony/event-dispatcher v2.7.2 - Conclusion: don't install symfony/event-dispatcher v2.7.1 - Conclusion: don't install symfony/event-dispatcher v2.7.0 - Conclusion: don't install symfony/event-dispatcher v2.7.0-BETA2 - Conclusion: don't install symfony/event-dispatcher v2.7.0-BETA1 - Conclusion: don't install symfony/event-dispatcher 2.8.x-dev - Can only install one of: symfony/event-dispatcher[2.7.x-dev, 3.0.x-dev]. - Can only install one of: symfony/event-dispatcher[3.0.x-dev, 2.7.x-dev]. - Can only install one of: symfony/event-dispatcher[2.7.x-dev, 3.0.x-dev]. - Installation request for symfony/event-dispatcher ~2.7 -> satisfiable by s ymfony/event-dispatcher[2.7.x-dev, 2.8.x-dev, v2.7.0, v2.7.0-BETA1, v2.7.0-BETA2 , v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.7.5]. - Installation request for symfony/event-dispatcher == 3.0.9999999.9999999-d ev -> satisfiable by symfony/event-dispatcher[3.0.x-dev].

Installation failed, reverting ./composer.json to its original content.

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dongshang1768 2015-10-13 07:10
    已采纳

    There is no mention of here koraktor/steam-condenser needing guzzle/guzzle in https://packagist.org/packages/koraktor/steam-condenser

    Anyway if koraktor/steam-condens have a dependency on guzzle/guzzle it should pull this dependency thought Composer. So you ONLY need to do:

    composer require koraktor/steam-condenser
    

    and it should automatically pull all of it's dependencies through the Composer.

    已采纳该答案
    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题