dongyushen9063
2016-12-05 03:36
浏览 78
已采纳

将Wordpress永久链接更改为“帖子名称”后,找不到页面

I have wordpress site, after i changed the permalink to "Post name", then the sub pages (but home page is working fine) are not found "Error occurred: 404 - not found" . But if i changed to page ID - Plain url, then it is working but it show page ID in the url.

Pls check my screen shot of wordpress permalink http://prnt.sc/dfgba3

thanks

图片转代码服务由CSDN问答提供 功能建议

我有wordpress网站,我将永久链接更改为“帖子名称”,然后是子页面(但主页) 工作正常)未找到“发生错误:404 - 未找到”。 但是,如果我改为页面ID - 普通网址,那么它正在工作,但它在网址中显示网页ID。

请检查我的屏幕截图wordpress固定链接 http://prnt.sc/dfgba3

谢谢

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • douwanc63652 2016-12-07 04:06
    已采纳

    Please ensure your .htaccess file looks like this if you are using Apache.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    

    Then try to clear your browser cache and visit the website. Or visit your website in incognito mode.

    By the way if you are using Apache you need to enable mod rewrite in order to get perms links to work.

    A command like the following if you are managing your own server

    sudo a2enmod rewrite
    
    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • donglian4464 2016-12-05 04:24

    Please make sure your .htaccess file on root is writable mode, means having 777 permission.

    Can you please share .htaccess and share url of website

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题