2017-01-22 23:22


I just created myself a brand new project using LibGDX. Usually, I don't care about how all projects have a yellow warning triangle on them, but at this point, It’s getting slightly annoying.

How can I resolve this issue?

This is what it looks like:

image here

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答


  • dtol41388 dtol41388 4年前

    This is due to the fact that Eclipse automatically defaults to JRE 6. In order for you not to get those nasty warning triangles, you will need to use the JRE 8. The following is how you might resolve it:

    Preliminary fix

    Right click one of your prjects > Build path > Configure build path

    enter image description here

    Make sure you are inside the Libraries submenu, from there:

    Press JRE 6 > Choose remove

    Now we will add JRE 8:

    Add Library > JRE System Library > Workspace default JRE (jre...)

    enter image description here

    Permanentally fix

    In case you want to permanentally use JRE 8 for every LIBGDX project instead of the default JRE 6. You can:

    Window > Preferences > Java > Compiler > Configure Project Specific Settings > Project > Deselect "Use compliance from execution environment 'JavaSE-1.6'" > Set "Compiler compliance level" to 1.8.

    That's about it.

    点赞 评论 复制链接分享