bin / cake烘焙没有结果

我正在关注 ver3.0的书签教程</ code>。</ 代码> </ p>

我尝试了这些命令:</ p>

  bin / cake烘焙所有用户
bin / cake烘焙所有书签
bin / cake烘焙 所有标签
</ code> </ pre>

结果都是“最低PHP版本:5.4.16。您正在使用:5.4.3”</ code>且没有控制器, 视图,模型被创建。</ p>

有人能引导我走向正确的方向吗? 我是 CakePHP </ code>的新手。</ p>

我在WAMP2.5上安装了PHP 5.5.12。 php -v </ code>给出了“php5.4.3 on git”。</ p>
</ div>

展开原文

原文

I'm following the bookmark tutorial for ver3.0.

I tried these commands:

bin/cake bake all users
bin/cake bake all bookmarks
bin/cake bake all tags

results were all "Minimum PHP version: 5.4.16. You are using: 5.4.3" and no controllers, views, models were created.

Can someone lead me to the right direction? I'm new to CakePHP.

I have PHP 5.5.12 installed on WAMP2.5. php -v gives "php5.4.3 on git".

php
doubomudichen0832
doubomudichen0832 感谢您的帮助。有效。将Windows环境变量从PHP4.4.3更改为5.5.12。非常感谢你。
大约 5 年之前 回复
du4822
du4822 toolong
大约 5 年之前 回复
dongyinzheng6572
dongyinzheng6572 您是否尝试过升级PHP版本?
大约 5 年之前 回复

4个回答

if want run cake bake the first step Windows 7 1-Select Computer from the Start menu 2-Choose System Properties from the context menu 3-Click Advanced system settings > Advanced tab 4-Click on Environment Variables, under System Variables, find PATH, and click on it. 5-In the Edit windows, modify PATH by adding C:\xampp\htdocs\App-file\bin;C:\xampp\php;C:\xampp\mysql\bin;

now can use

cake bake model all cake bake controller all cake bake Template all



将PHP升级到5.5或5.6,它会起作用。</ p>
</ div>

展开原文

原文

Upgrade PHP to 5.5 or to 5.6, and it will work.



我在XAMPP中遇到了与PHP 5.4.7相同的问题。 在将XAMPP更新到较新的PHP 5.6.8版之后,我能够 bake </ code>。</ p>
</ div>

展开原文

原文

I had same problem in XAMPP with PHP 5.4.7. After updating XAMPP to the newer PHP version 5.6.8, I am able to bake.



如果是Windows,则使用bake命令: bin \ cake bake all </ strong>而不是 bin / cake烘焙所有</ strong> </ p>
</ div>

展开原文

原文

In case of Windows, the bake command: bin\cake bake all is used instead of bin/cake bake all

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问