e2297192638
2019-11-19 18:40 阅读 1.5k

关于centos卸载gcc的问题?

linux 3.10 centos 7系统,默认安装的gcc版本为4.8.5。因为跑程序要用到4.9以上的gcc版本,所以安装了gcc-8.3.0。
安装完成后,使用cat /proc/version命令只能看到gcc4.8.5,使用gcc -v命令只能看到gcc8.3.0。
运行程序时,又提示gcc版本不能高于gcc7.0,所以想卸载gcc8.3.0。但是利用rpm -q gcc 只能找到gcc-4.8.5,求问该怎么办?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

2条回答 默认 最新

  • wojiushiwo945you 毕小宝 2019-11-20 09:45

    gcc -v 只能看到当前系统默认使用的版本。多版本切换参考:
    https://blog.csdn.net/weixin_30337251/article/details/98548504

    点赞 2 评论 复制链接分享
  • baidu_36313748 我爱吃烧白 2021-03-15 15:59

    同问啊,请问楼主解决问题了吗

    点赞 评论 复制链接分享

相关推荐