2 baifaxiaoyao baifaxiaoyao 于 2012.09.25 11:19 提问

Android错误:Android requires compiler compliance level 5.0

有人遇到同样的问题么?我导入android工程的时候就出现了这个错误

[2012-09-24 17:20:09 - Screen] Android requires compiler compliance level5.0 or6.0. Found '1.7' instead. Please useAndroid Tools > Fix Project Properties.
[2012-09-24 17:21:55 - App] Android requires compiler compliance level5.0 or6.0. Found '1.7' instead. Please useAndroid Tools > Fix Project Properties.
[2012-09-24 17:21:59 - App] Android requires compiler compliance level5.0 or6.0. Found '1.7' instead. Please useAndroid Tools > Fix Project Properties.

为了删除函数上的所有重写的方法,我得到了这个错误。我的是windows7 64位,64位的jvm7.有人知道这个错误么?(我用了Android Tools -> Fix Project Properties,但是不起作用)

2个回答

mansuifengqi
mansuifengqi   2012.09.25 13:17
已采纳

就像评论中说的,你必须设置工程的兼容性到Java5.0或Java6.0.
要这样做,有两个方法:
①正确点击你的工程,然后选择"Android Tools -> Fix Project Properties"(如果这个不行,试试第二个方法)
②正确点击你的工程然后选择"Properties -> Java Compiler",检查 "Enable project specific settings" ,然后从"Compiler compliance settings" 选项卡选择1.5或者1.6。

niangzhi
niangzhi   2012.09.25 13:46

我建议使用X86版本的jvm。当我第一次用我的新的笔记本电脑(64位),我一直都想要64位的(jvm,jdk,jre,eclipse等等)。但是一旦我将所有的都设置完了,我意识到android SDK不支持64位的,所以我遇到了问题。重新回到jvm 86版本,你的问题就能解决了。

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead的问题解决
Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead的问题解决
Android requires compiler compliance level 5.0 or 6.0. 出错原因分析、解决方法
开发过程中碰到了一个问题:  Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties. 网上找了找了很多文章,但是都没有从根本上了解问题产生的原因,就像我上一篇文章说的"程序代码写的有问题,导致内存溢
Android requires compiler compliance level 5.0 or 6.0. Found '1.8' instead. 解决办法
右击项目->Properties.然后弹出如下视图:                                 接下勾上 Enable project specific settings。最后将complier Compliance level设置为1.6或者1.5。点击Apply,问题解决。
Android异常汇集----4. Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please
重装操作系统后,要重新配置Android开发环境。配置成功后,添加原本项目时却出现了错误! Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties. 解决方法: 1.项目右键 ->and
Android requires compiler compliance level 5.0 or 6.0. Found '1.4' instead. Please use Android Tools
参考 http://www.cnblogs.com/henryxu/archive/2012/08/07/2626964.html 提示Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead 提示Android requires compiler compliance level 5.0 or
requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools Fix Pr
requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools  Fix Project Properties.报错处理 1、问题??? 具体报错如下: requires compiler compliance level 5.0 or 6.0. Found '1.7'
Android之导入项目提示Android requires compiler compliance level 5.0 or 6.0. Found '1.8' instead解决办法
1、问题导入项目eclipse提示如下:Android requires compiler compliance level 5.0 or 6.0. Found '1.8' instead2、解决办法项目右键->Android tools->Fix Project
【存疑】【安卓】Eclipse Compiler compliance level 设置问题
当前的环境是,JDK 1.8,而Eclipse 是Neon.2 (4.6.2),当前2017年3月官网的最新版(应该是的吧?)。Android  SDK版本是API 25。 然而在安卓开发时,把compileSDK version设为25 。java compiler里面的Compiler compliance level设为1.8,build project出现报错,大意是 dx not su
Eclipse导入项目出现 Android requires compiler compliance level 5.0 or 6.0. Found '1.4' instead. Please us
有时候导入项目的时候会出现Android requires compiler compliance level 5.0 or 6.0. Found '1.4' instead. Please use Android Tools > Fix Project Properties. 一般来说碰到这种情况有两种解决方法 1.项目 右键 ->android tools ->Fix Project,基本
Android requires compiler compliance level 5.0 or 6.0. Found '1.3' instead.
重装操作系统后,要重新配置Android开发环境。配置成功后,添加原本项目时却出现了错误! Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties. 解决方法: 1.项目右键 ->and