dongmei425373
2014-12-06 15:29
浏览 140
已采纳

XAMPP:无法启动Apache(Windows 10)

I'm using XAMPP, and I can start Apache, but, MySQL (PhpMyAdmin) start!

When I start, I get this error;

10:07:49  [Apache]  Error: Apache shutdown unexpectedly.
10:07:49  [Apache]  This may be due to a blocked port, missing dependencies, 
10:07:49  [Apache]  improper privileges, a crash, or a shutdown by another method.
10:07:49  [Apache]  Press the Logs button to view error logs and check
10:07:49  [Apache]  the Windows Event Viewer for more clues
10:07:49  [Apache]  If you need more help, copy and post this
10:07:49  [Apache]  entire log window on the forums

I search on it, and, change the port of Apache in Config -> Service and Port setting. I have;

Service name : Apache2.4
Main Port : 122
SSL port : 444

I also uninstall Skype (Windows 8/10/Metro version). Nothing Working. In the httpd.conf I have;

Listen 122
ServerName localhost:122

I start it via apache_start.bat and get;

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : AH00072: make_sock: could not bind to address [::]:445
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : AH00072: make_sock: could not bind to address 0.0.0.0:445
AH00451: no listening sockets available, shutting down
AH00015: Unable to open logs

Please not that all the LOGS files dosen't exsist! Skype is uninstalled.

If you need more informations, please ask me.

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

23条回答 默认 最新

  • duanba7498 2015-04-13 09:35
    已采纳

    Update: 15th May, 2018 :

    The latest Windows 10 update (re-)activated the World Wide Web Publishing Service (in german: WWW-Publishingdienst). This might depend on the options you select during the configuration of the update you can make afterwards.

    Update: 4th August, 2015 :

    If you have done clean installation of Windows 10, you may not have the Word Wide Web Publishing Service. In that case, simple WAMP/XAMPP installation should work fine.

    If it doesn't, try installing Visual C++ Redistributable and then re-install WAMP/XAMPP.


    I was facing a similar problem with WAMP. In Windows 10 TP, the Word Wide Web Publishing Service comes pre-installed. This is related to IIS and you can remove it if you don't need it.

    This blocks the port 80 making Apache act weirdly. You can do the following and try again.

    • Go to Start, type in services.msc
    • Scroll down in the Services window to find the World Wide Web Publishing Service.
    • Right click on it and select Stop.

    This should make port 80 free and restarting WAMP/XAMPP should get you up and running!

    There are other ways to do fix this. http://praveenpuglia.com/make-wamp-work-on-windows-10-technical-preview/

    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • drplww2505 2015-02-28 12:15

    so after playing around really all you have to do is change 2 lines in the httpd.conf file,

    Listen 80 change to Listen 122 (or anything else you want)

    and

    ServerName Localhost:80 to Localhost:122 ( or the port you changed above)

    then it all should fire right up :P

    honestly i think this is just the xampp application not knowing what to do with windows 10 if you use look at the event list in the xampp window mine says

    5:56:38 AM [Apache] Problem detected!

    5:56:38 AM [Apache] Port 80 in use by "Unable to open process" with PID 4!

    5:56:38 AM [Apache] Apache WILL NOT start without the configured ports free!

    5:56:38 AM [Apache] You need to uninstall/disable/reconfigure the blocking application

    5:56:38 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port

    5:56:38 AM [Apache] Attempting to start Apache app...

    and if you open up net stat it shows port 80 with PID 4 as being used by system, not sure as i don't have windows 7 anymore but if that is not the same on 7 then there is the problem.

    the other reason i believe this to be the problem is that since the PID is 4 while looking in net stat System is the only thing with PID 4 and its using more then port 80.

    so sadly i don't think anything can be done until Apache Friends updates there software, or someone finds a work around

    评论
    解决 无用
    打赏 举报
  • douwei1128 2015-06-04 18:39

    Solving this problem is easy:

    1. Open a command prompt with administrator privileges
      • Find "cmd", right-click on it, then select "Administrator".
    2. In the prompt, type net stop W3SVC and Enter.

    You can now click in WAMPP and restart all services. Open your browser and navigate to "localhost".

    If you need to start W3SVC again,

    1. Open a command prompt with administrator privileges
    2. In the prompt, type net start W3SVC and Enter.
    评论
    解决 无用
    打赏 举报
  • dongpo3957 2015-08-08 13:04
    • Go to Start, type in Turn Windows features on or off
    • Uncheck Internet Information Services
    • Press OK
    评论
    解决 无用
    打赏 举报
  • doulin9679 2015-08-27 18:38

    I found a way to solve this problem:

    1. If you are using Skype as well, uncheck the field stating to use ports 80 and 443 (Extra -> Settings -> Advanced -> Connections -> Uncheck Port 80 and 443)
    2. Restart Skype and XAMPP.

    If this does not work,

    1. Go to Start and type "services.msc"
    2. Locate "World Wide Web Publishing Service"
    3. Right-click on that entry, select "Stop", then restart XAMPP.

    If that did not work and "World Wide Web Publishing Service" was not available,

    1. Go to the Control Panel, navigate to "Uninstall Programs", then "Turn on/off Windows features"
    2. Locate "Internet Information Services"
    3. Click the checkbox and hit "OK".
    4. Restart, then repeat the second approach (services.msc)
    评论
    解决 无用
    打赏 举报
  • duanmi8349 2015-08-30 15:23

    1. Press Windows+R, type regedit

    2. Go to

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
    

    Change the value of Start to 4, which means disabled.

    3. Reboot your computer

    评论
    解决 无用
    打赏 举报
  • duanche2007 2015-09-01 08:20

    You can change the port of apache:

    1. Go to C:\xampp\apache\conf\httpd.
    2. Find by combination Ctrl+F line #Listen 12.34.56.78:80 and change the 80 to any you like for example 81
    3. The same with Listen 80 change to 81
    4. The same with ServerName localhost:80 change to 81.
    5. Go to C:\xampp\apache\conf\extra\httpd-vhosts and change 80 to 81

    NameVirtualHost *:80 here

    VirtualHost *:80 and here (two times)

    1. Restart apache

    To enter your web page type: http://localhost:81/index.html

    评论
    解决 无用
    打赏 举报
  • doujue9767 2015-09-20 00:34

    Actually, by default the IIS (microsoft dotnet etc.) installed. go to control panel turn Windows features on or Off.. Under (IIS) Internet Information Services uncheck the (WWWS) world wide web services. and then click OK. this could be a permanent solution. :)

    评论
    解决 无用
    打赏 举报
  • dongzhuo1958 2015-11-11 18:18

    These advices were great. I had the same problem, but my solution was different, because I was so stupid, that I have renamed directory where XAMPP was located and sice I had installed a lot of another programs I couldn't rename it back.

    In my case there was original directory C:\Programs\Xampp and renamed it to C:\PROGRAMS_\Xampp and that was the mistake.

    Solution was to find all references on C:\Programs and rename them C:\PROGRAMS_ in Xampp directory, because for some reason during the installation it writes absolute paths not realive. Of course there are some refences in registry too.

    Hope that will help someone.

    评论
    解决 无用
    打赏 举报
  • donglu9743 2015-12-06 02:07

    I tried everything listed in the answers here but none of them worked.

    Then all I did was to re-start XAMPP with administrator rights by:

    Start menu - right click on XAMPP - select run as administartor

    It worked. It is that simple.

    I uninstalled IIS services, stopped WWW services, changed ports back to 80, blocked all apache and mysql connections from windows 10 firewall, but yes it still works!

    评论
    解决 无用
    打赏 举报
  • douhui1333 2016-02-18 08:59

    It looks like there are many options answer it is depend on your windows. Here is my experience when having the same problem in windows 10 fresh install and fix the issue with the following step :

    1. Install Visual C++ Redistributable
    2. Open XAMPP and select config in apache service
    3. Change the port 80 to 9000 or 81 or whatever you want in httpd.conf on the line Listen 80
    4. Change the port on httpd-ssl.conf and change Listen 443 to Listen 441
    5. restart XAMPP and start apache service, and it work for me.

    NOTE : I'm using XAMPP Version 5.6.15 and XAMPP Control Panel version 3.2.2

    评论
    解决 无用
    打赏 举报
  • douzhuo1853 2016-03-13 15:51

    it's simply a matter of making port 80 available for your Apache service The way i solved the problem is

    1. On windows 10 right click the start button and select run
    2. Type services.msc and click OK
    3. Find and right Click World wide web publishing service
    4. Select properties
    5. Change the startup type value to Automatic (Delayed Start)
    6. Restart your computer.

    There you have it, All is back to normal

    评论
    解决 无用
    打赏 举报
  • dongpengqin3898 2016-03-14 09:54

    In my case it was a simple case of removing IIS because windows 10 comes with IIS pre installed - that conflicts with XAMPP because these both servers try to use the port 80. If you dont want to use IIS and keep using XAMPP

    1. Go to run/search in windows10
    2. Search for 'optionalfeatures'
    3. On that list untick the Internet Information Service(IIS)

    then RESTART

    评论
    解决 无用
    打赏 举报
  • doutun9179 2016-06-14 08:56

    That was simple for me! try to run XAMPP Control Panel as administrator

    评论
    解决 无用
    打赏 举报
  • dougu1990 2016-08-09 04:28

    I have tried all the above solutions. But it was not working in any way.

    Finally I just uninstalled the XAMPP and installed it again. Then it worked for me.

    Now I can able to run the server on any port (including 80).

    评论
    解决 无用
    打赏 举报
  • duanlie4621 2016-08-11 19:42

    I found that running apache_start in gave me the exact error and on which line it was. My error was that I left a space in between loccalhost: and the port

    评论
    解决 无用
    打赏 举报
  • douqiandai4327 2016-10-13 17:14

    I have fixed this issue with mine as well but what I had to do was change a couple things. I require that on my Win10 machine I keep my C# and VS development environment so I didn't want to tinker with any services. All I had to do was download the latest version of XAMPP and change the listening ports for 80 and 443. They were located in 2 files:

    C:\xampp\apache\conf\httpd.conf

    Listen 122
    ServerName localhost:122
    

    C:\xampp\apache\conf\extra\httpd-ssl.conf

    Listen 444
    

    Changing above from port 80 to 122 and 443 to 444 allowed me to have apache run and serve pages while keeping everything else the same for my ASP development. Hopefully this helps someone out there. In the end this is a very simple fix.

    Direct your browser to: http://localhost:122

    评论
    解决 无用
    打赏 举报
  • dpus81500574 2016-11-24 04:35

    The World Wide Web Publishing service was not the only one responsible in my case. I have IIS installed so I had to stop the whole http service.

    This are the commands that I've executed in CMD(as administrator):

    net stop W3SVC
    net stop http
    
    评论
    解决 无用
    打赏 举报
  • dqz7636 2017-07-09 07:18

    In you have installed SQL Server, Some of its services may block the port which XAMPP needs. I solved my problem by disabling SQL Server Reporting Services and now Apache starts with no problem.

    Just open the services.msc , scroll down and find SQL Server Reporting Services , right click on it and click the Stop.

    评论
    解决 无用
    打赏 举报
  • dpgf42422 2018-09-21 12:36

    Steps: Open the XAMMP Control Panel, Open Apache Config, then select the Apache - xammp- config file Search for Port 443, and then change it to some other port lets say 4433

    Then restart.

    评论
    解决 无用
    打赏 举报
  • dtrgqjcd877528 2019-04-29 14:48

    I got same problem, but the above solutions leads us to change the port instead of getting the exact solution. I've searched about the ports of simple HTTP & HTTPS Protocols and found

    If another application is already running the http or https ports on local machine, we'll get this problem obviously just because of those ports already in use and in busy state.

    That's why after changing the port number it was working. But instead of changing the port in XAMPP server I've used the following methods and It's works for me.

    Here's the following step which I've got during this fix up.

    1. Error which I got in XAMPP Server application.

    XAMPP Server Error

    1. At the top corner there's a button named Netstat. It's very useful for looking up the running ports on the system.

    Netstat button

    1. This is the Netstat application where I found an application already running and using the port no. 443. In my case It was vmware-hostd.exe. Your might be different application. Try to search for port 80 (HTTP) or port 443 (HTTPS).

    Netstat application opened

    1. I just opened the windows task manager, selected that application vmware-hostd.exe and kill the process by using the End Process button. I've killed that process which was used port 443. And this application wasn't needed at the moment.

    Opened task manager and kill that application

    1. After killing the application in windows task manager, Apache is now available at the moment. Here's the proof.

    Apache working


    NOTE: If you found any kind of application which is used the http or https ports means port 80 or port 443 and the application isn't important or not vital then only kill the process of that application. Otherwise no need to follow this steps. Then you need to consider to change the port of your XAMMP application as stated on the above answers.

    评论
    解决 无用
    打赏 举报
  • douzhu7507 2019-06-21 09:42

    Check your PHP installation works, check which php.ini you are running in apache's conf and use it to run php.exe...

    评论
    解决 无用
    打赏 举报
  • doudui2229 2019-07-25 01:25

    Update: 25/7/2019: Have you just updated your Windows to Version 1903 (OS Build:18362.239) OR have you been changing user passwords?

    I did, and despite having eliminated all port conflicts, I still kept getting the messages described by the OP at the very start of this post.

    In the end I cured it by upgrading to XAMPP to 7.3.7. (When forced to re-install might as well upgrade at the same time!)

    But the problem recurred when I again went to change 'root' user password.

    The console error messages were masking the fact that table mysql.user was corrupt.

    Check mysql_error.log. If you are seeing Fatal error: Can't open and lock privilege tables: Index for table 'user' is corrupt; try to repair it, then have a look at this.

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题