RedHat 7错误=>需要:libcrypto.so.10

我在安装php5.6时遇到了问题。我用“yumemovephp*”删除了所有php内容,使用LinuxRedHat 7并启用RepoRemi。我使用的是OpenSSL_1.0.2和64位操作系统。

enter image description here

[root@localhost ~]# yum install php56
Modules complémentaires chargés : langpacks, product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet php56.x86_64 0:2.3-1.el7.remi sera installé
--> Traitement de la dépendance : php56-runtime(x86-64) = 2.3-1.el7.remi pour le paquet : php56-2.3-1.el7.remi.x86_64
--> Traitement de la dépendance : php56-php-pear >= 1:1.10.5 pour le paquet : php56-2.3-1.el7.remi.x86_64
--> Traitement de la dépendance : php56-php-common(x86-64) >= 5.6.31 pour le paquet : php56-2.3-1.el7.remi.x86_64
--> Traitement de la dépendance : php56-runtime pour le paquet : php56-2.3-1.el7.remi.x86_64
--> Traitement de la dépendance : php56-php-cli(x86-64) pour le paquet : php56-2.3-1.el7.remi.x86_64
--> Lancement de la transaction de test
---> Le paquet php56-php-cli.x86_64 0:5.6.35-1.el7.remi sera installé
--> Traitement de la dépendance : libcrypto.so.10(OPENSSL_1.0.2)(64bit) pour le paquet : php56-php-cli-5.6.35-1.el7.remi.x86_64
---> Le paquet php56-php-common.x86_64 0:5.6.35-1.el7.remi sera installé
--> Traitement de la dépendance : php56-php-pecl-zip(x86-64) pour le paquet : php56-php-common-5.6.35-1.el7.remi.x86_64
--> Traitement de la dépendance : php56-php-pecl-jsonc(x86-64) pour le paquet : php56-php-common-5.6.35-1.el7.remi.x86_64
---> Le paquet php56-php-pear.noarch 1:1.10.5-5.el7.remi sera installé
--> Traitement de la dépendance : php56-php-xml pour le paquet : 1:php56-php-pear-1.10.5-5.el7.remi.noarch
--> Traitement de la dépendance : php56-php-posix pour le paquet : 1:php56-php-pear-1.10.5-5.el7.remi.noarch
---> Le paquet php56-runtime.x86_64 0:2.3-1.el7.remi sera installé
--> Traitement de la dépendance : environment-modules pour le paquet : php56-runtime-2.3-1.el7.remi.x86_64
--> Traitement de la dépendance : /usr/sbin/semanage pour le paquet : php56-runtime-2.3-1.el7.remi.x86_64
--> Lancement de la transaction de test
---> Le paquet environment-modules.x86_64 0:3.2.10-0.el7.remi sera installé
--> Traitement de la dépendance : libtcl8.5.so()(64bit) pour le paquet : environment-modules-3.2.10-0.el7.remi.x86_64
---> Le paquet php56-php-cli.x86_64 0:5.6.35-1.el7.remi sera installé
--> Traitement de la dépendance : libcrypto.so.10(OPENSSL_1.0.2)(64bit) pour le paquet : php56-php-cli-5.6.35-1.el7.remi.x86_64
---> Le paquet php56-php-pecl-jsonc.x86_64 0:1.3.10-1.el7.remi sera installé
---> Le paquet php56-php-pecl-zip.x86_64 0:1.15.2-1.el7.remi sera installé
---> Le paquet php56-php-process.x86_64 0:5.6.35-1.el7.remi sera installé
---> Le paquet php56-php-xml.x86_64 0:5.6.35-1.el7.remi sera installé
---> Le paquet php56-runtime.x86_64 0:2.3-1.el7.remi sera installé
--> Traitement de la dépendance : /usr/sbin/semanage pour le paquet : php56-runtime-2.3-1.el7.remi.x86_64
--> Traitement de la dépendance : /usr/sbin/semanage pour le paquet : php56-runtime-2.3-1.el7.remi.x86_64
--> Résolution des dépendances terminée
Erreur : Paquet : php56-runtime-2.3-1.el7.remi.x86_64 (remi)
         Requiert : /usr/sbin/semanage
Erreur : Paquet : php56-php-cli-5.6.35-1.el7.remi.x86_64 (remi)
         Requiert : libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Erreur : Paquet : environment-modules-3.2.10-0.el7.remi.x86_64 (remi)
         Requiert : libtcl8.5.so()(64bit)
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest
dongxi3911
dongxi3911 请阅读在什么情况下我可以在我的问题中添加“亲密”或其他类似的短语,以获得更快的答案?-摘要是,这不是解决志愿者问题的理想方式,可能会对获得答案产生反作用。请不要在您的问题中添加此内容。
2 年多之前 回复
duanruanxian5028
duanruanxian5028 我在问题中添加了我的代码,谢谢:)
2 年多之前 回复
duanlu0075
duanlu0075 请将您的代码粘贴到问题中,不要只依赖外部链接
2 年多之前 回复

1个回答

It looks like RHEL 7.4 switched from OpenSSL 1.0.1e to 1.0.2:

openssl on RHEL7 is originally based on openssl-1.0.1e but was rebased to openssl-1.0.2k with RHEL7.4

I guess this means you're using <7.4 but Remi builds his PHP RPMs with 7.4+. I think your options are:

  • upgrade your server to 7.4 or later
  • take Remi's SRPMs and rebuild PHP 5.6 yourself, adjusting the openssl version in the specfile if necessary (but it'll probably just work)

You could look back through his RPMs to find a version of PHP 5.6 built before 7.4, but this is a bad idea because you'd be missing recent security fixes.

douzhun8615
douzhun8615 确实......正如FAQ中所解释的那样... blog.remirepo.net/pages/English-FAQ#deps
2 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐