将codeigniter从3.0.6升级到3.1.0

Hy,我有一个基于codeigniter 3.0.6的网站,我将升​​级到3.1.0,\ 我下载了codeigniter 3.1.0并复制了我的文件(视图,模型。控制器)。 我改变了我的routes.php,database.php和config.php。 </ p>

我遇到错误:</ p>

 遇到PHP错误

Severity:Notice

消息:未定义的属性: Travels :: $ db

文件名:core / Model.php

Line Number:77

Backtrace:

File:D:\ xamp \ htdocs \ update \ application \ models \ Travel.php
Line :95
功能:__ get

File:D:\ xamp \ htdocs \ update \ application \ controllers \ Travels.php
Line:29
功能:all_des

File:D:\ xamp \ htdocs \ update \ application \ controllers \ Travels.php
Line:41
功能:main_header

File:D:\ xamp \ htdocs \ update \ index.php
Line:315
功能:require_once
</ code> </ pre> \ n

我该怎么办?</ p>
</ div>

展开原文

原文

Hy, I have a site based on codeigniter 3.0.6 which I am going to upgrade to 3.1.0, I downloaded the codeigniter 3.1.0 and copy my files (view, model. controller). I changed my routes.php, database.php and config.php.

I am facing an error:

A PHP Error was encountered

Severity: Notice

Message: Undefined property: Travels::$db

Filename: core/Model.php

Line Number: 77

Backtrace:

File: D:\xamp\htdocs\update\application\models\Travel.php
Line: 95
Function: __get

File: D:\xamp\htdocs\update\application\controllers\Travels.php
Line: 29
Function: all_des

File: D:\xamp\htdocs\update\application\controllers\Travels.php
Line: 41
Function: main_header

File: D:\xamp\htdocs\update\index.php
Line: 315
Function: require_once

what should I do ??

doumian0569
doumian0569 我不知道如何通过composer升级。我是codeigniter的新手
3 年多之前 回复
dongyuan7981
dongyuan7981 或类似这样的codeigniter.com/userguide3/installation/upgrade_301.html..请注意升级的步骤。
3 年多之前 回复
drasv0904
drasv0904 嗯..你认为你应该通过作曲家进行升级吗?
3 年多之前 回复

1个回答



尝试使用新文件夹替换系统文件夹。</ p>

请参阅:从3.0.6升级到3.1.0 </ p>
</ div >

展开原文

原文

Try just replace the system folder with the new one.

Please refer to: Upgrading from 3.0.6 to 3.1.0

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐