dqm7854
2018-02-27 08:28
浏览 91
已采纳

禁止访问:您无权访问此服务器上的/ abcd /

I am running a CentOS 6.9 OS. I have Apache/2.2.15 (CentOS) Server running. I have a cakephp 2 application that I want to run here. I have an index.php file inside /var/www/html that runs perfectly. I have another folder called test inside /var/www/html.

Inside that folder there is an index.php file. Test folder also runs perfectly. But whenever I try to run the cakephp application from the browser I get the message I don't have permission to access that folder. The cakephp application has 0777 permission. Inside my /etc/httpd/conf/httpd.conf file there is written -

<Directory "/var/www/html">
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

So I don't know what I am doing wrong and what more I can do.

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • dsfsfdsf4544 2018-02-27 08:33
    已采纳

    hi dude please find and edit httpd.conf file, which is in /etc/httpd/conf/httpd.conf. and paste the code below

    <Directory "/">
    #Options FollowSymLinks
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride None
    Allow from all
    </Directory>
    
    <Directory "/home/">
     #Options FollowSymLinks
     Options Indexes FollowSymLinks Includes ExecCGI
     AllowOverride None
     Allow from all
    </Directory>
    

    Then kindly restart the server if the problem still appear

    disable the seLinux in /etc/selinux/config change SELINUX=disabled and restart the server it again hope it works now ^_^

    点赞 评论
  • dongxiao3694 2018-02-27 08:55

    restorecon -r /var/www/html does the job

    I got the answer from here. https://www.centos.org/forums/viewtopic.php?t=6834

    点赞 评论

相关推荐 更多相似问题