解決 vue code ELIFECYCLE 的方法

图片说明

图片说明

環境
npm -v
6.12.0

node -v -->v8.16.1

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! tabbar@1.0.0 dev: webpack-dev-server --inline --progress --config build/webpack.dev.conf.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the tabbar@1.0.0 dev script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

google 百度查找方法一(不ok)

 rm -rf node_modules
rm package-lock.json
npm cache clear --force
npm install

方法二(還是不OK)

npm uninstall webpack-dev-server
npm install webpack-dev-server@2.9.1

vue版本和webpack-dev-server版本不匹配導致

software20121216
低調的D吖 不知道是什麼原因 然後重寫了項目就OK了
4 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
crontab 执行 npm run build 报错: code ELIFECYCLE
 直接在命令行执行,是正常的: ``` npm run build ```  如果在脚本中执行,是正常的: ``` #!/bin/sh npm run build ```   ![图片说明](https://img-ask.csdn.net/upload/201908/22/1566465579_51483.png)  但是任务中执行就报错了: ``` */1 * * * * cd /***/hbv3 && npm run build >> /run-error.log 2>&1 ```   ![图片说明](https://img-ask.csdn.net/upload/201908/22/1566465814_364387.png) 请问这是什么原因?如何解决
运行Vue项目时,报错npm ERR! errno 1 npm ERR! Failed at the single@1.0.0 dev script.
运行Vue项目时,报错,不清楚是哪里出了问题 ``` Error: Cannot find module 'webpack-cli/bin/config-yargs' at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15) at Function.Module._load (internal/modules/cjs/loader.js:562:25) at Module.require (internal/modules/cjs/loader.js:690:17) at require (internal/modules/cjs/helpers.js:25:18) at Object.<anonymous> (E:\HBuilderProjects\Vue\single\node_modules\_webpack-dev-server@3.7.1@webpack-dev-server\bin\webpack-dev-server.js:60:1) at Module._compile (internal/modules/cjs/loader.js:776:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:787:10) at Module.load (internal/modules/cjs/loader.js:653:32) at tryModuleLoad (internal/modules/cjs/loader.js:593:12) at Function.Module._load (internal/modules/cjs/loader.js:585:3) npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! single@1.0.0 dev: `webpack-dev-server --open --hot --port 8020` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the single@1.0.0 dev script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\asus\AppData\Roaming\npm-cache\_logs\2019-06-15T16_43_01_654Z-debug.log ``` ``` ``` 这个是package.json文件 ``` { "name": "single", "version": "1.0.0", "description": "", "main": "main.js", "scripts": { "dev": "webpack-dev-server --open --hot --port 8020" }, "keywords": [], "author": "", "license": "ISC", "dependencies": { "vue": "^2.6.10" }, "devDependencies": { "babel-core": "^6.26.3", "babel-loader": "^8.0.6", "babel-preset-env": "^1.7.0", "css-loader": "^3.0.0", "file-loader": "^4.0.0", "vue-html-loader": "^1.2.4", "vue-loader": "^15.7.0", "vue-style-loader": "^4.1.2", "vue-template-compiler": "^2.6.10", "webpack": "^4.34.0", "webpack-dev-server": "^3.7.1" } } ```
Vue启动 npm run dev之后报错!!!!!!!!!!!!!!!!!!!!!!!!!!!
npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! vue_demo01@1.0.0 dev: `webpack-dev-server --inline --progr ess --config build/webpack.dev.conf.js` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the vue_demo01@1.0.0 dev script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\apple\AppData\Roaming\npm-cache\_logs\2019-03-23T08_47_19_392Z-debug.log ``` ```
vue+vux 项目依赖丢失
项目已经发布,因为要加功能跑了dev后报了依赖丢失,可以肯定不是手动删的,求问为什么会出现这种状况,以及如何避免 To debug the "dev" script, make sure the %NODE_DEBUG_OPTION% string is specified as the first argument for the node command you'd like to debug. For example: "scripts": { "start": "node %NODE_DEBUG_OPTION% server.js" } > member@1.0.0 dev D:\member\member > webpack-dev-server --inline --progress --config build/webpack.dev.conf.js module.js:550 throw err; ^ Error: Cannot find module 'vux-loader' at Function.Module._resolveFilename (module.js:548:15) at Function.Module._load (module.js:475:25) at Module.require (module.js:597:17) at require (internal/module.js:11:18) at Object.<anonymous> (D:\member\member\build\vue-loader.conf.js:4:19) at Module._compile (module.js:653:30) at Object.Module._extensions..js (module.js:664:10) at Module.load (module.js:566:32) at tryModuleLoad (module.js:506:12) at Function.Module._load (module.js:498:3) npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! member@1.0.0 dev: `webpack-dev-server --inline --progress --config build/webpack.dev.conf.js` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the member@1.0.0 dev script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\DELL\AppData\Roaming\npm-cache\_logs\2018-11-24T03_14_53_401Z-debug.log Process finished with exit code 1
win10下 nodejs报错:error Windows_NT 10.0.14393
0 info it worked if it ends with ok 1 verbose cli [ 'D:\\Program Files\\nodejs\\node.exe', 1 verbose cli 'D:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js', 1 verbose cli 'run', 1 verbose cli 'dev' ] 2 info using npm@3.10.9 3 info using node@v6.9.2 4 warn invalid config registry="registry" 5 warn invalid config Must be a full url with 'http://' 6 verbose run-script [ 'predev', 'dev', 'postdev' ] 7 info lifecycle vue@1.0.0~predev: vue@1.0.0 8 silly lifecycle vue@1.0.0~predev: no script for predev, continuing 9 info lifecycle vue@1.0.0~dev: vue@1.0.0 10 verbose lifecycle vue@1.0.0~dev: unsafe-perm in lifecycle true 11 verbose lifecycle vue@1.0.0~dev: PATH: D:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin;E:\WEB\vue\node_modules\.bin;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;D:\Program Files\TortoiseSVN\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;D:\Program Files (x86)\VisualSVN Server\bin;D:\Program Files\nodejs\;C:\Users\King\AppData\Local\Microsoft\WindowsApps;C:\Users\King\AppData\Roaming\npm 12 verbose lifecycle vue@1.0.0~dev: CWD: E:\WEB\vue 13 silly lifecycle vue@1.0.0~dev: Args: [ '/d /s /c', 'node build/dev-server.js' ] 14 silly lifecycle vue@1.0.0~dev: Returned: code: 1 signal: null 15 info lifecycle vue@1.0.0~dev: Failed to exec dev script 16 verbose stack Error: vue@1.0.0 dev: `node build/dev-server.js` 16 verbose stack Exit status 1 16 verbose stack at EventEmitter.<anonymous> (D:\Program Files\nodejs\node_modules\npm\lib\utils\lifecycle.js:255:16) 16 verbose stack at emitTwo (events.js:106:13) 16 verbose stack at EventEmitter.emit (events.js:191:7) 16 verbose stack at ChildProcess.<anonymous> (D:\Program Files\nodejs\node_modules\npm\lib\utils\spawn.js:40:14) 16 verbose stack at emitTwo (events.js:106:13) 16 verbose stack at ChildProcess.emit (events.js:191:7) 16 verbose stack at maybeClose (internal/child_process.js:877:16) 16 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5) 17 verbose pkgid vue@1.0.0 18 verbose cwd E:\WEB\vue 19 error Windows_NT 10.0.14393 20 error argv "D:\\Program Files\\nodejs\\node.exe" "D:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "run" "dev" 21 error node v6.9.2 22 error npm v3.10.9 23 error code ELIFECYCLE 24 error vue@1.0.0 dev: `node build/dev-server.js` 24 error Exit status 1 25 error Failed at the vue@1.0.0 dev script 'node build/dev-server.js'. 25 error Make sure you have the latest version of node.js and npm installed. 25 error If you do, this is most likely a problem with the vue package, 25 error not with npm itself. 25 error Tell the author that this fails on your system: 25 error node build/dev-server.js 25 error You can get information on how to open an issue for this project with: 25 error npm bugs vue 25 error Or if that isn't available, you can get their info via: 25 error npm owner ls vue 25 error There is likely additional logging output above. 26 verbose exit [ 1, true ] 全部内容如上,求各位大神支招
windows下运行npm run dev报错,查了很多资料,哪位大神指点下,感激~
0 info it worked if it ends with ok 1 verbose cli [ 'D:\\nodejs\\node.exe', 1 verbose cli 'D:\\nodejs\\node_global\\node_modules\\npm\\bin\\npm-cli.js', 1 verbose cli 'run', 1 verbose cli 'dev' ] 2 info using npm@5.0.0 3 info using node@v8.4.0 4 verbose run-script [ 'predev', 'dev', 'postdev' ] 5 info lifecycle vue_elmentui@1.0.0~predev: vue_elmentui@1.0.0 6 silly lifecycle vue_elmentui@1.0.0~predev: no script for predev, continuing 7 info lifecycle vue_elmentui@1.0.0~dev: vue_elmentui@1.0.0 8 verbose lifecycle vue_elmentui@1.0.0~dev: unsafe-perm in lifecycle true 9 verbose lifecycle vue_elmentui@1.0.0~dev: PATH: D:\nodejs\node_global\node_modules\npm\bin\node-gyp-bin;D:\vueElmentUI\node_modules\.bin;D:\cmder\bin;D:\cmder\vendor\git-for-windows\cmd;D:\cmder\vendor\conemu-maximus5\ConEmu\Scripts;D:\cmder\vendor\conemu-maximus5;D:\cmder\vendor\conemu-maximus5\ConEmu;C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;D:\svn\bin;C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET Web Pages\v1.0\;C:\Program Files (x86)\Windows Kits\8.0\Windows Performance Toolkit\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;D:\Git\cmd;D:\java\bin;D:\MongoDB\bin;D:\MongoDB\bin;D:\nodejs\node_global;D:\cmder;D:\nodejs\node_global;D:\nodejs\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Users\xw\AppData\Roaming\npm;D:\cmder\vendor\git-for-windows\usr\bin;D:\cmder\vendor\git-for-windows\usr\share\vim\vim74;D:\cmder\ 10 verbose lifecycle vue_elmentui@1.0.0~dev: CWD: D:\vueElmentUI 11 silly lifecycle vue_elmentui@1.0.0~dev: Args: [ '/d /s /c', 'node build/dev-server.js' ] 12 info lifecycle vue_elmentui@1.0.0~dev: Failed to exec dev script 13 verbose stack Error: vue_elmentui@1.0.0 dev: `node build/dev-server.js` 13 verbose stack spawn ;d:\Git\cmd ENOENT 13 verbose stack at _errnoException (util.js:1041:11) 13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:192:19) 13 verbose stack at onErrorNT (internal/child_process.js:374:16) 13 verbose stack at _combinedTickCallback (internal/process/next_tick.js:138:11) 13 verbose stack at process._tickCallback (internal/process/next_tick.js:180:9) 14 verbose pkgid vue_elmentui@1.0.0 15 verbose cwd D:\vueElmentUI 16 verbose Windows_NT 6.1.7601 17 verbose argv "D:\\nodejs\\node.exe" "D:\\nodejs\\node_global\\node_modules\\npm\\bin\\npm-cli.js" "run" "dev" 18 verbose node v8.4.0 19 verbose npm v5.0.0 20 error file ;d:\Git\cmd 21 error path ;d:\Git\cmd 22 error code ELIFECYCLE 23 error errno ENOENT 24 error syscall spawn ;d:\Git\cmd 25 error vue_elmentui@1.0.0 dev: `node build/dev-server.js` 25 error spawn ;d:\Git\cmd ENOENT 26 error Failed at the vue_elmentui@1.0.0 dev script. 26 error This is probably not a problem with npm. There is likely additional logging output above. 27 verbose exit [ 1, true ]
我在文件夹下执行npm run dev出现错误,该如何解决?
我先执行以下命令,没有出现问题 ``` cd web/ npm install cd client/ npm install ``` 但是当我执行 ``` cd ../ npm run dev ``` 发生错误,我不知道如何解决, ``` zcy@ubuntu:~/new project/blockchain-document-management/web$ npm run dev > nykredit-network@0.0.1 dev /home/zcy/new project/blockchain-document-management/web > concurrently --kill-others-on-fail "npm run server" "npm run client" [0] [0] > nykredit-network@0.0.1 server /home/zcy/new project/blockchain-document-management/web [0] > nodemon app.js [0] [1] [1] > nykredit-network@0.0.1 client /home/zcy/new project/blockchain-document-management/web [1] > cd client && npm run start [1] [0] sh: 1: nodemon: not found [0] npm ERR! file sh [0] npm ERR! code ELIFECYCLE [0] npm ERR! errno ENOENT [0] npm ERR! syscall spawn [0] npm ERR! nykredit-network@0.0.1 server: `nodemon app.js` [0] npm ERR! spawn ENOENT [0] npm ERR! [0] npm ERR! Failed at the nykredit-network@0.0.1 server script. [0] npm ERR! This is probably not a problem with npm. There is likely additional logging output above. [0] [0] npm ERR! A complete log of this run can be found in: [0] npm ERR! /home/zcy/.npm/_logs/2018-12-17T02_31_36_271Z-debug.log [0] npm run server exited with code 1 --> Sending SIGTERM to other processes.. [1] npm run client exited with code SIGTERM npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! nykredit-network@0.0.1 dev: `concurrently --kill-others-on-fail "npm run server" "npm run client"` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the nykredit-network@0.0.1 dev script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! /home/zcy/.npm/_logs/2018-12-17T02_31_36_412Z-debug.log ```
npm问题'Path must be a string
> app@1.0.0 dev D:\work\qk\app > node build/dev-server.js [HPM] Proxy created: /api -> http://xxx.xxx.x.xxx [HPM] Proxy rewrite rule created: "^/api" ~> "/api" path.js:7 throw new TypeError('Path must be a string. Received ' + inspect(path)); ^ TypeError: Path must be a string. Received undefined at assertPath (path.js:7:11) at Object.join (path.js:1211:7) at Object.<anonymous> (D:\work\qk\app\build\dev-server.js:57:29) at Module._compile (module.js:541:32) at Object.Module._extensions..js (module.js:550:10) at Module.load (module.js:458:32) at tryModuleLoad (module.js:417:12) at Function.Module._load (module.js:409:3) at Function.Module.runMain (module.js:575:10) at startup (node.js:160:18) at node.js:449:3 npm ERR! Windows_NT 10.0.14393 npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "run" "dev" npm ERR! node v6.2.0 npm ERR! npm v3.8.9 npm ERR! code ELIFECYCLE npm ERR! app@1.0.0 dev: `node build/dev-server.js` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the app@1.0.0 dev script 'node build/dev-server.js'. npm ERR! Make sure you have the latest version of node.js and npm installed. npm ERR! If you do, this is most likely a problem with the app package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: npm ERR! node build/dev-server.js npm ERR! You can get information on how to open an issue for this project with: npm ERR! npm bugs app npm ERR! Or if that isn't available, you can get their info via: npm ERR! npm owner ls app npm ERR! There is likely additional logging output above. npm ERR! Please include the following file with any support request: npm ERR! D:\work\qk\app\npm-debug.log
webpack 打包报错,怎么解决,大神帮忙看一下 多谢
ERROR in ./node_modules/_css-loader@0.28.11@css-loader!./src/assets/vendor/mui/css/mui.css Module build failed: @ ./src/assets/vendor/mui/css/mui.css 2:14-104 @ ./src/main.js npm ERR! code ELIFECYCLE npm ERR! errno 2 npm ERR! y@1.0.0 build: `cross-env NODE_ENV=production webpack --progress --hide-modules` npm ERR! Exit status 2 npm ERR! npm ERR! Failed at the y@1.0.0 build script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in:
为什么nuxt.js无法安装node-sass?
1.npm 不管怎么样都安装不了 淘宝镜像也没用 2.每次安装后都卡在Downloading binary from https://github.com/sass/node-sass/releases/download/v4.12.0/win32-x64-64这里然后就报错 3.T.T小白求教 ``` PS E:\Users\FuYuHao\Desktop\sb\a\aaa> npm i node-sass > node-sass@4.12.0 install E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass > node scripts/install.js Downloading binary from https://github.com/sass/node-sass/releases/download/v4.12.0/win32-x64-64_binding.node Cannot download "https://github.com/sass/node-sass/releases/download/v4.12.0/win32-x64-64_binding.node": connect ETIMEDOUT 52.216.135.19:443 Timed out whilst downloading the prebuilt binary Hint: If github.com is not accessible in your location try setting a proxy via HTTP_PROXY, e.g. export HTTP_PROXY=http://example.com:1234 or configure npm proxy via npm config set proxy http://example.com:8080 > node-sass@4.12.0 postinstall E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass > node scripts/build.js Building: C:\Program Files\nodejs\node.exe E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-gyp\bin\node-gyp.js rebuild --verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library= gyp info it worked if it ends with ok gyp verb cli [ 'C:\\Program Files\\nodejs\\node.exe', gyp verb cli 'E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\node-gyp\\bin\\node-gyp.js', gyp verb cli 'rebuild', gyp verb cli '--verbose', gyp verb cli '--libsass_ext=', gyp verb cli '--libsass_cflags=', gyp verb cli '--libsass_ldflags=', gyp verb cli '--libsass_library=' ] gyp info using node-gyp@3.8.0 gyp info using node@10.14.1 | win32 | x64 gyp verb command rebuild [] gyp verb command clean [] gyp verb clean removing "build" directory gyp verb command configure [] gyp verb check python checking for Python executable "python2" in the PATH gyp verb `which` failed Error: not found: python2 gyp verb `which` failed at getNotFoundError (E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\which\which.js:13:12) gyp verb `which` failed at F (E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\which\which.js:68:19) gyp verb `which` failed at E (E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\which\which.js:80:29) gyp verb `which` failed at E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\which\which.js:89:16 gyp verb `which` failed at E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\isexe\index.js:42:5 gyp verb `which` failed at E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\isexe\windows.js:36:5 gyp verb `which` failed at FSReqWrap.oncomplete (fs.js:154:21) gyp verb `which` failed python2 { Error: not found: python2 gyp verb `which` failed at getNotFoundError (E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\which\which.js:13:12) gyp verb `which` failed at F (E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\which\which.js:68:19) gyp verb `which` failed at E (E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\which\which.js:80:29) gyp verb `which` failed at E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\which\which.js:89:16 gyp verb `which` failed at E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\isexe\index.js:42:5 gyp verb `which` failed at E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\isexe\windows.js:36:5 gyp verb `which` failed at FSReqWrap.oncomplete (fs.js:154:21) gyp verb `which` failed stack: gyp verb `which` failed 'Error: not found: python2\n at getNotFoundError (E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\which\\which.js:13:12)\n at F (E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\which\\which.js:68:19)\n at E (E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\which\\which.js:80:29)\n at E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\which\\which.js:89:16\n at E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\isexe\\index.js:42:5\n at E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\isexe\\windows.js:36:5\n at FSReqWrap.oncomplete (fs.js:154:21)', gyp verb `which` failed code: 'ENOENT' } gyp verb check python checking for Python executable "python" in the PATH gyp verb `which` succeeded python C:\Python27\python.EXE gyp verb check python version `C:\Python27\python.EXE -c "import sys; print "2.7.15 gyp verb check python version .%s.%s" % sys.version_info[:3];"` returned: %j gyp verb get node dir no --target version specified, falling back to host node version: 10.14.1 gyp verb command install [ '10.14.1' ] gyp verb install input version string "10.14.1" gyp verb install installing version: 10.14.1 gyp verb install --ensure was passed, so won't reinstall if already installed gyp verb install version is already installed, need to check "installVersion" gyp verb got "installVersion" 9 gyp verb needs "installVersion" 9 gyp verb install version is good gyp verb get node dir target node version installed: 10.14.1 gyp verb build dir attempting to create "build" dir: E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build gyp verb build dir "build" dir needed to be created? E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build gyp verb find vs2017 Found installation at: C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools gyp verb find vs2017 - Found Microsoft.VisualStudio.Component.Windows10SDK.17763 gyp verb find vs2017 - Found Microsoft.VisualStudio.Component.VC.Tools.x86.x64 gyp verb find vs2017 - Found Microsoft.VisualStudio.VC.MSBuild.Base gyp verb find vs2017 - Using this installation with Windows 10 SDK gyp verb find vs2017 using installation: C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools gyp verb build/config.gypi creating config file gyp verb build/config.gypi writing out config file: E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\config.gypi gyp verb config.gypi checking for gypi file: E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\config.gypi gyp verb common.gypi checking for gypi file: E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\common.gypi gyp verb gyp gyp format was not specified; forcing "msvs" gyp info spawn C:\Python27\python.EXE gyp info spawn args [ 'E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\node-gyp\\gyp\\gyp_main.py', gyp info spawn args 'binding.gyp', gyp info spawn args '-f', gyp info spawn args 'msvs', gyp info spawn args '-G', gyp info spawn args 'msvs_version=2015', gyp info spawn args '-I', gyp info spawn args 'E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\node-sass\\build\\config.gypi', gyp info spawn args '-I', gyp info spawn args 'E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\node-gyp\\addon.gypi', gyp info spawn args '-I', gyp info spawn args 'C:\\Users\\FuYuHao\\.node-gyp\\10.14.1\\include\\node\\common.gypi', gyp info spawn args '-Dlibrary=shared_library', gyp info spawn args '-Dvisibility=default', gyp info spawn args '-Dnode_root_dir=C:\\Users\\FuYuHao\\.node-gyp\\10.14.1', gyp info spawn args '-Dnode_gyp_dir=E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\node-gyp', gyp info spawn args '-Dnode_lib_file=C:\\Users\\FuYuHao\\.node-gyp\\10.14.1\\<(target_arch)\\node.lib', gyp info spawn args '-Dmodule_root_dir=E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\node-sass', gyp info spawn args '-Dnode_engine=v8', gyp info spawn args '--depth=.', gyp info spawn args '--no-parallel', gyp info spawn args '--generator-output', gyp info spawn args 'E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\node-sass\\build', gyp info spawn args '-Goutput_dir=.' ] gyp verb command build [] gyp verb build type Release gyp verb architecture x64 gyp verb node dev dir C:\Users\FuYuHao\.node-gyp\10.14.1 gyp verb found first Solution file build/binding.sln gyp verb using MSBuild: C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\MSBuild\15.0\Bin\MSBuild.exe gyp info spawn C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\MSBuild\15.0\Bin\MSBuild.exe gyp info spawn args [ 'build/binding.sln', gyp info spawn args '/nologo', gyp info spawn args '/p:Configuration=Release;Platform=x64' ] 在此解决方案中一次生成一个项目。若要启用并行生成,请添加“/m”开关。 生成启动时间为 2019/5/29 22:01:12。 节点 1 上的项目“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.sln”(默认目标)。 ValidateSolutionConfiguration: 正在生成解决方案配置“Release|x64”。 项目“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.sln”(1)正在节点 1 上生成“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj.metaproj”(2) (默认目标)。 项目“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj.metaproj”(2)正在节点 1 上生成“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj”(3) (默认目标)。 PrepareForBuild: 正在创建目录“Release\obj\libsass\”。 正在创建目录“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\Release\”。 正在创建目录“Release\obj\libsass\libsass.tlog\”。 InitializeBuildStatus: 正在创建“Release\obj\libsass\libsass.tlog\unsuccessfulbuild”,因为已指定“AlwaysCreate”。 ClCompile: C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Tools\MSVC\14.16.27023\bin\HostX64\x64\CL.exe /c /I"C:\Users\FuYuHao\.node-gyp\10.14.1\include\node" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\src" /I"C:\Use rs\FuYuHao\.node-gyp\10.14.1\deps\openssl\config" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\openssl\openssl\include" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\uv\include" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\zli b" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\v8\include" /I..\..\src\libsass\include /Z7 /nologo /W3 /WX- /diagnostics:classic /MP /Ox /Ob2 /Oi /Ot /Oy /GL /D NODE_GYP_MODULE_NAME=libsass /D USING_UV_SHARED=1 /D USING_ V8_SHARED=1 /D V8_DEPRECATION_WARNINGS=1 /D WIN32 /D _CRT_SECURE_NO_DEPRECATE /D _CRT_NONSTDC_NO_DEPRECATE /D _HAS_EXCEPTIONS=0 /D "LIBSASS_VERSION=\"3.5.4\"" /GF /Gm- /MT /GS /Gy /fp:precise /Zc:wchar_t /Zc:forScope /Z c:inline /GR- /Fo"Release\obj\libsass\\" /Fd"Release\obj\libsass\libsass.pdb" /Gd /TP /wd4351 /wd4355 /wd4800 /wd4251 /wd4275 /wd4244 /wd4267 /FC /errorReport:queue /GR /EHsc ..\..\src\libsass\src\ast.cpp ..\..\src\libs ass\src\ast_fwd_decl.cpp ..\..\src\libsass\src\backtrace.cpp ..\..\src\libsass\src\base64vlq.cpp ..\..\src\libsass\src\bind.cpp ..\..\src\libsass\src\check_nesting.cpp ..\..\src\libsass\src\color_maps.cpp ..\..\src\libs ass\src\constants.cpp ..\..\src\libsass\src\context.cpp ..\..\src\libsass\src\cssize.cpp ..\..\src\libsass\src\emitter.cpp ..\..\src\libsass\src\environment.cpp ..\..\src\libsass\src\error_handling.cpp ..\..\src\libsass \src\eval.cpp ..\..\src\libsass\src\expand.cpp ..\..\src\libsass\src\extend.cpp ..\..\src\libsass\src\file.cpp ..\..\src\libsass\src\functions.cpp ..\..\src\libsass\src\inspect.cpp ..\..\src\libsass\src\json.cpp ..\..\s rc\libsass\src\lexer.cpp ..\..\src\libsass\src\listize.cpp ..\..\src\libsass\src\memory\SharedPtr.cpp ..\..\src\libsass\src\node.cpp ..\..\src\libsass\src\operators.cpp ..\..\src\libsass\src\output.cpp ..\..\src\libsass \src\parser.cpp ..\..\src\libsass\src\plugins.cpp ..\..\src\libsass\src\position.cpp ..\..\src\libsass\src\prelexer.cpp ..\..\src\libsass\src\remove_placeholders.cpp ..\..\src\libsass\src\sass.cpp ..\..\src\libsass\src\ sass2scss.cpp ..\..\src\libsass\src\sass_context.cpp ..\..\src\libsass\src\sass_functions.cpp ..\..\src\libsass\src\sass_util.cpp ..\..\src\libsass\src\sass_values.cpp ..\..\src\libsass\src\source_map.cpp ..\..\src\libs ass\src\subset_map.cpp ..\..\src\libsass\src\to_c.cpp ..\..\src\libsass\src\to_value.cpp ..\..\src\libsass\src\units.cpp ..\..\src\libsass\src\utf8_string.cpp ..\..\src\libsass\src\util.cpp ..\..\src\libsass\src\values. cpp cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] ast.cpp cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] ast_fwd_decl.cpp cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] backtrace.cpp cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] base64vlq.cpp bind.cpp check_nesting.cpp color_maps.cpp constants.cpp context.cpp cssize.cpp emitter.cpp environment.cpp error_handling.cpp eval.cpp expand.cpp extend.cpp file.cpp functions.cpp inspect.cpp json.cpp e:\users\fuyuhao\desktop\sb\a\aaa\node_modules\node-sass\src\libsass\src\json.cpp(26): warning C4005: “_CRT_NONSTDC_NO_DEPRECATE”: 宏重定义 [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxp roj] e:\users\fuyuhao\desktop\sb\a\aaa\node_modules\node-sass\src\libsass\src\json.cpp: note: 参见“_CRT_NONSTDC_NO_DEPRECATE”的前一个定义 lexer.cpp listize.cpp SharedPtr.cpp node.cpp operators.cpp output.cpp parser.cpp plugins.cpp position.cpp prelexer.cpp remove_placeholders.cpp sass.cpp sass2scss.cpp e:\users\fuyuhao\desktop\sb\a\aaa\node_modules\node-sass\src\libsass\src\sass2scss.cpp(9): warning C4005: “_CRT_NONSTDC_NO_DEPRECATE”: 宏重定义 [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass. vcxpr oj] e:\users\fuyuhao\desktop\sb\a\aaa\node_modules\node-sass\src\libsass\src\sass2scss.cpp: note: 参见“_CRT_NONSTDC_NO_DEPRECATE”的前一个定义 sass_context.cpp sass_functions.cpp sass_util.cpp sass_values.cpp source_map.cpp subset_map.cpp to_c.cpp to_value.cpp units.cpp utf8_string.cpp util.cpp values.cpp C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Tools\MSVC\14.16.27023\bin\HostX64\x64\CL.exe /c /I"C:\Users\FuYuHao\.node-gyp\10.14.1\include\node" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\src" /I"C:\Use rs\FuYuHao\.node-gyp\10.14.1\deps\openssl\config" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\openssl\openssl\include" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\uv\include" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\zli b" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\v8\include" /I..\..\src\libsass\include /Z7 /nologo /W3 /WX- /diagnostics:classic /MP /Ox /Ob2 /Oi /Ot /Oy /GL /D NODE_GYP_MODULE_NAME=libsass /D USING_UV_SHARED=1 /D USING_ V8_SHARED=1 /D V8_DEPRECATION_WARNINGS=1 /D WIN32 /D _CRT_SECURE_NO_DEPRECATE /D _CRT_NONSTDC_NO_DEPRECATE /D _HAS_EXCEPTIONS=0 /D "LIBSASS_VERSION=\"3.5.4\"" /GF /Gm- /MT /GS /Gy /fp:precise /Zc:wchar_t /Zc:forScope /Z c:inline /GR- /Fo"Release\obj\libsass\\" /Fd"Release\obj\libsass\libsass.pdb" /Gd /TC /wd4351 /wd4355 /wd4800 /wd4251 /wd4275 /wd4244 /wd4267 /FC /errorReport:queue /GR /EHsc ..\..\src\libsass\src\cencode.c cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] cencode.c Lib: C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Tools\MSVC\14.16.27023\bin\HostX64\x64\Lib.exe /OUT:"E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\Release\libsass.lib" /NOLOGO /MACHINE :X64 /LTCG:INCREMENTAL Release\obj\libsass\ast.obj Release\obj\libsass\ast_fwd_decl.obj Release\obj\libsass\backtrace.obj Release\obj\libsass\base64vlq.obj Release\obj\libsass\bind.obj Release\obj\libsass\cencode.obj Release\obj\libsass\check_nesting.obj Release\obj\libsass\color_maps.obj Release\obj\libsass\constants.obj Release\obj\libsass\context.obj Release\obj\libsass\cssize.obj Release\obj\libsass\emitter.obj Release\obj\libsass\environment.obj Release\obj\libsass\error_handling.obj Release\obj\libsass\eval.obj Release\obj\libsass\expand.obj Release\obj\libsass\extend.obj Release\obj\libsass\file.obj Release\obj\libsass\functions.obj Release\obj\libsass\inspect.obj Release\obj\libsass\json.obj Release\obj\libsass\lexer.obj Release\obj\libsass\listize.obj Release\obj\libsass\SharedPtr.obj Release\obj\libsass\node.obj Release\obj\libsass\operators.obj Release\obj\libsass\output.obj Release\obj\libsass\parser.obj Release\obj\libsass\plugins.obj Release\obj\libsass\position.obj Release\obj\libsass\prelexer.obj Release\obj\libsass\remove_placeholders.obj Release\obj\libsass\sass.obj Release\obj\libsass\sass2scss.obj Release\obj\libsass\sass_context.obj Release\obj\libsass\sass_functions.obj Release\obj\libsass\sass_util.obj Release\obj\libsass\sass_values.obj Release\obj\libsass\source_map.obj Release\obj\libsass\subset_map.obj Release\obj\libsass\to_c.obj Release\obj\libsass\to_value.obj Release\obj\libsass\units.obj Release\obj\libsass\utf8_string.obj Release\obj\libsass\util.obj Release\obj\libsass\values.obj libsass.vcxproj -> E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\Release\\libsass.lib FinalizeBuildStatus: 正在删除文件“Release\obj\libsass\libsass.tlog\unsuccessfulbuild”。 正在对“Release\obj\libsass\libsass.tlog\libsass.lastbuildstate”执行 Touch 任务。 已完成生成项目“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj”(默认目标)的操作。 项目“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj.metaproj”(2)正在节点 1 上生成“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj”(4) (默认目标)。 PrepareForBuild: 正在创建目录“Release\obj\binding\”。 正在创建目录“Release\obj\binding\binding.tlog\”。 InitializeBuildStatus: 正在创建“Release\obj\binding\binding.tlog\unsuccessfulbuild”,因为已指定“AlwaysCreate”。 ClCompile: C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Tools\MSVC\14.16.27023\bin\HostX64\x64\CL.exe /c /I"C:\Users\FuYuHao\.node-gyp\10.14.1\include\node" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\src" /I"C:\Use rs\FuYuHao\.node-gyp\10.14.1\deps\openssl\config" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\openssl\openssl\include" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\uv\include" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\zli b" /I"C:\Users\FuYuHao\.node-gyp\10.14.1\deps\v8\include" /I..\..\nan /I..\src\libsass\include /Z7 /nologo /W3 /WX- /diagnostics:classic /MP /Ox /Ob2 /Oi /Ot /Oy /GL /D NODE_GYP_MODULE_NAME=binding /D USING_UV_SHARED=1 /D USING_V8_SHARED=1 /D V8_DEPRECATION_WARNINGS=1 /D WIN32 /D _CRT_SECURE_NO_DEPRECATE /D _CRT_NONSTDC_NO_DEPRECATE /D _HAS_EXCEPTIONS=0 /D BUILDING_NODE_EXTENSION /D _WINDLL /GF /Gm- /MT /GS /Gy /fp:precise /Zc:wchar_t /Zc:forScope /Zc:inline /GR- /Fo"Release\obj\binding\\" /Fd"Release\obj\binding\vc141.pdb" /Gd /TP /wd4351 /wd4355 /wd4800 /wd4251 /wd4275 /wd4244 /wd4267 /FC /errorReport:queue /Zc:threadSafeInit- ..\src\binding.cpp . .\src\create_string.cpp ..\src\custom_function_bridge.cpp ..\src\custom_importer_bridge.cpp ..\src\sass_context_wrapper.cpp ..\src\sass_types\boolean.cpp ..\src\sass_types\color.cpp ..\src\sass_types\error.cpp ..\src\sa ss_types\factory.cpp ..\src\sass_types\list.cpp ..\src\sass_types\map.cpp ..\src\sass_types\null.cpp ..\src\sass_types\number.cpp ..\src\sass_types\string.cpp "E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-gyp\src \win_delay_load_hook.cc" binding.cpp create_string.cpp custom_function_bridge.cpp custom_importer_bridge.cpp sass_context_wrapper.cpp boolean.cpp color.cpp error.cpp factory.cpp list.cpp map.cpp null.cpp number.cpp string.cpp win_delay_load_hook.cc Link: C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Tools\MSVC\14.16.27023\bin\HostX64\x64\link.exe /ERRORREPORT:QUEUE /OUT:"E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\Release\binding.n ode" /INCREMENTAL:NO /NOLOGO kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib DelayImp.lib "C:\Users\FuYuHao\.node-gyp\10.14.1\x64\node.lib" Delayimp.lib /DELAYLOAD:iojs.exe /DELAYLOAD:node.exe /MANIFEST /MANIFESTUAC:"level='asInvoker' uiAccess='false'" /manifest:embed /DEBUG /PDB:"E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\Release\bindi ng.pdb" /MAP /MAPINFO:EXPORTS /OPT:REF /OPT:ICF /TLBID:1 /RELEASE /DYNAMICBASE /NXCOMPAT /MACHINE:X64 /ignore:4199 /LTCG:INCREMENTAL /DLL Release\obj\binding\binding.obj Release\obj\binding\create_string.obj Release\obj\binding\custom_function_bridge.obj Release\obj\binding\custom_importer_bridge.obj Release\obj\binding\sass_context_wrapper.obj Release\obj\binding\boolean.obj Release\obj\binding\color.obj Release\obj\binding\error.obj Release\obj\binding\factory.obj Release\obj\binding\list.obj Release\obj\binding\map.obj Release\obj\binding\null.obj Release\obj\binding\number.obj Release\obj\binding\string.obj Release\obj\binding\win_delay_load_hook.obj "E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\Release\libsass.lib" C:\Users\FuYuHao\.node-gyp\10.14.1\x64\node.lib : fatal error LNK1107: 文件无效或损坏: 无法在 0x39F993 处读取 [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj] 已完成生成项目“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj”(默认目标)的操作 - 失败。 已完成生成项目“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj.metaproj”(默认目标)的操作 - 失败。 已完成生成项目“E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.sln”(默认目标)的操作 - 失败。 生成失败。 “E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.sln”(默认目标) (1) -> “E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj.metaproj”(默认目标) (2) -> “E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj”(默认目标) (3) -> (ClCompile 目标) -> cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] e:\users\fuyuhao\desktop\sb\a\aaa\node_modules\node-sass\src\libsass\src\json.cpp(26): warning C4005: “_CRT_NONSTDC_NO_DEPRECATE”: 宏重定义 [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vc xproj ] e:\users\fuyuhao\desktop\sb\a\aaa\node_modules\node-sass\src\libsass\src\sass2scss.cpp(9): warning C4005: “_CRT_NONSTDC_NO_DEPRECATE”: 宏重定义 [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsas s.vcx proj] “E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.sln”(默认目标) (1) -> “E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj.metaproj”(默认目标) (2) -> “E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj”(默认目标) (3) -> cl : 命令行 warning D9025: 正在重写“/GR-”(用“/GR”) [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\src\libsass.vcxproj] “E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.sln”(默认目标) (1) -> “E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj.metaproj”(默认目标) (2) -> “E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj”(默认目标) (4) -> (Link 目标) -> C:\Users\FuYuHao\.node-gyp\10.14.1\x64\node.lib : fatal error LNK1107: 文件无效或损坏: 无法在 0x39F993 处读取 [E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass\build\binding.vcxproj] 8 个警告 1 个错误 已用时间 00:00:24.13 gyp ERR! build error gyp ERR! stack Error: `C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\MSBuild\15.0\Bin\MSBuild.exe` failed with exit code: 1 gyp ERR! stack at ChildProcess.onExit (E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-gyp\lib\build.js:262:23) gyp ERR! stack at ChildProcess.emit (events.js:182:13) gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:240:12) gyp ERR! System Windows_NT 10.0.17763 gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "E:\\Users\\FuYuHao\\Desktop\\sb\\a\\aaa\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library=" gyp ERR! cwd E:\Users\FuYuHao\Desktop\sb\a\aaa\node_modules\node-sass gyp ERR! node -v v10.14.1 gyp ERR! node-gyp -v v3.8.0 gyp ERR! not ok Build failed with error code: 1 npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.0.7 (node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.0.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\watchpack\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\nodemon\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! node-sass@4.12.0 postinstall: `node scripts/build.js` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the node-sass@4.12.0 postinstall script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\FuYuHao\AppData\Roaming\npm-cache\_logs\2019-05-29T14_01_39_903Z-debug.log PS E:\Users\FuYuHao\Desktop\sb\a\aaa> ```
webpack build报错 ERROR in 1.ea409344b3c6c7fd1ccf.chunk.js from UglifyJs
项目可以正常运行,突然打包报错,有没有大神指点一下 ``` ERROR in 1.ea409344b3c6c7fd1ccf.chunk.js from UglifyJs Unexpected token: operator (>) [1.ea409344b3c6c7fd1ccf.chunk.js:4739,34] Child html-webpack-plugin for "..\index.html": 1 asset Child extract-text-webpack-plugin node_modules/_extract-text-webpack-plugin@3.0.2@extract-text-webpack-plugin/dist node_modules/_css-loader@0.28.11@css-loader/index.js?minimize!node_modules/_autoprefixer-loader@3.2.0@autoprefixer-loader/index.js!node_modules/_iview@3.3.3@iview/dist/styles/iview.css: 3 assets Child extract-text-webpack-plugin node_modules/_extract-text-webpack-plugin@3.0.2@extract-text-webpack-plugin/dist node_modules/_css-loader@0.28.11@css-loader/index.js?minimize!node_modules/_autoprefixer-loader@3.2.0@autoprefixer-loader/index.js!node_modules/_less-loader@4.1.0@less-loader/dist/cjs.js!src/styles/my-theme.less: Asset Size Chunks Chunk Names d535a25a79fb1365ae814b61e88fae71.ttf 198 kB [emitted] 99ac3308dd8ee14f749f51538d0d5b9e.woff 198 kB [emitted] a2c4a261a239aa84463dc70e4bac9b9a.svg 555 kB [emitted] [big] npm ERR! code ELIFECYCLE npm ERR! errno 2 npm ERR! smart-lock@1.2.3 build: `webpack --progress --hide-modules --config build/webpack.prod.config.js` npm ERR! Exit status 2 npm ERR! npm ERR! Failed at the smart-lock@1.2.3 build script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. ```
在中国程序员是青春饭吗?
今年,我也32了 ,为了不给大家误导,咨询了猎头、圈内好友,以及年过35岁的几位老程序员……舍了老脸去揭人家伤疤……希望能给大家以帮助,记得帮我点赞哦。 目录: 你以为的人生 一次又一次的伤害 猎头界的真相 如何应对互联网行业的「中年危机」 一、你以为的人生 刚入行时,拿着傲人的工资,想着好好干,以为我们的人生是这样的: 等真到了那一天,你会发现,你的人生很可能是这样的: ...
深析Synchronized关键字(小白慎入,深入jvm源码,两万字长文)
目录一、synchronized基础1.1synchronized的使用1.1示例1.2验证1.2.1 普通方法和代码块中使用this是同一个监视器(锁),即某个具体调用该代码的对象1.2.2 静态方法和代码块中使用该类的class对象是同一个监视器,任何该类的对象调用该段代码时都是在争夺同一个监视器的锁定1.2、synchronized的特点二、synchronized进阶2.1对象头2.2sy
GitHub 总星 4w+!删库?女装?表情包?这些沙雕中文项目真是我每天快乐的源泉!
大家好,我是 Rocky0429,一个喜欢在 GitHub 上瞎逛的蒟蒻… 好看的皮囊千篇一律,有趣的灵魂没有底线。作为全球最大的同性交友网站,GayHub GitHub 上不止有鲜活的代码,秃头的算法,还有很多拥有有(sha)趣(diao)灵魂的宝藏。 还记得我之前给大家介绍的 Sorry 项目嘛,一个可以自己做表情包的项目,这个的沙雕程度在下面这些项目面前只能算弟弟。虽然说沙雕不分国...
程序员请照顾好自己,周末病魔差点一套带走我。
程序员在一个周末的时间,得了重病,差点当场去世,还好及时挽救回来了。
卸载 x 雷某度!GitHub 标星 1.5w+,从此我只用这款全能高速下载工具!
作者 | Rocky0429 来源 | Python空间 大家好,我是 Rocky0429,一个喜欢在网上收集各种资源的蒟蒻… 网上资源眼花缭乱,下载的方式也同样千奇百怪,比如 BT 下载,磁力链接,网盘资源等等等等,下个资源可真不容易,不一样的方式要用不同的下载软件,因此某比较有名的 x 雷和某度网盘成了我经常使用的工具。 作为一个没有钱的穷鬼,某度网盘几十 kb 的下载速度让我...
20道你必须要背会的微服务面试题,面试一定会被问到
这篇博客总结了面试中最常见的微服务面试题,相信对你有所帮助。
讲真,这两个IDE插件,可以让你写出质量杠杠的代码
周末躺在床上看《拯救大兵瑞恩》 周末在闲逛的时候,发现了两个优秀的 IDE 插件,据说可以提高代码的质量,我就安装了一下,试了试以后发现,确实很不错,就推荐给大家。 01、Alibaba Java 代码规范插件 《阿里巴巴 Java 开发手册》,相信大家都不会感到陌生,其 IDEA 插件的下载次数据说达到了 80 万次,我今天又贡献了一次。嘿嘿。 该项目的插件地址: https://github....
为什么猝死的都是程序员,基本上不见产品经理猝死呢?
相信大家时不时听到程序员猝死的消息,但是基本上听不到产品经理猝死的消息,这是为什么呢? 我们先百度搜一下:程序员猝死,出现将近700多万条搜索结果: 搜索一下:产品经理猝死,只有400万条的搜索结果,从搜索结果数量上来看,程序员猝死的搜索结果就比产品经理猝死的搜索结果高了一倍,而且从下图可以看到,首页里面的五条搜索结果,其实只有两条才是符合条件。 所以程序员猝死的概率真的比产品经理大,并不是错...
毕业5年,我问遍了身边的大佬,总结了他们的学习方法
我问了身边10个大佬,总结了他们的学习方法,原来成功都是有迹可循的。
推荐10个堪称神器的学习网站
每天都会收到很多读者的私信,问我:“二哥,有什么推荐的学习网站吗?最近很浮躁,手头的一些网站都看烦了,想看看二哥这里有什么新鲜货。” 今天一早做了个恶梦,梦到被老板辞退了。虽然说在我们公司,只有我辞退老板的份,没有老板辞退我这一说,但是还是被吓得 4 点多都起来了。(主要是因为我掌握着公司所有的核心源码,哈哈哈) 既然 4 点多起来,就得好好利用起来。于是我就挑选了 10 个堪称神器的学习网站,推...
良心推荐,我珍藏的一些Chrome插件
上次搬家的时候,发了一个朋友圈,附带的照片中不小心暴露了自己的 Chrome 浏览器插件之多,于是就有小伙伴评论说分享一下我觉得还不错的浏览器插件。 我下面就把我日常工作和学习中经常用到的一些 Chrome 浏览器插件分享给大家,随便一个都能提高你的“生活品质”和工作效率。 Markdown Here Markdown Here 可以让你更愉快的写邮件,由于支持 Markdown 直接转电子邮...
看完这篇HTTP,跟面试官扯皮就没问题了
我是一名程序员,我的主要编程语言是 Java,我更是一名 Web 开发人员,所以我必须要了解 HTTP,所以本篇文章就来带你从 HTTP 入门到进阶,看完让你有一种恍然大悟、醍醐灌顶的感觉。 最初在有网络之前,我们的电脑都是单机的,单机系统是孤立的,我还记得 05 年前那会儿家里有个电脑,想打电脑游戏还得两个人在一个电脑上玩儿,及其不方便。我就想为什么家里人不让上网,我的同学 xxx 家里有网,每...
2020 年,大火的 Python 和 JavaScript 是否会被取而代之?
Python 和 JavaScript 是目前最火的两大编程语言,但是2020 年,什么编程语言将会取而代之呢? 作者 |Richard Kenneth Eng 译者 |明明如月,责编 | 郭芮 出品 | CSDN(ID:CSDNnews) 以下为译文: Python 和 JavaScript 是目前最火的两大编程语言。然而,他们不可能永远屹立不倒。最终,必将像其他编程语言一...
C语言数字图像处理---1.4直方图拉伸和直方图均衡化
本篇将延续上一篇的内容,对直方图进行扩展,讲述直方图拉伸和直方图均衡化两个内容,并通过简单的C语言来实现这两个基础功能,让初学者通俗易懂。
史上最全的IDEA快捷键总结
现在Idea成了主流开发工具,这篇博客对其使用的快捷键做了总结,希望对大家的开发工作有所帮助。
阿里程序员写了一个新手都写不出的低级bug,被骂惨了。
这种新手都不会范的错,居然被一个工作好几年的小伙子写出来,差点被当场开除了。
谁是华为扫地僧?
是的,华为也有扫地僧!2020年2月11-12日,“养在深闺人不知”的华为2012实验室扫地僧们,将在华为开发者大会2020(Cloud)上,和大家见面。到时,你可以和扫地僧们,吃一个洋...
没用过这些 IDEA 插件?怪不得写代码头疼
使用插件,可以提高开发效率。对于开发人员很有帮助。这篇博客介绍了IDEA中最常用的一些插件。
AI 没让人类失业,搞 AI 的人先失业了
最近和几个 AI 领域的大佬闲聊 根据他们讲的消息和段子 改编出下面这个故事 如有雷同 都是巧合 1. 老王创业失败,被限制高消费 “这里写我跑路的消息实在太夸张了。” 王葱葱哼笑一下,把消息分享给群里。 阿杰也看了消息,笑了笑。在座几位也都笑了。 王葱葱是个有名的人物,21岁那年以全额奖学金进入 KMU 攻读人工智能博士,累计发表论文 40 余篇,个人技术博客更是成为深度学习领域内风向标。 ...
2020年,冯唐49岁:我给20、30岁IT职场年轻人的建议
点击“技术领导力”关注∆每天早上8:30推送 作者|Mr.K 编辑| Emma 来源|技术领导力(ID:jishulingdaoli) 前天的推文《冯唐:职场人35岁以后,方法论比经验重要》,收到了不少读者的反馈,觉得挺受启发。其实,冯唐写了不少关于职场方面的文章,都挺不错的。可惜大家只记住了“春风十里不如你”、“如何避免成为油腻腻的中年人”等不那么正经的文章。 本文整理了冯...
推荐一些有趣的在线编程游戏
1.Robocode 让坦克们互相博弈的游戏,你可以看到它们飞奔,碾碎一切挡道的东西。机器人配有雷达与火炮,选手在躲避对手进攻的同时攻击对手,以此来较量得分的多少。这个游戏很有意思,曾经令我沉迷… 你可以用Java、Scala、C#等编程语言,编写人工智能程序,驱动机器人。 2.Code Combat Code Combat是一款学习编程的角色扮演游戏。每一关都用任务的形式设立目标,用实时的反馈...
工作十年的数据分析师被炒,没有方向,你根本躲不过中年危机
2020年刚刚开始,就意味着离职潮高峰的到来,我身边就有不少人拿着年终奖离职了,而最让我感到意外的,是一位工作十年的数据分析师也离职了,不同于别人的主动辞职,他是被公司炒掉的。 很多人都说数据分析是个好饭碗,工作不累薪资高、入门简单又好学。然而今年34的他,却真正尝到了中年危机的滋味,平时也有不少人都会私信问我: 数据分析师也有中年危机吗?跟程序员一样是吃青春饭的吗?该怎么保证自己不被公司淘汰...
作为一名大学生,如何在B站上快乐的学习?
B站是个宝,谁用谁知道???? 作为一名大学生,你必须掌握的一项能力就是自学能力,很多看起来很牛X的人,你可以了解下,人家私底下一定是花大量的时间自学的,你可能会说,我也想学习啊,可是嘞,该学习啥嘞,不怕告诉你,互联网时代,最不缺的就是学习资源,最宝贵的是啥? 你可能会说是时间,不,不是时间,而是你的注意力,懂了吧! 那么,你说学习资源多,我咋不知道,那今天我就告诉你一个你必须知道的学习的地方,人称...
那些年,我们信了课本里的那些鬼话
教材永远都是有错误的,从小学到大学,我们不断的学习了很多错误知识。 斑羚飞渡 在我们学习的很多小学课文里,有很多是错误文章,或者说是假课文。像《斑羚飞渡》: 随着镰刀头羊的那声吼叫,整个斑羚群迅速分成两拨,老年斑羚为一拨,年轻斑羚为一拨。 就在这时,我看见,从那拨老斑羚里走出一只公斑羚来。公斑羚朝那拨年轻斑羚示意性地咩了一声,一只半大的斑羚应声走了出来。一老一少走到伤心崖,后退了几步,突...
张朝阳回应迟到 1 分钟罚 500:资本家就得剥削员工
loonggg读完需要2分钟速读仅需 1 分钟大家我,我是你们的校长。前几天,搜狐的董事局主席兼 CEO 张朝阳和搜狐都上热搜了。原因很简单,就是搜狐出了“考勤新规”。一封搜狐对员工发布...
一个程序在计算机中是如何运行的?超级干货!!!
强烈声明:本文很干,请自备茶水!???? 开门见山,咱不说废话! 你有没有想过,你写的程序,是如何在计算机中运行的吗?比如我们搞Java的,肯定写过这段代码 public class HelloWorld { public static void main(String[] args) { System.out.println("Hello World!"); } ...
【蘑菇街技术部年会】程序员与女神共舞,鼻血再次没止住。(文末内推)
蘑菇街技术部的年会,别开生面,一样全是美女。
那个在阿里养猪的工程师,5年了……
简介: 在阿里,走过1825天,没有趴下,依旧斗志满满,被称为“五年陈”。他们会被授予一枚戒指,过程就叫做“授戒仪式”。今天,咱们听听阿里的那些“五年陈”们的故事。 下一个五年,猪圈见! 我就是那个在养猪场里敲代码的工程师,一年多前我和20位工程师去了四川的猪场,出发前总架构师慷慨激昂的说:同学们,中国的养猪产业将因为我们而改变。但到了猪场,发现根本不是那么回事:要个WIFI,没有;...
为什么程序猿都不愿意去外包?
分享外包的组织架构,盈利模式,亲身经历,以及根据一些外包朋友的反馈,写了这篇文章 ,希望对正在找工作的老铁有所帮助
Java校招入职华为,半年后我跑路了
何来 我,一个双非本科弟弟,有幸在 19 届的秋招中得到前东家华为(以下简称 hw)的赏识,当时秋招签订就业协议,说是入了某 java bg,之后一系列组织架构调整原因等等让人无法理解的神操作,最终毕业前夕,被通知调往其他 bg 做嵌入式开发(纯 C 语言)。 由于已至于校招末尾,之前拿到的其他 offer 又无法再收回,一时感到无力回天,只得默默接受。 毕业后,直接入职开始了嵌入式苦旅,由于从未...
世界上有哪些代码量很少,但很牛逼很经典的算法或项目案例?
点击上方蓝字设为星标下面开始今天的学习~今天分享四个代码量很少,但很牛逼很经典的算法或项目案例。1、no code 项目地址:https://github.com/kelseyhight...
​两年前不知如何编写代码的我,现在是一名人工智能工程师
全文共3526字,预计学习时长11分钟 图源:Unsplash 经常有小伙伴私信给小芯,我没有编程基础,不会写代码,如何进入AI行业呢?还能赶上AI浪潮吗? 任何时候努力都不算晚。 下面,小芯就给大家讲一个朋友的真实故事,希望能给那些处于迷茫与徘徊中的小伙伴们一丝启发。(下文以第一人称叙述) 图源:Unsplash 正如Elsa所说,职业转换是...
强烈推荐10本程序员必读的书
很遗憾,这个春节注定是刻骨铭心的,新型冠状病毒让每个人的神经都是紧绷的。那些处在武汉的白衣天使们,尤其值得我们的尊敬。而我们这些窝在家里的程序员,能不外出就不外出,就是对社会做出的最大的贡献。 有些读者私下问我,窝了几天,有点颓丧,能否推荐几本书在家里看看。我花了一天的时间,挑选了 10 本我最喜欢的书,你可以挑选感兴趣的来读一读。读书不仅可以平复恐惧的压力,还可以对未来充满希望,毕竟苦难终将会...
作为一个程序员,内存的这些硬核知识你必须懂!
我们之前讲过CPU,也说了CPU和内存的那点事儿,今天咱就再来说说有关内存,作为一个程序员,你必须要懂的哪那些硬核知识! 大白话聊一聊,很重要! 先来大白话的跟大家聊一聊,我们这里说的内存啊,其实就是说的我们电脑里面的内存条,所以嘞,内存就是内存条,数据要放在这上面才能被cpu读取从而做运算,还有硬盘,就是电脑中的C盘啥的,一个程序需要运行的话需要向内存申请一块独立的内存空间,这个程序本身是存放在...
非典逼出了淘宝和京东,新冠病毒能够逼出什么?
loonggg读完需要5分钟速读仅需 2 分钟大家好,我是你们的校长。我知道大家在家里都憋坏了,大家可能相对于封闭在家里“坐月子”,更希望能够早日上班。今天我带着大家换个思路来聊一个问题...
牛逼!一行代码居然能解决这么多曾经困扰我半天的算法题
春节假期这么长,干啥最好?当然是折腾一些算法题了,下面给大家讲几道一行代码就能解决的算法题,当然,我相信这些算法题你都做过,不过就算做过,也是可以看一看滴,毕竟,你当初大概率不是一行代码解决的。 学会了一行代码解决,以后遇到面试官问起的话,就可以装逼了。 一、2 的幂次方 问题描述:判断一个整数 n 是否为 2 的幂次方 对于这道题,常规操作是不断这把这个数除以 2,然后判断是否有余数,直到 ...
Spring框架|JdbcTemplate介绍
文章目录一、JdbcTemplate 概述二、创建对象的源码分析三、JdbcTemplate操作数据库 一、JdbcTemplate 概述 在之前的web学习中,学习了手动封装JDBCtemplate,其好处是通过(sql语句+参数)模板化了编程。而真正的JDBCtemplete类,是Spring框架为我们写好的。 它是 Spring 框架中提供的一个对象,是对原始 Jdbc API 对象的简单...
谁说程序员不懂浪漫——我的C语言结婚请柬(附源码)
前言:但行好事,莫问前程——《增广贤文》 从上学起开始学C++,后面也做过H5,现在做Android。无论是学习用的,还是工作用的,上百个软件不止。但最另我骄傲的是,我用程序烂漫了一把。 用C++语言,利用WIN32框架写一个结婚请柬,文末附源码和使用方法,大家可以自行修改,记得帮我点赞哦。 点开程序,你的电脑像中毒一般,漫天的樱花从屏幕上方,伴随着歌声《今天你要嫁给我》,缓缓落下。 ...
立即提问