nginx要求浏览器下载index.php而不是正常服务

I'm a student just learning about nginx so please bear with me. I've just set up a LEMP stack and installed WordPress by following these guides: https://www.linode.com/docs/websites/cms/how-to-install-and-configure-wordpress https://www.linode.com/docs/websites/lemp/lemp-server-on-centos-7-with-fastcgi

However, when I access my domain where my index should be, I just get a popup to download my index.php. As far as the guides say, everything in my configurations is correct and I've tried making some changes to no avail. Here are my configs:

tburg.io.conf:

server {
     listen 80;
     server_name www.tburg.io tburg.io;
     access_log /var/www/tburg.io/logs/access.log;
     error_log /var/www/tburg.io/logs/error.log;

     location / {
          root /var/www/tburg.io/public_html/;
          index index.php;
     }
}

nginx.conf:

user nginx;
worker_processes auto;
error_log /var/log/nginx/error.log;
pid /run/nginx.pid;

events {
    worker_connections 1024;
}

http {
    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';
access_log  /var/log/nginx/access.log  main;

sendfile            on;
tcp_nopush          on;
tcp_nodelay         on;
keepalive_timeout   65;
types_hash_max_size 2048;

include             /etc/nginx/mime.types;
default_type        application/octet-stream;

# Load modular configuration files from the /etc/nginx/conf.d directory.
# See http://nginx.org/en/docs/ngx_core_module.html#include
# for more information.
include /etc/nginx/conf.d/*.conf;

server {
    listen       80 default_server;
    listen       [::]:80 default_server;
    server_name  _;
    root         /usr/share/nginx/html;

    # Load configuration files for the default server block.
    include /etc/nginx/default.d/*.conf;

    location / {
    }

    error_page 404 /404.html;
        location = /40x.html {
    }

    error_page 500 502 503 504 /50x.html;
        location = /50x.html {
    }
}
}

From what I've read, it seems like maybe nginx isn't using fastcgi to parse PHP the way it's supposed to? However, none of the previous iterations of this question seem to fit the way I've got nginx configured, but it's unclear what I'm doing wrong. Thanks for your help!

1个回答



朋友帮我解决了这个问题。 我将在我遇到此问题时在我试图设置的博客上发布有关正确设置的指南,并在我完成后将其发布在此处。</ p>
</ div>

展开原文

原文

A friend helped me get this fixed. I'll be posting a guide on setting this up properly on the blog I was trying to set up when I encountered this issue, and will post it here when I finish.

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐