doudao9896
2016-10-01 18:34
浏览 922
已采纳

mysqli_connect():( HY000 / 2002):无法建立连接,因为目标计算机主动拒绝它

I know there are many questions like this, but i didn't find any solution in it.

Things i tried:-

  • checked firewall

  • restarted my PC and Apache server

  • restarted MYSQL

  • checked my code

  • Tried everything i know and found on internet

here's my code:-

<?php

$dbhost = 'localhost:3360';
$dbuser = 'root';
$dbpass = '';
$db     = 'test_db13';


$conn  = mysqli_connect($dbhost,$dbuser,'',$db);

if(! $conn){
  die('Could not connect connect: ') ;
}

echo 'Successfully Connected';


$sql = 'Connected Successfully';
  $retvalue = mysqli_query($sql);

  if(! $retvalue){
    die('Cannot connect to SQL: ');
  }

echo 'DataBase test_db13 has successfully created';

mysqli_close($conn);

 ?>

I did set the password, but it still is showing me the error.

Here's the firewall picture:- enter image description here

lastly XAMMP is running here's the proof

enter image description here

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • dozug64282 2016-10-01 18:55
    已采纳

    If you look at your XAMPP Control Panel, it's clearly stated that the port to the MySQL server is 3306 - you provided 3360. The 3306 is default, and thus doesn't need to be specified. Even so, the 5th parameter of mysqli_connect() is the port, which is where it should be specified.

    You could just remove the port specification altogether, as you're using the default port, making it

    $dbhost = 'localhost';
    $dbuser = 'root';
    $dbpass = '';
    $db     = 'test_db13';
    

    References

    点赞 打赏 评论
  • duan198811 2016-10-01 18:51

    You have entered wrong port number 3360 instead of 3306. You dont need to write database port number if you are using daefault (3306 in case of MySQL)

    点赞 打赏 评论
  • dongyuan1970 2016-10-01 18:52

    In your PHP code you have set the incorrect port, this is what the code should be

    <?php
    
    $dbhost = 'localhost';
    $dbuser = 'root';
    $dbpass = '';
    $db     = 'test_db13';
    

    The port in your code is set to 3360 when it should be 3306, however as this is the default port, you don't need to specify.

    点赞 打赏 评论

相关推荐 更多相似问题