在MAMP中更改openssl版本

openssl 0.9.8 </ code> 无法使用 tls 1.2 </ code>:</ p>

 <  code> user @ computer:/ usr / bin / openssl version 
OpenSSL 0.9.8zg 2015年7月14日
user @ computer:/ usr / bin / openssl s_client -connect somesite.com:8443
CONNECTED(00000003)
write:errno= 54
</ code> </ pre>

openssl 1.0.2 </ code>正在使用它:</ p>

  user  @computer:openssl版本
OpenSSL 1.0.2d 2015年7月9日
user @ computer:openssl s_client -connect somesite.com:8443
CONNECTED(00000003)
depth=2 C = US,O =“blah-blah”...

....
</ code> </ pre>

我正在使用 MAMP 作为本地服务器。 phpinfo </ code>:
</ p>

如何在 MAMP中更改 openssl </ code>版本</ code> ?
我知道,这个问题是重复,但我真的需要帮助 。</ p>
</ div>

展开原文

原文

openssl 0.9.8 doesn't work with tls 1.2:

user@computer: /usr/bin/openssl version
OpenSSL 0.9.8zg 14 July 2015
user@computer: /usr/bin/openssl s_client -connect somesite.com:8443
CONNECTED(00000003)
write:errno=54

But openssl 1.0.2 are working with it:

user@computer: openssl version         
OpenSSL 1.0.2d 9 Jul 2015
user@computer: openssl s_client -connect somesite.com:8443
CONNECTED(00000003)
depth=2 C = US, O = "blah-blah" ...
....

I'm using MAMP as a local server. phpinfo: phpinfo

How change openssl version in MAMP? I know, that this question is duplicate, but I really need help.

drn34916
drn34916 哦!谢谢!
4 年多之前 回复
doufeng3602
doufeng3602 好的...对不起如果您还不知道,我可以建议您使用最新版本的AMPPS,其中包含apache2.4和openssl的升级版本...请参阅我的帖子:apple.stackexchange.com/questions/206901/...
4 年多之前 回复
doutian3269
doutian3269 不,我没有。
4 年多之前 回复
douzi0609
douzi0609 你找到了解决方案吗?如果有,你能和我分享一下吗?我也需要使用tls1.2(因为ios9)...
4 年多之前 回复
doumen5895
doumen5895 我不使用mac,mamp和所有这些东西,但考虑到如果你需要openssl1.0而停止使用mamp,即使对于当前的PHP版本它们仍然提供0.9。例如,用于Windows的PHP5.5+随openssl1.0一起提供。我相信您可以从其他来源安装PHP或将开发环境安装到虚拟机。作为PHP开发人员,您应该能够从头开始安装基本的开发环境。
4 年多之前 回复

4个回答

I have asked this question to developers MAMP & MAMP PRO. Here's what they said:

MAMP (PRO) 3.x does NOT bundle OpenSSL software but uses what comes bundled with Mac OS. If you update OpenSSL in Mac OS, MAMP (PRO) should automatically use the updated version. We will be including the latest OpenSSL in our future MAMP 4 release, which will be available soon. This will be a paid update.


UPD From comments (thanks to @lukemh):

PHP CURL fails on Cloudflare or SSLv3 sites using MAMP 3.5 due to old OpenSSL version

duanfu1942
duanfu1942 不:他们通常会重命名旧的MAMP,他们永远不会删除。
3 年多之前 回复
dongyi8383
dongyi8383 只是关于MAMP 4.0的警告。 我刚刚安装了预发行版4,它完全删除了htdocs文件夹下的所有网站。 一切都消失了。 谢天谢地,我做了一个备份。 小心。
接近 4 年之前 回复
dro7152
dro7152 这是相关的:coreyolson.com/2016/02/14 / ...
4 年多之前 回复
duannaiying9662
duannaiying9662 这事有进一步更新吗 ? 我遇到了同样的问题
4 年多之前 回复
dongqi8030
dongqi8030 好的,我会写他们要求热解决这个问题并让你知道;)
4 年多之前 回复
dongqian6234
dongqian6234 我有同样的问题=(
4 年多之前 回复
doucheng7808
doucheng7808 support@appsolute.zendesk.com
4 年多之前 回复
dongliang1996
dongliang1996 你能告诉我他们的电子邮件吗? 我也想写它们
4 年多之前 回复
dpx49470
dpx49470 这些都是好消息,但我担心他们会取笑我们,因为我用El Capitan在我的MacBook Pro上更新了OpenSLL并遵循这个答案(stackoverflow.com/questions/34518502 / ...)我还更新了新openssl的链接 二进制文件...(/ usr / bin / openssl)但它没有用... mamp和apache仍然使用0.9.8 ...... :(
4 年多之前 回复



截至2016年7月21日,有一个预发布的MAMP PRO 4,其中包括OpenSSL 1.0.2,获取前 - 请在这里:</ p>

https:// www。 mamp.info/en/pre-release.html </ p>
</ div>

展开原文

原文

As of July 21, 2016, there is a pre-release available of MAMP PRO 4 which includes OpenSSL 1.0.2, get the pre-release here:

https://www.mamp.info/en/pre-release.html

I recompiled libcurl MAMP is using. It works for me now :)

So, let's do the following:

  1. Run /Applications/MAMP/Library/bin/curl-config --version to see which version you've got
  2. Go to http://curl.haxx.se/download/ and download the right version
  3. Configure it with ./configure --prefix=/Applications/MAMP/Library/
  4. make && make install

Source: http://dev.soup.io/post/56438473/If-youre-using-MAMP-and-doing-something

douzhang3822
douzhang3822 这对我有用。 这是一个易于遵循的指南:grasmash.com/article/using-httpsssl-mamps-curl-osx对于MAMP,您可以将php.ini行删除到您正在运行的PHP版本的php.ini中,即Applications / MAMP /bin/php/php7.0.0/conf/php.ini
3 年多之前 回复
dtp0760
dtp0760 好的,现在我已经“卷曲7.49.1(x86_64-apple-darwin15.5.0)libcurl / 7.49.1 OpenSSL / 1.0.2h zlib / 1.2.5 librtmp / 2.3”但在PHP中仍然没有TLS 1.2 - 例如file_get_contents,例如 在内部使用libcurl?
大约 4 年之前 回复
donglinli2027
donglinli2027 -bash:./ configure:没有这样的文件或目录
大约 4 年之前 回复
dqd2800
dqd2800 嗨Fran,我需要添加--with-ssl = / usr / local / Cellar / openssl / 1.0.2c来配置使用自制软件安装的openssl版本,否则它仍然使用macos提供的版本。
大约 4 年之前 回复
doukeng1922
doukeng1922 - 这一开始工作得很好,但现在我在libcurl中不支持或禁用协议“https”。 显然它应该配置--with-ssl,但是它找不到openssl文件并且配置失败。
大约 4 年之前 回复



如果您希望继续使用MAMP版本3,您还可以执行以下操作以使其正常工作:</ p>
\ n


  1. 将当前版本的MAMP重命名为MAMPv3 </ li>
  2. 下载MAMP版本4,下载后重命名为MAMPv4 </ li>
  3. 将MAMPv3重命名为 只是简单的旧MAMP </ li>
  4. 返回MAMPv4并进入“Library”目录并复制名为“OpenSSL”的文件夹</ li>
  5. 将此文件夹移至旧版本 MAMP和重启服务器。 为我工作!</ li>
    </ ol>
    </ div>

展开原文

原文

If you wish to continue using MAMP version 3 you could also do the following to get it to work:

  1. Rename your current version of MAMP to MAMPv3
  2. Download MAMP version 4 and once downloaded rename it to MAMPv4
  3. Rename MAMPv3 back to just plain old MAMP
  4. Go back into MAMPv4 and head into the "Library" directory and copy the folder inside called "OpenSSL"
  5. Move this folder into your older version of MAMP and reboot servers. Worked for me!

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问