DeinServerläuftmitder PHP-Version 4.4.9,aber WordPress3.9.1benötigtmindestensdie 5.2.4 [关闭]

wordpress安装的php版本在服务器上是错误的(web.de)。
提供者(web) .de)我找不到任何改变php版本的可能性。</ p>
</ div>

展开原文

原文

The php version for the wordpress installation is wrong on the server (web.de). At the provider (web.de) i can't find any possibility to change the php version.

doujiayuan8415
doujiayuan8415 除了一个例外,所有在这里评论或回答的用户都是德语:-P
大约 6 年之前 回复
dongsechuan0535
dongsechuan0535 奇怪的是没有人抱怨德国头衔....所以我必须这样做:只有英文!
大约 6 年之前 回复
douyan2470
douyan2470 您一定要联系您的提供商,看看他们的支持建议和解决问题的方法。
大约 6 年之前 回复
doukuilian8365
doukuilian8365 这个问题似乎是偏离主题的,因为我们无法为提供商提供支持。
大约 6 年之前 回复
doudi8231
doudi8231 联系web.de.我们不是web.de支持。他们必须提供比4.4更新的版本。
大约 6 年之前 回复
dongshi9489
dongshi9489 联系web.de.
大约 6 年之前 回复
dt888999
dt888999 你可能是互联网上最尴尬的人。2014年的PHP4.4,真的很老兄?这个版本已有10年以上的历史。
大约 6 年之前 回复

1个回答

Your problem is that by default, web.de uses PHP4 to interpret .php files. PHP5 is installed, you can try by adding three files:

  • test.php5 with content <?php phpinfo() ?>
  • test.php4 with content <?php phpinfo() ?>
  • test.php with content <?php phpinfo() ?>

Calling them all from your browser, you will find out that .php and .php4 are interpreted using php 4, while .php5 is interpreted using php 5!

You can change this behaviour by adding a .htaccess file to your wordpress directory with the following content:

Type application/x-httpd-php5 .php
duan0417
duan0417 只需很小的(或大的)运气就可以获得stackoverflow.com/help/badges/95/reversal;)
大约 6 年之前 回复
douhao2011
douhao2011 顺便说一句:是否有正确回答有5个或更多downvotes的问题的特殊徽章? ;)
大约 6 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问