dongza1708
2015-05-22 07:10
浏览 266
已采纳

“与远程接口拒绝的连接”使用PDO连接到Firebird 3

Try code below, but cause exception - SQLSTATE[HY000] [335544421] connection rejected by remote interface:

try {
    $dbh = new PDO("firebird:dbname=localhost/3050:empty", "SYSDBA", "masterkey");
    $dbh->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
    $sth = $dbh->query('SELECT idmspos, idmsqnt, cdmsval from svc$dms'); 
    $sth->setFetchMode(PDO::FETCH_ASSOC); 

    while($row = $sth->fetch()) {  
        echo $row['idmspos']." ".$row['idmsqnt']." ".$row['cdmsval']."<br>";  
    }

    $dbh = null;
}
catch(PDOException $e) {
    $dbh = null;
    echo $e->getMessage();
}

Specs:

Linux 3.2.0-4-686-pae #1 SMP Debian 3.2.65-1+deb7u1 i686 GNU/Linux
PHP 5.6
php5-interbase
Firebird 3 from official site. Server is worked, can connect to him from local and remote machine.
  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • doujin8673 2015-05-22 13:00
    已采纳

    Find firebird.conf, uncomment (if using fbclient 2.x) and change the following parameters to disable WireCrypt and set higher priority for legacy authentication:

    WireCrypt = Disabled
    AuthServer = Legacy_Auth, Srp, Win_Sspi
    AuthClient = Legacy_Auth, Srp, Win_Sspi
    
    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • duanjia1870 2017-01-21 12:17

    You need to change the Firebird service as follows:

    1. Install Firebird
    2. Go search Services-> Firebird
    3. Right click on Firebird->Properties-> LogOn-> and tick checkbox having option as "Allows services to interact with Desktop"
    4. and then click on Restart service

      You are now able to connect with firebird successfully in case of Firebird 2.1.

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题