dongxiang3205
2016-06-24 13:02
浏览 148
已采纳

如何让Nginx使用替代PHP版本?

I have an Ubuntu web server running Nginx. I was runngin PHP 5.5.30 and I installed PHP 5.6.23 using the following commands:

1) sudo apt-add-repository ppa:ondrej/php
2) sudo apt-get update
3) sudo apt-get install php5.6

The installation is under a new path from the previous verison of PHP (/etc/php/5.6/). When I run a phpinfo() command from a web page I still get it running under the old version of PHP (5.5.30) - how do I get Nginx looking at the new installation?

p.s. When I run php --version from the command line it show PHP 5.6.23 ! p.p.s My nginx.conf file contains fastcgi_pass unix:/run/php/php5.6-fpm.sock;

图片转代码服务由CSDN问答提供 功能建议

我有一个运行Nginx的Ubuntu Web服务器。 我运行PHP 5.5.30并使用以下命令安装PHP 5.6.23:

  1)sudo apt-add-repository ppa:ondrej / php 
2)sudo  apt-get update 
3)sudo apt-get install php5.6 
   
 
 

安装在以前的PHP版本的新路径下(/ etc / php) /5.6/)。 当我从网页运行phpinfo()命令时,我仍然可以在旧版本的PHP(5.5.30)下运行它 - 如何让Nginx查看新安装?

PS 当我从命令行运行php --version时,它显示PHP 5.6.23! p.ps我的nginx.conf文件包含 fastcgi_pass unix:/run/php/php5.6-fpm.sock;

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • douhanshu5517 2017-06-24 15:16
    已采纳

    I have the same problem. You forgot to change the default sockets from fastcgi_pass unix:/var/run/php-fpm/php-fpm.sock; to fastcgi_pass unix:/var/run/php/php5.6-fpm.sock; - you can find the configuration file at /etc/nginx/sites-available/default.

    Before:

    fastcgi_pass unix:/var/run/php-fpm/php-fpm.sock;
    

    After:

    fastcgi_pass unix:/run/php/php5.6-fpm.sock;
    
    已采纳该答案
    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题