dongzhao5970 2017-01-04 20:26
浏览 106
已采纳

已安装PHP intl扩展,但CakePHP安装表示它已丢失

For over a day I have been trying to start a CakePHP 3 project. When I run the composer install command, I get the following error:

cakephp/cakephp 3.3.x requires ext-intl * -> the requested PHP extension intl is missing from your system.

I am using MacOS Sierra 10.12.2. XCode and all that jazz are fully up-to-date. I am running PHP 5.6.25 via MAMP Pro 4.0.1 (3985). And I am trying to install CakePHP 3.3.x through my terminal, which is using ZSH instead of Bash.

I've spent quite a while trying to get intl installed. And by now I'm pretty confident that it is indeed installed:

  1. When I run php -m I see intl in the list of PHP modules.
  2. I have extension=intl.so in my php.ini, located in /Applications/MAMP/bin/php/php5.6.25/conf/php.ini.
  3. The file intl.so is located in the directory /Applications/MAMP/bin/php/php5.6.25/lib/php/extensions/no-debug-non-zts-20131226.
  4. On MAMP's phpinfo page I can see '--enable-intl' in the Configure Command cell. Further down the page, it has its own table, showing that internationalization is supported with version 1.1.0. However, in this table, for the row intl.default_locale the value is no value. Could this be my problem?
  5. In my ~/.zshrc file I have alias php="/Applications/MAMP/bin/php/php5.6.25/bin/php" so I can be sure I'm using the correct version and installation of PHP.

I hope I haven't ruined anything by trying to use so many articles and StackOverflow answers to get this working. I know there are a number of similar intl questions here, but so far I've had no luck with any answers.

So I suppose here are my two main questions:

  1. Is the evidence I listed above enough to suggest I truly have the intl extension correctly installed, and why does CakePHP still complain about the extension being missed if it is correctly installed?
  2. If it is not correctly installed, how can I correct this and get CakePHP to install?

Thank you!

  • 写回答

2条回答 默认 最新

  • dongpo7467 2017-01-05 17:03
    关注

    Thank you to everyone who lent a hand in the comments. But a special thank you to Aman Rawat for pointing me to this answer. I've read through that thread a number of times, but apparently overlooked it.

    I added export PATH="/Applications/MAMP/bin/php/php5.6.25/bin:$PATH" to ~/.zshrc.

    I was then able to install CakePHP via composer.\

    I assumed I had MAMP's PHP in my path. I had it as an alias, so php in terminal would correctly point to MAMP's PHP install, but it turns out that PHP was never actually in my PATH.

    Oops!

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

悬赏问题

  • ¥15 调用函数时,无关变量的改变引起函数值的改变
  • ¥15 xy坐标转化为经纬度坐标
  • ¥15 一般三角模糊数的上界值和下届值取中值的多少比较合理?
  • ¥15 关于#python#的问题,请各位专家解答!
  • ¥20 Hbase启动失败,无法启动HMaster
  • ¥15 sqpingboot在父模块已经引入了mybatisplus 在子组件不写版本号还是报错
  • ¥20 Lumerical FDTD solutions 中模型的相对阻抗,有效介电常数和有效磁导率的实部和虚部的数据如何获得?
  • ¥100 sql reporting service 远程smtp服务器配置支持
  • ¥15 ppyoloe_r带角度目标检测,loss_cls没法收敛
  • ¥15 淘宝交易指数如何解读,其关联的数据指标是什么