douluogu8713
2011-02-15 04:36
浏览 69
已采纳

在Fedora 8上安装php-devel的问题(运行PHP 5.2.14)

I'm trying to install php-devel, but getting a dependency error:

Error: Missing Dependency: php = 5.2.4-3 is needed by package php-devel

I googled around a bit but couldn't find anything too useful. Anybody seen this before? I'm sure I just need to manually yum install something but I'm not that versed with yum.

Here's the full deal:

[peter@akebono xdebug]$ cat /proc/version Linux version 2.6.23.1-42.fc8 (kojibuilder@xenbuilder2.fedora.redhat.com) (gcc version 4.1.2 20070925 (Red Hat 4.1.2-33)) #1 SMP Tue Oct 30 13:18:33 EDT 2007

[peter@akebono xdebug]$ php --version PHP Warning: Module 'mysqli' already loaded in Unknown on line 0 PHP 5.2.6 (cli) (built: May 8 2008 08:54:23) Copyright (c) 1997-2008 The PHP Group Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies with Zend Debugger v5.2.14, Copyright (c) 1999-2008, by Zend Technologies

[peter@akebono xdebug]$ sudo yum install php-devel Password: Repository development is listed more than once in the configuration Repository development-debuginfo is listed more than once in the configuration Repository development-source is listed more than once in the configuration Setting up Install Process Parsing package install arguments Resolving Dependencies --> Running transaction check ---> Package php-devel.i386 0:5.2.4-3 set to be updated --> Processing Dependency: php = 5.2.4-3 for package: php-devel ---> Package php-devel.x86_64 0:5.2.6-2.fc8 set to be updated --> Finished Dependency Resolution Error: Missing Dependency: php = 5.2.4-3 is needed by package php-devel

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dongyao4003 2011-02-16 15:08
    已采纳

    Note that Fedora 8 stopped being supported over a year ago, so you are almost certainly better off migrating to a newer version of Fedora (Fedora 14 at this point) or moving to RHEL if you want something that changes less frequently.

    已采纳该答案
    打赏 评论

相关推荐 更多相似问题