坚持安装php7.0-zip扩展

Im trying to install the extension php7.0-zip (using Ubuntu 16.04), im getting the following message:

The following packages have unmet dependencies:
php7.0-zip : Depends: libzip2 (>= 0.11.2) but 0.10.1-1.2 is to be installed

this is my php version:

PHP 7.0.28-1~dotdeb+8.1 (cli) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
with Zend OPcache v7.0.28-1~dotdeb+8.1, Copyright (c) 1999-2017, by Zend Technologies

i tried to run sudo apt-get update, purgue and reinstall libzip2 but the newer version is 0.10.1-1.2 libzip2 is already the newest version (0.10.1-1.2).

I don't have a clue of what to do, plz help

php

1个回答



libzip4:i386是一个32位软件包。 与64位版本冲突。 您使用的是32位计算机吗?</ p>

如果您使用的是64位,请执行:
sudo apt-get purge libzip4 </ p>

然后: </ p>

  sudo apt-get install php-zip 
</ code> </ pre>

如果您使用的是32位:</ p>

  sudo apt-get install php-zip:i386 
</ code> </ pre>
</ div>

展开原文

原文

libzip4:i386 is a 32-bit package. and conflicts with 64-bit version. are you using a 32-bit computer?

if you are using 64-bit then do: sudo apt-get purge libzip4

then:

sudo apt-get install php-zip

if you are using 32-bit then:

sudo apt-get install php-zip:i386

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐