2 chen875351636 chen875351636 于 2015.06.04 11:42 提问

关于用eclipse做gwt开发时,应用启动后,eclipse报错

Could not stop source viewer server.
java.lang.ExceptionInInitializerError
at com.google.gdt.eclipse.platform.jetty.JettyServer.initLogging(JettyServer.java:40)
at com.google.gdt.eclipse.platform.jetty.JettyServer.(JettyServer.java:30)
at com.google.gwt.eclipse.core.GWTPlugin.stop(GWTPlugin.java:147)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:771)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.stop(BundleContextImpl.java:764)
at org.eclipse.osgi.framework.internal.core.BundleHost.stopWorker(BundleHost.java:510)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.suspend(AbstractBundle.java:566)
at org.eclipse.osgi.framework.internal.core.Framework.suspendBundle(Framework.java:1206)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.decFWSL(StartLevelManager.java:592)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:257)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.shutdown(StartLevelManager.java:215)
at org.eclipse.osgi.framework.internal.core.InternalSystemBundle.suspend(InternalSystemBundle.java:284)
at org.eclipse.osgi.framework.internal.core.Framework.shutdown(Framework.java:692)
at org.eclipse.osgi.framework.internal.core.Framework.close(Framework.java:600)
at org.eclipse.core.runtime.adaptor.EclipseStarter.shutdown(EclipseStarter.java:400)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:200)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
at org.eclipse.equinox.launcher.Main.main(Main.java:1426)
Caused by: java.lang.IllegalArgumentException: Logging bundle must not be null.
at org.eclipse.core.internal.runtime.Log.(Log.java:30)
at org.eclipse.core.internal.runtime.InternalPlatform.getLog(InternalPlatform.java:356)
at org.eclipse.core.runtime.Platform.getLog(Platform.java:1001)
at com.google.gdt.eclipse.platform.jetty.JettyEclipseLogger.(JettyEclipseLogger.java:35)
... 25 more
有没有人遇到过这样的错误。
所有的配置跟其他同事的都一样。eclipse版本是4.3。集成的也是对应版本的gwt插件4.3

3个回答

sinat_27985725
sinat_27985725   2015.06.04 12:15

好高端。学习了,我遇到也没解决

pop32399
pop32399   2015.06.04 12:54

这个问题问得好,不太好回答

chen875351636
chen875351636   2015.06.04 14:32

不要沉啊。有没有大大来解答下

Csdn user default icon
上传中...
上传图片
插入图片