2 plantago Plantago 于 2016.02.16 10:37 提问

使用HttpClient访问网络

使用HttpClient访问网络
清单文件 android:minSdkVersion="14"
android:targetSdkVersion="19" />
出错

android:minSdkVersion="9"
/>
就没错。请问是什么问题

4个回答

bdmh
bdmh   Ds   Rxr 2016.02.16 10:41
已采纳

从11开始,就不允许和在主线程中请求了

Plantago
Plantago 哦,原来如此,谢谢
接近 2 年之前 回复
wangzhiyu1980
wangzhiyu1980   2016.02.16 10:54

关于这个异常可以定义一个线程,把http请求的部分放在线程里去做。

bdmh
bdmh   Ds   Rxr 2016.02.16 10:38

出什么错,高版本http请求需要写在异步里面

Plantago
Plantago   2016.02.16 10:44

图片说明

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!