2 cassie 2016 Cassie_2016 于 2016.03.10 23:13 提问

eclipse删除后重新安装时出错

具体错误提示如下:
[2016-03-10 23:07:32] Executing bootstrap tasks
[2016-03-10 23:07:32] Product org.eclipse.products.epp.package.java.mars
[2016-03-10 23:07:32] Bundle org.eclipse.oomph.setup 1.3.0.v20160213-0953, build=2199, branch=7194e06d06a87ced95779121a8281b59b9abdf81, commit=7194e06d06a87ced95779121a8281b59b9abdf81
[2016-03-10 23:07:32] Bundle org.eclipse.oomph.setup.core 1.3.0.v20160213-0953, build=2199, branch=7194e06d06a87ced95779121a8281b59b9abdf81, commit=7194e06d06a87ced95779121a8281b59b9abdf81
[2016-03-10 23:07:32] Bundle org.eclipse.oomph.setup.p2 1.3.0.v20160213-0953, build=2199, branch=7194e06d06a87ced95779121a8281b59b9abdf81, commit=7194e06d06a87ced95779121a8281b59b9abdf81
[2016-03-10 23:07:32] Performing P2 Director (Eclipse IDE for Java Developers (Mars))
[2016-03-10 23:07:32] Offline = false
[2016-03-10 23:07:32] Mirrors = true
[2016-03-10 23:07:32] Resolving 5 requirements from 3 repositories to C:\Users\Cassie_\eclipse\java-mars2\eclipse
[2016-03-10 23:07:32] Requirement epp.package.java [4.5.0,4.6.0)
[2016-03-10 23:07:32] Requirement org.eclipse.platform.feature.group [4.5.0,4.6.0)
[2016-03-10 23:07:32] Requirement org.eclipse.rcp.feature.group [4.5.0,4.6.0)
[2016-03-10 23:07:32] Requirement org.eclipse.jdt.feature.group [3.11.0,3.12.0)
[2016-03-10 23:07:32] Requirement org.eclipse.oomph.setup.feature.group
[2016-03-10 23:07:32] Repository http://download.eclipse.org/technology/epp/packages/mars
[2016-03-10 23:07:32] Repository http://download.eclipse.org/releases/mars/201602261000
[2016-03-10 23:07:32] Repository http://download.eclipse.org/oomph/updates/milestone/latest
[2016-03-10 23:11:08] ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 Unable to read repository at http://download.eclipse.org/releases/mars/201602261000/content.xml.xz.
java.net.SocketException: Connection reset
at java.net.SocketInputStream.read(Unknown Source)
at java.net.SocketInputStream.read(Unknown Source)
at org.apache.http.impl.io.AbstractSessionInputBuffer.read(AbstractSessionInputBuffer.java:198)
at org.apache.http.impl.io.ContentLengthInputStream.read(ContentLengthInputStream.java:178)
at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:137)
at java.io.FilterInputStream.read(Unknown Source)
at java.net.SocketInputStream.read(Unknown Source)
at org.apache.http.impl.io.AbstractSessionInputBuffer.read(AbstractSessionInputBuffer.java:198)
at org.apache.http.impl.io.ContentLengthInputStream.read(ContentLengthInputStream.java:178)
at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:137)
at java.io.FilterInputStream.read(Unknown Source)
at java.io.FilterInputStream.read(Unknown Source)
at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer$1.performFileTransfer(AbstractRetrieveFileTransfer.java:178)
at org.eclipse.ecf.filetransfer.FileTransferJob.run(FileTransferJob.java:73)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

[2016-03-10 23:11:08]
就是这样的,求大神帮忙,要开始写作业了啊!!

PS:就是直接又下了一个Eclipse,然后运行.exe文件的时候,出错了。打不开。

8个回答

u010339179
u010339179   2016.03.11 10:01
已采纳

eclipse 不需要安装的,解压之后直接运行.exe文件就行了。去官网下载 www.eclipse.org

wojiushiwo945you
wojiushiwo945you   Ds   Rxr 2016.03.11 08:00

Eclipse不需要安装啊,直接删除原来的文件夹,放个新的Eclipse就好了吧。

wen_wxpk
wen_wxpk   2016.03.11 08:10

楼上正解,不需要安装的,去网上下另外一个版本

qq_20039385
qq_20039385   2016.03.11 09:01

搞个解压版的,解压好了直接运行

tangys623656350
tangys623656350   2016.03.11 09:58

检查一下你的环境变量

dongfeng9ge
dongfeng9ge   Ds   Rxr 2016.03.11 10:24

eclipse是不需要安装的

devmiao
devmiao   Ds   Rxr 2016.03.11 00:50
devmiao
devmiao   Ds   Rxr 2016.03.11 00:49
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!