明知道这是一场意外 2016-03-13 08:17 采纳率: 66.7%
浏览 1465
已采纳

ACM的小伙伴进,uva-1584有些小问题求大神解惑

Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence CGAGTCAGCT", that is, the last symbolT" in CGAGTCAGCT" is connected to the first symbolC". We always read a circular sequence in the clockwise direction.

\epsfbox{p3225.eps}
Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence.

Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is ``AGCTCGAGTC". If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).

Input

The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, A, C, G and T, are allowed. Each sequence has length at least 2 and at most 100.

Output

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.

The following shows sample input and output for two test cases.

Sample Input

2

CGAGTCAGCT

CTCC
Sample Output

AGCTCGAGTC
CCCT

我的代码如下

#include <iostream>
#include <cstring>
using namespace std;
int small(const char* s,int p,int q);
#define maxn 105
int main()
{
    int n;//测试数
    cin>>n;
    while(n--){
        //为何不能用char *str={0};?
        char str[maxn];
        cin>>str;
        int len=strlen(str);
        int ans=0;
        for(int i=1;i<len;i++){
            if(small(str,i,ans))
                ans=i;
        }
        for(int i=0;i<len;i++){
            putchar(str[(ans+i)%len]);
        }
        putchar('\n');
    }
    return 0;

}

int small(const char* s,int p,int q){  //比较表示法p和表示法q字典序大小
    int n=strlen(s);
    for(int i=0;i<n;i++){
        if(s[(p+i)%n]!=s[(q+i)%n])
            return s[(p+i)%n]<s[(q+i)%n];
    }
    return 0;


}


问题疑惑在注释里,如果用注释里的会报空指针错误( returned -1073741819 (0xC0000005))问的问题很小白,让各位见笑了囧。

  • 写回答

1条回答 默认 最新

  • 林深 2016-03-13 09:37
    关注
     char *str={0};
      cin>>str;
    

    这样写,你如何让机器知道str的大小?要知道下面还有输入语句cin的呀,cin会根据str的大小来选择性输入的,所以你这样写当然会报错。
    你可以改成下面这样,指定str的大小,然后再输入的话就没问题了

     char *str = new char[maxn];
     cin>>str;
    
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥15 thinkphp6配合social login单点登录问题
  • ¥15 HFSS 中的 H 场图与 MATLAB 中绘制的 B1 场 部分对应不上
  • ¥15 如何在scanpy上做差异基因和通路富集?
  • ¥20 关于#硬件工程#的问题,请各位专家解答!
  • ¥15 关于#matlab#的问题:期望的系统闭环传递函数为G(s)=wn^2/s^2+2¢wn+wn^2阻尼系数¢=0.707,使系统具有较小的超调量
  • ¥15 FLUENT如何实现在堆积颗粒的上表面加载高斯热源
  • ¥30 截图中的mathematics程序转换成matlab
  • ¥15 动力学代码报错,维度不匹配
  • ¥15 Power query添加列问题
  • ¥50 Kubernetes&Fission&Eleasticsearch