2 xjingweiu XjingweiU 于 2016.09.11 11:56 提问

出现Unable to satisfy the following requirements:

之前正常运行的项目今天打开运行出现库引用失败的问题,于是便pod insatll,但是又是各种下列问题,写上SDK的版本好也不好用。
✗ pod install

Analyzing dependencies
[!] The version of CocoaPods used to generate the lockfile (1.1.0.beta.1) is higher than the version of the current executable (1.0.1). Incompatibility issues may arise.
[!] Unable to satisfy the following requirements:

  • AFNetworking required by Podfile
  • AFNetworking (= 3.1.0) required by Podfile.lock

Specs satisfying the AFNetworking, AFNetworking (= 3.1.0) dependency were found, but they required a higher minimum deployment target.

2个回答

XjingweiU
XjingweiU   2016.09.11 12:00
已采纳

于是乎便Google出了这个http://blog.csdn.net/l2i2j2/article/details/51184386
按此修改后,再pod install就好了

XjingweiU
XjingweiU   2016.09.11 12:03

图片说明
添加上platform :ios, '8.0',重新安装即解决问题

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!