2 ffffatass Ffffatass 于 2016.09.23 11:00 提问

Struts2的配置问题,Tomcat加载就报错

![![![![图片说明](http://img.ask.csdn.net/upload/201609/23/1474599459_447497.png)图片说明](http://img.ask.csdn.net/upload/201609/23/1474599450_937679.png)图片说明](http://img.ask.csdn.net/upload/201609/23/1474599440_107426.png)图片说明](http://img.ask.csdn.net/upload/201609/23/1474599426_516941.png)图片说明

6个回答

Ffffatass
Ffffatass   2016.09.23 10:59

Jar包和XML应该都是正常的

<?xml version="1.0" encoding="UTF-8"?>
xmlns="http://java.sun.com/xml/ns/javaee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">


index.jsp


struts2
org.apache.struts2.dispatcher.FilterDispatcher


struts2
/*

u013076997
u013076997   2016.09.23 11:02

从报错内容来看是spring的一个jar包没有引入吧

Ffffatass
Ffffatass   2016.09.23 10:59


struts2
org.apache.struts2.dispatcher.FilterDispatcher


struts2
/*

Ffffatass
Ffffatass   2016.09.23 11:04

我把所有包引入还是会报错
严重: Exception starting filter struts2
Unable to load configuration. - bean - jar:file:/C:/Program%20Files/Apache%20Software%20Foundation/Tomcat%207.0/webapps/web/WEB-INF/lib/struts2-codebehind-plugin-2.3.30.jar!/struts-plugin.xml:29:122

qq_27905183
qq_27905183   2016.09.23 11:45

貌似是导入的包和Struts当前版本不匹配

Ffffatass
Ffffatass 什么意思?我导入的包就是下载版本里的包
大约一年之前 回复
cs1075341779
cs1075341779   2016.09.23 11:46

报错显示的是spring-context包未找到或者冲突

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!