编程介的小学生 2017-05-30 05:07 采纳率: 20.5%
浏览 842
已采纳

Has the sum exceeded

Problem Description
As we all know, in the computer science, an integer A is in the range of 32-signed integer, which means the integer A is between -2^31 and (2^31)-1 (inclusive), and A is a 64-signed integer, which means A is between -2^63 and (2^63)-1(inclusive). Now we give the K-signed range, and two K-signed integers A and B, you should check whether the sum of A and B is beyond the range of K-signed integer or not.

Input
There will be many cases to calculate. In each case, there comes the integer K (2<=K<=64) first in a single line. Then following the line, there is another single line which has two K-signed integers A and B.

Output
For each case, you should estimate whether the sum is beyond the range. If exceeded, print “Yes”, otherwise “WaHaHa”.

Sample Input
32
100 100

Sample Output
WaHaHa

  • 写回答

2条回答 默认 最新

  • SuperKilling 2017-05-30 08:32
    关注

    #include "stdafx.h"
    #include "iostream"

    using namespace std;

    int main()
    {
    int k = 0;
    long int A = 0, B = 0;
    double Sum = 0.0;

    //input k , A and B
    cin >> k;
    cin >> A;
    cin >> B;

    if (k < 2 || k > 64)
    {
        cout << "k is not in [2, 64]"<<endl;
        return   0;
    }
    
    Sum = (double)A + (double)B;
    
    if (Sum > pow(2, k) )
    {
        cout << "yes" << endl;
        return   0;
    }
    else
    {
        cout << "WaHaHa" << endl;
        return   0;
    }
    
    return   0;
    

    }

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

悬赏问题

  • ¥15 如何在node.js中或者java中给wav格式的音频编码成sil格式呢
  • ¥15 不小心不正规的开发公司导致不给我们y码,
  • ¥15 我的代码无法在vc++中运行呀,错误很多
  • ¥50 求一个win系统下运行的可自动抓取arm64架构deb安装包和其依赖包的软件。
  • ¥60 fail to initialize keyboard hotkeys through kernel.0000000000
  • ¥30 ppOCRLabel导出识别结果失败
  • ¥15 Centos7 / PETGEM
  • ¥15 csmar数据进行spss描述性统计分析
  • ¥15 各位请问平行检验趋势图这样要怎么调整?说标准差差异太大了
  • ¥15 delphi webbrowser组件网页下拉菜单自动选择问题