2 annbnncnnd AnnBnnCnnD 于 2012.11.23 11:08 提问

Eclipse中安卓工程怎么修复

从别的电脑里下了我的工程,然后导入到Eclipse里面,然后出问题了。

我已经在project菜单里清空了project,然后在工具栏里面修复工程属性,但是还是出现错误。

错误提示:

Problems occurred when invoking code from plug-in: "org.eclipse.core.resources".

Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.

修复工程属性也不好使。是不是路径的问题啊?

感谢帮忙。

2个回答

ce_la_vie
ce_la_vie   2012.11.23 11:44
已采纳

右键点击工程,选择Properties -> Java Compiler,然后选择Enable project specific settings
再从Compiler compliance settings选择框里选1.6 或者1.7就行了。

AnnBnnCnnD
AnnBnnCnnD 谢谢,果然是这样
大约 5 年之前 回复
huweilong1030
huweilong1030   2012.11.23 14:27

Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead

其实错误提示很明显了,因为编译器的版本不对,如楼上所说,改一下版本应该就行了。

AnnBnnCnnD
AnnBnnCnnD 果然是这样
大约 5 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!